OpenStack Dashboard (Horizon)

Can not display usage data for Quota Summary

Reported by Kylin CG on 2012-09-25
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Undecided
Kylin CG
Folsom
High
Sam Morrison
ubuntu-cloud-archive
Undecided
Unassigned
horizon (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

No data display on Quota Summary (overview page).
1. All components are got from github(master).
2. Quotas data display properly when i launch a instance from Intance page.

Kylin CG (kylin7-sg) on 2012-09-25
Changed in horizon:
assignee: nobody → Kylin CG (kylin7-sg)
Gabriel Hurley (gabriel-hurley) wrote :

There isn't anywhere near enough information here to diagnose this issue. Basic information would include:

  1. What version of OpenStack are you using?
  2. How did you install it? (e.g. DevStack, Ubuntu distribution, etc.)
  3. What services are you running?
  4. Is Nova working properly?

And so on...

Changed in horizon:
status: New → Incomplete
Kylin CG (kylin7-sg) on 2012-09-26
description: updated
description: updated
Sam Morrison (sorrison) wrote :

Just to update with more details.

The bars on the overview page show no usage, they work on the launch instances page.
It will always say eg. Used of Available Instances

This is due to a simple template bug. We'll be putting in a Gerrit review shortly

Changed in horizon:
status: Incomplete → Confirmed

Fix proposed to branch: master
Review: https://review.openstack.org/14379

Changed in horizon:
status: Confirmed → In Progress
Sam Morrison (sorrison) on 2012-10-12
tags: added: folsom-backport-potential

Reviewed: https://review.openstack.org/14379
Committed: http://github.com/openstack/horizon/commit/5eac426a2a1304b166f85cd68086a1b1abeafd23
Submitter: Jenkins
Branch: master

commit 5eac426a2a1304b166f85cd68086a1b1abeafd23
Author: Kylin CG <email address hidden>
Date: Fri Oct 12 17:04:40 2012 +0800

    Fix bug 1055929 - Can not display usage data for Quota Summary.

    Change-Id: I051e97f14375714d22303ad44a9f0b16aa7d6c51

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-11-22
Changed in horizon:
milestone: none → grizzly-1
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

shankao (shankao) wrote :

Assigning to ubuntu package

affects: ubuntu → openstack-dashboard (Ubuntu)
Changed in openstack-dashboard (Ubuntu):
status: New → Confirmed

Reviewed: https://review.openstack.org/17030
Committed: http://github.com/openstack/horizon/commit/9060885a5661f0c1786dd6feea8f07e45776e410
Submitter: Jenkins
Branch: stable/folsom

commit 9060885a5661f0c1786dd6feea8f07e45776e410
Author: Kylin CG <email address hidden>
Date: Fri Oct 12 17:04:40 2012 +0800

    Fix bug 1055929 - Can not display usage data for Quota Summary.

    Change-Id: I051e97f14375714d22303ad44a9f0b16aa7d6c51

Mark McLoughlin (markmc) on 2013-01-22
tags: removed: folsom-backport-potential
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in openstack-dashboard (Ubuntu):
status: New → Confirmed
Sina Sadeghi (sina-sa) wrote :

Can this fix be pushed to the Ubuntu Cloud Archive? I don't like having to sed this template file every time the package is upgraded.

tags: added: cloud-archive
affects: openstack-dashboard (Ubuntu) → horizon (Ubuntu)
Changed in horizon (Ubuntu):
status: Confirmed → Fix Released
Changed in cloud-archive:
status: New → Confirmed
Changed in horizon (Ubuntu Quantal):
status: New → Confirmed

Hello Kylin, or anyone else affected,

Accepted horizon into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/horizon/2012.2.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in horizon (Ubuntu Quantal):
status: Confirmed → Fix Committed
tags: added: verification-needed
Thierry Carrez (ttx) on 2013-04-04
Changed in horizon:
milestone: grizzly-1 → 2013.1

Please find the attached test log from the Ubuntu Server Team's CI infrastructure. As part of the verification process for this bug, the OpenStack components have been deployed and configured across multiple nodes using quantal-proposed as an installation source. After successful bring-up and configuration of the cluster, a number of exercises and smoke tests have be invoked to ensure the updated package did not introduce any regressions. A number of test iterations were carried out to catch any possible transient errors.

These proposed packages were deployed and tested in several different configurations. Attached are tarballs with various test logs from each configuration. In addition to the base components, variables in deployments include:

quantal_folsom.tar: nova-network (FlatDHCP), glance (Ceph backend), cinder (Ceph backend),
quantal_folsom_nova-volume.tar: nova-network (FlatDHCP), glance (local file), nova-volume (iSCSI backend)
quantal_folsom_quantum.tar: quantum (OVS plugin), glance (Ceph backend), nova-volume (Ceph backend)

Please note the versions_tested file in each tarball, which contains details about relevant package versions installed and tested.

For records of upstream test coverage of this update, please see the Jenkins links in the comments of the relevant upstream code-review(s):

Trunk review: https://review.openstack.org/14379
Stable review: https://review.openstack.org/17030

As per the provisional Micro Release Exception granted to this package by the Technical Board, we hope this contributes toward verification of this update.

Adam Gandelman (gandelman-a) wrote :

Test coverage log.

Adam Gandelman (gandelman-a) wrote :

Test coverage log.

Adam Gandelman (gandelman-a) wrote :

Test coverage log.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 2012.2.3-0ubuntu1

---------------
horizon (2012.2.3-0ubuntu1) quantal-proposed; urgency=low

  * Resynchronize with stable/folsom (f421145b) (LP: #1116671):
    - [20fa0fc] EC2 panel shouldn't be visible when the EC2 service isn't
      enabled LP: 1102411
    - [0b1c553] Server error pages are broken LP: 1067206
    - [476072d] login not possible if not service "volume" defined on keystone
      LP: 1084137
    - [ebc5e6d] Quota tally not handling unlimited values correctly LP: 1084976
    - [e19a218] Unable to set unlimited quotas in Horizon LP: 1082489
    - [2f959c6] The css class td.actions_column's width is not enough
      LP: 1081875
    - [817d628] Revert "Temp fix for api/keystone.py"
    - [9060885] Can not display usage data for Quota Summary (LP: #1055929)
  * debian/static/openstack-dashboard: Recompress static JS and CSS based on
    changes applied upstream in stable/folsom.
 -- Adam Gandelman <email address hidden> Tue, 05 Feb 2013 14:06:12 -0400

Changed in horizon (Ubuntu Quantal):
status: Fix Committed → Fix Released
James Page (james-page) on 2013-10-11
Changed in cloud-archive:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers