node.js is required for access to the dashboard

Bug #1024326 reported by Emilien Macchi on 2012-07-13
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Undecided
Gabriel Hurley
horizon (Ubuntu)
High
Adam Gandelman
Quantal
High
Adam Gandelman

Bug Description

Ubuntu 12.10, Folsom Testing Packages (https://launchpad.net/~openstack-ubuntu-testing/+archive/folsom-trunk-testing).

django_compressor is required tu run the dashboard :

pip install django_compressor

You can get the bug just after apt-get install openstack-dashboard & checking Apache Error log file.

Emilien Macchi (emilienm) wrote :

I think this bug is linked to https://review.openstack.org/#/c/7367/

Maybe I'm wrong...

Emilien Macchi (emilienm) wrote :

Here are the Apache Errors : http://paste.openstack.org/show/19386/

affects: ubuntu → horizon (Ubuntu)
Changed in horizon (Ubuntu):
assignee: nobody → Adam Gandelman (gandelman-a)
Gabriel Hurley (gabriel-hurley) wrote :

Yes, django_compressor is required for use of Horizon without modification. It is the recommended deployment scenario. That said, downstream distros have two options:

1. Add django compressor, node.js and LESS to their packaging requirements,

2. Compile a static stylesheet and link that in the template instead of using compressor, LESS, etc.

Both options are valid, and we'll do what we can to help support both. But either way this isn't a Horizon bug. If there are questions feel free to ask in the "answers" section or on the OpenStack mailing list.

Changed in horizon:
assignee: nobody → Gabriel Hurley (gabriel-hurley)
status: New → Won't Fix
Emilien Macchi (emilienm) wrote :

Thank you Gabriel, I'll follow your advise.

Changed in horizon (Ubuntu):
status: New → In Progress
importance: Undecided → High
summary: - django_compressor is required for access to the dashboard
+ node.js is required for access to the dashboard
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package horizon - 2012.2~rc1-0ubuntu1

---------------
horizon (2012.2~rc1-0ubuntu1) quantal; urgency=low

  [ Adam Gandelman ]
  * debian/patches/ubuntu_local_settings.patch: Squash all patches that
    touch local_settings.py.example into one.
  * Drop node-less dependency (LP: #1024326).
      - debian/static/openstack-dashboard: Pre-compressed and compiled JS, CSS
        and compressor manifest.json.
      - debian/patches/ubuntu_local_settings.patch: Set COMPRESS_OFFLINE=True
        to enable offline compression and pre-compressed static files by
        default.

  [ Chuck Short ]
  * New upstream release
 -- Chuck Short <email address hidden> Wed, 12 Sep 2012 12:21:33 -0500

Changed in horizon (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers