No display of user quotas visible without launching instance

Bug #1018560 reported by Matt Joyce on 2012-06-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Dashboard (Horizon)
Wishlist
Matt Joyce

Bug Description

Current usage summary screen (on overview screen). should include Project Quotas graphs from 'Launch Instance' shadowbox.

description: updated
summary: - No display of user quotas anywhere
+ No display of user quotas visible without launching instance
description: updated
Gabriel Hurley (gabriel-hurley) wrote :

Having this on the project overview screen would be great!

Changed in horizon:
assignee: nobody → Nebula (nebula)
importance: Undecided → Medium
milestone: none → folsom-3
status: New → Confirmed
Gabriel Hurley (gabriel-hurley) wrote :

Deferring this for now since nobody's worked on it and it's a feature request more than a bug. If we can fit it in before Folsom final that's great.

Changed in horizon:
importance: Medium → Low
importance: Low → Wishlist
Changed in horizon:
milestone: folsom-3 → none
Matt Joyce (matt-nycresistor) wrote :

I'll give it a go right now. I have a little breathing room right now and I am giving it some effort. I got a question out to the list about implementation and using usage.base, adding quota info methods there. Hopefully that's okay. If it is I can reuse the code from the launch instance helper template.

Changed in horizon:
assignee: Nebula (nebula) → Matt Joyce (matt-nycresistor)
Matt Joyce (matt-nycresistor) wrote :
Changed in horizon:
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/11441
Committed: http://github.com/openstack/horizon/commit/705aef0ef5b655e471b21cefef04fe3094365992
Submitter: Jenkins
Branch: master

commit 705aef0ef5b655e471b21cefef04fe3094365992
Author: Matt Joyce <email address hidden>
Date: Wed Aug 15 14:54:26 2012 -0700

    Bug #1018560 Adding quota display to Overview template

    Change-Id: I8b7d5070dade4f0caae0ca9794a169cfc15b985f

Changed in horizon:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-08-16
Changed in horizon:
milestone: none → folsom-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-09-27
Changed in horizon:
milestone: folsom-3 → 2012.2
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers