compile problem with gtk 2.23 with deprecated flags

Bug #695790 reported by Filipe Rosset on 2010-12-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HomeBank
Medium
Maxime Doyen
Fedora
Fix Released
High

Bug Description

HomeBank 4.3 doesn't compile on Fedora 15

The link with the error is here: https://bugzilla.redhat.com/attachment.cgi?id=466867

Can you please take a look why its happening?

homebank-4.3-1.fc14.src.rpm Failed To Build From Source against the rawhide tree. See http://fedoraproject.org/wiki/FTBFS for more information.
If you believe this is actually a bug in another package, do NOT change the component in this bug or close this bug. Instead, add the appropriate bug number from the other package to the "Depends on" line in this bug. If the other package does not yet have a bug created that you think matches, please create one. Doing so helps us properly track bugs and their dependencies, just as we track package dependencies. (If you close this bug, and the other package is not fixed before the next FTBFS run, a new bug will get created. Please follow the above advice to avoid such duplication.)

Created attachment 466863
root.log

root.log for i386

Created attachment 466864
build.log

build.log for i386

Created attachment 466865
mock.log

mock.log for i386

Created attachment 466866
root.log

root.log for x86_64

Created attachment 466867
build.log

build.log for x86_64

Created attachment 466868
mock.log

mock.log for x86_64

This package has changed ownership in the Fedora Package Database. Reassigning to the new owner of this component.

I opened https://bugs.launchpad.net/homebank/+bug/695790 to work with upstream while I look for a solution to this problem.

I made a new update and now homebank is building on rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=2694634

http://koji.fedoraproject.org/koji/buildinfo?buildID=212103

I'll ping the upstream to stop the use of deprecated functions in the source code.

Filipe Rosset (rosset) wrote :

I had to remove -DGTK_DISABLE_DEPRECATED on the configure files, can you please update the sources and avoid to use DEPRECATED functions?

Can you please try to build the sources against a newer GTK2 version?

Cheers,

--- configure.ac.original 2010-12-31 00:52:27.654282449 -0200
+++ configure.ac 2010-12-31 00:53:18.635259725 -0200
@@ -33,7 +33,7 @@

 # Usual c & gtk cflags
-CFLAGS="${CFLAGS} -Wall -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
+CFLAGS="${CFLAGS} -Wall -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED"

 # Check for libofx

--- configure.original 2010-12-31 00:52:18.532928659 -0200
+++ configure 2010-12-31 00:52:55.432359838 -0200
@@ -4537,7 +4537,7 @@

 # Usual c & gtk cflags
-CFLAGS="${CFLAGS} -Wall -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED -DGTK_DISABLE_DEPRECATED"
+CFLAGS="${CFLAGS} -Wall -DG_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED"

 # Check for libofx

Maxime Doyen (mdoyen) wrote :

@Filipe: does these 2 questions are for me of for fedora package maintainer ?

Maxime Doyen (mdoyen) on 2011-01-02
Changed in homebank:
assignee: nobody → Maxime DOYEN (mdoyen)
status: New → Incomplete
Filipe Rosset (rosset) wrote :

Hi Maxime,

I'm the new maintainer of HomeBank on Fedora :)

Which version of GTK are you using to build the 4.3 tree?
I'm asking it because on Fedora 15 we have gtk2-2.23, and I'm sure if you build HomeBank against this version in any other OS you can see the same problem.
Maybe, can you update the deprecated functions in 4.4. tree? :)

Cheers,

Maxime Doyen (mdoyen) wrote :

build under ubuntu 10.10, with gtk 2.22
I will see what to do with deprecated function in 2.23 for sure in 4.4.

Changed in homebank:
importance: Undecided → Low
status: Incomplete → Confirmed
milestone: none → 4.4
Filipe Rosset (rosset) wrote :

Hi Maxime,

Thanks for the update, I'll inform you if we've found other bugs.

Cheers,

Maxime Doyen (mdoyen) on 2011-01-07
summary: - HomeBank 4.3 doesn't compile on Fedora 15
+ compile problem with gtk 2.23 with deprecated flags
Maxime Doyen (mdoyen) wrote :

GtkComboBoxEntry is deprecated since version 2.23.

So the correct workaround is to remove the GTK_DISABLE_DEPRECATED flag.

I will do the chnage, but for v4.5, not the 4.4

Changed in homebank:
importance: Low → Medium
milestone: 4.4 → 4.5
Maxime Doyen (mdoyen) wrote :

I have modified the configure.ac to not check for deprecated.
I keep this usage for the dev, not for release.
This will be fixed for the soon coming v4.4

Changed in homebank:
milestone: 4.5 → 4.4
Maxime Doyen (mdoyen) on 2011-01-13
Changed in homebank:
status: Confirmed → Fix Committed
Maxime Doyen (mdoyen) on 2011-01-17
Changed in homebank:
status: Fix Committed → Fix Released

homebank-4.4-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/homebank-4.4-1.fc14

homebank-4.4-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/homebank-4.4-1.fc13

Package homebank-4.4-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing homebank-4.4-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/homebank-4.4-1.fc14
then log in and leave karma (feedback).

homebank-4.4-1.fc14 has been pushed to the Fedora 14 stable repository. If problems still persist, please make note of it in this bug report.

homebank-4.4-1.fc13 has been pushed to the Fedora 13 stable repository. If problems still persist, please make note of it in this bug report.

Changed in fedora:
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.