wish: add pdf export (for print purpose)

Bug #300380 reported by Ray Facer on 2008-11-20
206
This bug affects 32 people
Affects Status Importance Assigned to Milestone
HomeBank
Wishlist
Maxime DOYEN
Baltix
Wishlist
Unassigned

Bug Description

How do you print out from HomeBank?

I can not find the print button or export via pdf file.

Regards,
Ray

Maxime DOYEN (mdoyen) wrote :

At the present time, you can't.
This is something that still to be implemented.

Changed in homebank:
assignee: nobody → mdoyen
importance: Undecided → Medium
status: New → Confirmed
Maxime DOYEN (mdoyen) on 2009-08-23
Changed in homebank:
milestone: none → 4.2
Deserttaxguy (jeff-deserttax) wrote :

Dear Maxime,
Nice work so far. I would volunteer to the help specify some print formats if you would like some assistance with setting up report configurations. I know you are very busy. Good work on your project.

Maxime DOYEN (mdoyen) wrote :

Gtk has a native print functionnality set, I have already tested and will probably uses.
This permit to direclty print or save into a pdf file.

Maxime DOYEN (mdoyen) on 2009-12-22
Changed in homebank:
milestone: 4.2 → none
Maxime DOYEN (mdoyen) on 2009-12-23
Changed in homebank:
importance: Medium → Wishlist
nomnex (nomnex) wrote :

I subscribe to the thread. This feature would be more than welcome. Thanks

Odin Hørthe Omdal (velmont) wrote :

Yes, I think it is frowned upon to send in a screenshots to the authorities for my one-man-firm.

Maxime DOYEN (mdoyen) wrote :

Just because I'm a quite printless man, what all of you need so much to print, and what to print from HomeBank ?

Hello Maxime,
We need to be able to print out summary reports for review or to use as
documentary support in preparing tax returns or other information.

On Mon, Mar 29, 2010 at 12:56 PM, Maxime DOYEN <email address hidden> wrote:

> Just because I'm a quite printless man, what all of you need so much to
> print, and what to print from HomeBank ?
>
> --
> How do I print out results? Pdf output? other?
> https://bugs.launchpad.net/bugs/300380
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in HomeBank: Confirmed
>
> Bug description:
> How do you print out from HomeBank?
>
> I can not find the print button or export via pdf file.
>
> Regards,
> Ray
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/homebank/+bug/300380/+subscribe
>

Maxime DOYEN (mdoyen) on 2010-07-08
summary: - How do I print out results? Pdf output? other?
+ wish : add print and pdf output

I would love this functionality to be included, I may add it myself.

I already spent all of 2 minutes to change the automatic transactions maximum days from 100 to 36500, increasing that number definitely needed doing :)

def_wallet.c line 223:
--- def_wallet.c 2010-11-01 17:45:44.000000000 +0000
+++ def_wallet.c 2010-11-01 17:45:44.000000000 +0000
@@ -220,7 +220,7 @@

  label = make_label(_("_Insert:"), 0, 0.5);
  gtk_table_attach (GTK_TABLE (table), label, 1, 2, row, row+1, (GtkAttachOptions) (GTK_FILL), (GtkAttachOptions) (0), 0, 0);
- spinner = make_numeric(label, 0, 100);
+ spinner = make_numeric(label, 0, 3650);
  data.NU_arc = spinner;
     gtk_box_pack_start (GTK_BOX (hbox), spinner, FALSE, FALSE, 0);
  //TRANSLATORS: there is a spinner on the left of this label, and so you have 0....x days into the future

Eric Forgeot (eforgeot) wrote :

I think at least a PDF output would be great. Direct print could wait if the PDF option was available (or the opposite, on Linux it's easy to use the build-in PDF converter when a print is needed).

I'm a printless man myself too, but being able to get a PDF to send to third parties is quite needed.

Maxime DOYEN (mdoyen) wrote :

So most of you need to print mainly from the report dialogs.
Can you specify which one is the most needed for print? statistics ? any other
My goal is to organize the print implementation step by step, has I would probably enable to do all print part at once.
So I will implement this by priority order if possible, and include maybe the most urgent one into v4.5

Changed in homebank:
milestone: none → 4.5

Dear Maxime Doyen,
I need to print the following (in the order of priority):
1. Account Statement for the period (For each account)
2. Account Summary&nbsp;3. Income , Expenditure &amp; Balance Report (All Statistics- Categaory wise, sub category ,etc.)4.Others can wait
Thanks for taking up on priority in v4.5.
Yours sincerely,Jayantilal B Kalaiya
From: Maxime Doyen &lt;<email address hidden>&gt;
Sent: Sat, 30 Jul 2011 18:26:23
To: <email address hidden>
Subject: [Bug 300380] wish : add print and pdf output
So most of you need to print mainly from the report dialogs.

Can you specify which one is the most needed for print? statistics ? any other

My goal is to organize the print implementation step by step, has I would probably enable to do all print part at once.

So I will implement this by priority order if possible, and include maybe the most urgent one into v4.5

** Changed in: homebank

 &nbsp; &nbsp;Milestone: None =&gt; 4.5

--

You received this bug notification because you are subscribed to the bug

report.

https://bugs.launchpad.net/bugs/300380

Title:

 &nbsp;wish :&nbsp;add print and pdf output

Status in HomeBank:

 &nbsp;Confirmed

Status in Baltix GNU/Linux:

 &nbsp;New

Bug description:

 &nbsp;How do you print out from HomeBank?

 &nbsp;I can not find the print button or export via pdf file.

 &nbsp;Regards,

 &nbsp;Ray

To manage notifications about this bug go to:

https://bugs.launchpad.net/homebank/+bug/300380/+subscriptions

So, clearly if I enabel pdf export for account window and statistic it will be ok I think. Please confirm.

Changed in baltix:
status: New → Invalid
Maxime DOYEN (mdoyen) on 2012-04-03
Changed in homebank:
milestone: 4.5 → 4.6
Zoubidoo (zoubidoo) wrote :

To build upon the above suggestions, it would be useful to print or create a pdf for the following:

* Transaction list (homebank already produces this) with totals.
* Balance sheet https://en.wikipedia.org/wiki/Balance_sheet (example: https://decollins1969.files.wordpress.com/2010/08/wb_balance_sheet1.gif)
* Income statement https://en.wikipedia.org/wiki/Income_statement (example: http://www.immi.gov.au/about/reports/annual/2006-07/html/_img/Financials/GIFS_financials/income-statement/financials_extractedPage275.jpg)

For the above, it would be helpful to be able to specify:
* categories to include
* date range

Larry Short (larrshort) wrote :

First thanks for the new look in 4.5 and cleaner English terminology.
Second balance sheets and income statements are business software and is not appropriate for free software.
Lastly, just add pdf output for all existing reports, and skip print. Print drivers change with every Windows version and will always be a source of bugs. Print from pdf and let adobe keep drivers up to date.

Changed in baltix:
status: Invalid → Triaged
importance: Undecided → Wishlist
Maxime DOYEN (mdoyen) on 2013-07-21
Changed in homebank:
milestone: none → 4.6
Maxime DOYEN (mdoyen) on 2013-10-06
summary: - wish : add print and pdf output
+ wish : add pdf export (for print purpose)

So, as a summary, here is what you will be able to export as pdf:
1) account transaction, according the current view (with active filter)
2) statistics report: graph + list

Maxime DOYEN (mdoyen) on 2013-12-21
Changed in homebank:
status: Confirmed → In Progress
Maxime DOYEN (mdoyen) on 2013-12-28
summary: - wish : add pdf export (for print purpose)
+ wish: add pdf export (for print purpose)

Hi, I support this, thanks.

Maxime DOYEN (mdoyen) on 2014-07-16
Changed in homebank:
milestone: 5.0 → 5.1
status: In Progress → Confirmed
Maxime DOYEN (mdoyen) on 2015-05-29
Changed in homebank:
milestone: 5.1 → 5.2
Maxime DOYEN (mdoyen) on 2016-08-07
tags: added: file-import-export
Alvin Kutil (akutil86) wrote :

wish : add print or pdf output
Agree with thread pdf output before print capability. Much needed, should be upgraded to primary feature and worked on a monthly basis. Tax season is upon us, but feature should be finished before 2018.

Maxime DOYEN (mdoyen) on 2017-02-18
Changed in homebank:
status: Confirmed → In Progress
Maxime DOYEN (mdoyen) wrote :

by the way: I am also changing the graph display to be able to export to pdf: inspired from here
https://google-developers.appspot.com/chart/interactive/docs/gallery/piechart#donut

Yves (yvesbe) wrote :

Avez-vous une date de mise à disposition de cette fonctionnalité ?
J'envisage d'utiliser homebank pour transmettre mes comptes à mon comptable et celui-ci me demande des pdf avec la liste de mes transactions.

Si cette fonction n'est pas prévue pour l'année en cours, je vais devoir me tourner vers un autre logiciel.

Maxime DOYEN (mdoyen) wrote :

I will release the transaction export to pdf (in RC state) in 5.1.7, to come this week-end.

Yves (yvesbe) wrote :

Hi there,

I downloaded the 5.1.7 and tryed to export to pdf the accounts.
There is no export, no pdf.

I tried to save it under different place (i.e. no special folder ) and different name (with or without special caracters).

None worked.

Maxime DOYEN (mdoyen) wrote :

- open an account window
- testing menu
- export to PDF

...

Changed in homebank:
milestone: 5.2 → none

Bonjour,
Cela ne fonctionne pas.
Voici ce que j'ai fais:

- Ouverture du fichier comptable
- Double clic sur le nom du compte bancaire dont je veux le détail
- choix d'un dossier spécifique ( C:\Users\Yves\Documents\chatterie\2017 )
- je laisse le nom proposé ( ING (professionel).pdf )
- je clique sur exporter
- je vais voir dans le dossier C:\Users\Yves\Documents\chatterie\2017
==> pas de pdf créé
==> pas de répertoire créé

version de windows: 10 famillial 64 bit
processeur intel core I5
6 Go ram

version programme 5.1.7

Bien à vous,

<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
Garanti
sans virus. www.avast.com
<https://www.avast.com/sig-email?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
<#DAB4FAD8-2DD7-40BB-A1B8-4E2AA1F9FDF2>

2018-02-17 11:39 GMT+01:00 Maxime Doyen <email address hidden>:

> - open an account window
> - testing menu
> - export to PDF
>
> ...
>
> ** Changed in: homebank
> Milestone: 5.2 => None
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/300380
>
> Title:
> wish: add pdf export (for print purpose)
>
> Status in HomeBank:
> In Progress
> Status in Baltix:
> Triaged
>
> Bug description:
> How do you print out from HomeBank?
>
> I can not find the print button or export via pdf file.
>
> Regards,
> Ray
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/homebank/+bug/300380/+subscriptions
>

Maxime DOYEN (mdoyen) wrote :

cet export reste pour le moment experimental (RC state), donc c'est tout à fait possible.
suggestions:
- testez avec le fichier exemple
- lancez homebank a partir d'un cmd.exe pour voir si des messages s'affichent

Yves (yvesbe) wrote :

Bonsoir,

Je sais que c'est toujours en testing, pas de soucis pour ça :)

- je viens de tester avec le fichier d'exemple: même résultat, pas d'output.
- depuis un cmd, pas de message d'erreur, je colle le contenu inintéressant
de la fenetre dos (voir en fin de message)
- si vous avez un mode debug avec log, je veux bien passer dans ce mode et
faire le test puis vous renvoyer le log. (voir installer une version de
debug si vous avez).

C:\Program Files (x86)\HomeBank>dir *.exe
 Le volume dans le lecteur C s’appelle OS
 Le numéro de série du volume est B23B-633B

 Répertoire de C:\Program Files (x86)\HomeBank

22-06-17 02:29 182.706 gtk3-widget-factory.exe
06-01-18 19:52 742.912 HomeBank.exe
12-02-18 01:22 1.197.769 unins000.exe
               3 fichier(s) 2.123.387 octets
               0 Rép(s) 180.252.028.928 octets libres

C:\Program Files (x86)\HomeBank>HomeBank.exe

C:\Program Files (x86)\HomeBank>

2018-02-18 22:52 GMT+01:00 Maxime Doyen <email address hidden>:

> cet export reste pour le moment experimental (RC state), donc c'est tout à
> fait possible.
> suggestions:
> - testez avec le fichier exemple
> - lancez homebank a partir d'un cmd.exe pour voir si des messages
> s'affichent
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/300380
>
> Title:
> wish: add pdf export (for print purpose)
>
> Status in HomeBank:
> In Progress
> Status in Baltix:
> Triaged
>
> Bug description:
> How do you print out from HomeBank?
>
> I can not find the print button or export via pdf file.
>
> Regards,
> Ray
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/homebank/+bug/300380/+subscriptions
>

rugk (48509946-3) wrote :

Hmm, may you speak English so everybody understands it?

BTW I've discovered that the PDF is always dumped into my home directory, no matter what directory you actually choose.

Fedora 27, Homebank v1.5.7

Maxime DOYEN (mdoyen) wrote :

@rugk: not all people speak english.
Yves don't find the file after expot to pdf, and you are right the folder used is the one configured as export into the import/export section of the preferences, this is the actual bug for this.

@Yves: le fichier est toujours exporté dans le dossier configuré dans les préférences, section Import/Export

Yves (yvesbe) wrote :

Hi there,

Sorry, i didn't knew you prefered english. i'll do my best in that
language.

I changed preferences to C:\Users\Yves\Documents\chatterie to be sure to
spot exported files easily.
I tryed but no file was created there.

I closed and relaunched homebank for the case preferences where only read
at start up.
I exported againe: No file was created.

I also tried to specify the same folder as in preferences to avoid a bug of
different folders : Still no file created whith testing -> export pdf.

I now tried the same case , but renaming the pdf file to avoid "(" and ")"
in its name (account name countains those parenthesis). It also included a
space in the name.
it still doesn't work.

To handle pdf files , i have acrobat reader dc and pdf creator, as you can
see in the attached file. Perhaps don't i have the same readers as you and
it's not working due of that ?

i'm willing to help as much as i can (i need the pdf feature :) ). If you
want me to test something, just tell me.

Best regards,

[image: Images intégrées 1]

2018-02-19 22:45 GMT+01:00 Maxime Doyen <email address hidden>:

> @rugk: not all people speak english.
> Yves don't find the file after expot to pdf, and you are right the folder
> used is the one configured as export into the import/export section of the
> preferences, this is the actual bug for this.
>
> @Yves: le fichier est toujours exporté dans le dossier configuré dans
> les préférences, section Import/Export
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/300380
>
> Title:
> wish: add pdf export (for print purpose)
>
> Status in HomeBank:
> In Progress
> Status in Baltix:
> Triaged
>
> Bug description:
> How do you print out from HomeBank?
>
> I can not find the print button or export via pdf file.
>
> Regards,
> Ray
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/homebank/+bug/300380/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments