inherit with keep last date off should set todays date

Bug #1873311 reported by Skymirrh
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HomeBank
Low
Maxime DOYEN

Bug Description

Hello,

There is a regression on bug #1858945 in latest 5.4 (I am using the "fixed" executable provided in bug #1871776).

Prerequisite:
- Make sure "Keep the last date" is NOT ticked in "Preferences/Transaction" (i.e. default state).

Scenario:
- Open any account.
- Select any past transaction (i.e. not today).
- Inherit transaction.

Result:
- Transaction is duplicated and date is kept "in the past".

Expected:
- Transaction is duplicated but date is changed to today.

I guess this may be related to the fixes of either bug #1862677 or bug #1860309?

Note: first posted as a comment on #1858945, reposting as a new bug for visibility.

Cheers :)

Skymirrh (skymirrh)
description: updated
description: updated
description: updated
Revision history for this message
Maxime DOYEN (mdoyen) wrote :

OK, I will check this helping with the following data.
I thought I did all the test, but maybe forgot to check the initial date when inherit
Adding to this, I noticed there is no explanation into the doc on how this feature is supposed to work, with Add & Keep and Add button.

For the record.
Here is the complete test matrix from 5.2.8 (and the feature design):

legend:
1: means ok
0: means bug

A) Add txn
-----------------------------------------------------------------------------
         window | register | register | mainwindow | mainwindow |
 keep last date | OFF | ON | OFF | ON |
-----------------------------------------------------------------------------
[Add & Keep] | 1:date kept | 1:date kept | 1:date kept | 1:date kept |
 with past date | 1:data kept | 1:data kept | 1:data kept | 1:data kept |
-----------------------------------------------------------------------------
[Add] | 1:date today | 1:date kept | 1:date today | 1:date kept |
 with past date | 1:data clear | 1:data clear | 1:data clear | 1:data clear |
-----------------------------------------------------------------------------

B) Inherit txn
-----------------------------------------------
         window | register | register |
 keep last date | OFF | ON |
-----------------------------------------------
   initial date | 1:today | 1:txn date |
-----------------------------------------------
[Add & Keep] | 1:date kept | 1:date kept |
 with past date | 1:data kept | 1:data kept |
-----------------------------------------------
[Add] | 1:date today | 1:date kept |
 with past date | 0:data clear | 0:data clear | 2 bugs here will be fixed in 1829927
-----------------------------------------------

and the related bugs history since 5.2.8:

5.4.1 1873311 keep last date preference no more working
5.4 1862677 add and keep FROM register reset the date
5.3.2 1860309 Preference "Keep the last date" not working after creating a new transaction
5.3.1 1858945 keep last date preference no more working
5.3 1829927 when inherit a txn, the Add button faulty keep the data
5.2.8 initial situation prior any bug report (but 1829927 already exists)

Revision history for this message
Maxime DOYEN (mdoyen) wrote :

open with a text editor (fixed width font) :)

Changed in homebank:
assignee: nobody → Maxime DOYEN (mdoyen)
importance: Undecided → Low
milestone: none → 5.4.1
status: New → Confirmed
Revision history for this message
Maxime DOYEN (mdoyen) wrote :

here is a formatted text file of the matrix

Changed in homebank:
status: Confirmed → In Progress
Maxime DOYEN (mdoyen)
Changed in homebank:
status: In Progress → Fix Committed
summary: - keep last date preference no more working
+ inherit with keep last date off should set todays date
Revision history for this message
Skymirrh (skymirrh) wrote :

Hello Maxime, thanks for the design matrix, very useful to understand what is supposed or not supposed to happen :)

Thanks for all your work, this particular feature seems to be a maintenance PITA.

Revision history for this message
Maxime DOYEN (mdoyen) wrote :

Hi,

Your welcome.
This feature as become more complex during time, and when I refactored in 5.3, I broken things.
As usual on development stuff the problem is generally under the chair and the keyboard :)

Max.

Revision history for this message
Maxime DOYEN (mdoyen) wrote :

DOh, I meant: between the chair and the keyboard

Revision history for this message
Maxime DOYEN (mdoyen) wrote :

doc updated
already online: http://homebank.free.fr/help/dlg-tran.html

Maxime DOYEN (mdoyen)
Changed in homebank:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers