wish: option to control the autocomplete of memo

Bug #1673048 reported by Christopher on 2017-03-15
30
This bug affects 3 people
Affects Status Importance Assigned to Milestone
HomeBank
Wishlist
Maxime DOYEN

Bug Description

Simple question - HOW DO I EDIT SAVED ENTRIES IN THE MEMO FIELD. I cannot find a drop down or similar to be able to correct spelling mistakes for example?? can anyone help please?
Every time one makes an entry in a memo field that entry is stored in what I can only describe as a data base and can even be viewed or selected from the drop down.
Old entries no longer required even ones that you have edited due to spelling errors for example are held in this data base and cannot as far as I can see cannot be MANAGED like othe details can be.

Maxime DOYEN (mdoyen) wrote :

this list is filled with all memo at each HomeBank loading a file.
so if there is some spelling mistake, fix it into the source txn directly.

this is an old feature, maybe need to be refresh. Changing this rule will probably annoy other people, so I won't.

Changed in homebank:
status: New → Won't Fix
Maxime DOYEN (mdoyen) on 2017-05-29
Changed in homebank:
status: Won't Fix → New
Maxime DOYEN (mdoyen) wrote :

#1673048 add:
- check for any duplicate insert

observation:
- load the list at file open lead that if you fix memo, it will not reflect the changes
- load all is probably too much
- the list propose memo of all account despite the target account of the current txn

my proposal: set a more accurate behavior:

- add a pref parameter to only insert here last X months, or Z days ?
- maybe add a parameter to disable this option ?
- only propose list of memo for the current target account ?

please comment/agree

Changed in homebank:
importance: Undecided → Wishlist
summary: - Unable to edit saved memo feild data base/drop down
+ wish: option to control the autocomplete of memo
Changed in homebank:
status: New → Confirmed
assignee: nobody → Maxime Doyen (mdoyen)
status: Confirmed → Incomplete

Sorry cannot comment now until July, I am away from my desktop computer.

Best regards

Sent from Graham's iPad

> On 29 May 2017, at 20:35, Maxime Doyen <email address hidden> wrote:
>
> ** Changed in: homebank
> Status: Won't Fix => New
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1673048
>
> Title:
> Unable to edit saved memo feild data base/drop down
>
> Status in HomeBank:
> New
>
> Bug description:
> Simple question - HOW DO I EDIT SAVED ENTRIES IN THE MEMO FIELD. I cannot find a drop down or similar to be able to correct spelling mistakes for example?? can anyone help please?
> Every time one makes an entry in a memo field that entry is stored in what I can only describe as a data base and can even be viewed or selected from the drop down.
> Old entries no longer required even ones that you have edited due to spelling errors for example are held in this data base and cannot as far as I can see cannot be MANAGED like othe details can be.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/homebank/+bug/1673048/+subscriptions

Maxime DOYEN (mdoyen) on 2017-07-09
Changed in homebank:
status: Incomplete → New
Maxime DOYEN (mdoyen) on 2017-07-09
Changed in homebank:
milestone: none → 5.2
Christopher (u-graham) wrote :

Hello Maxine,
Sorry but I am not sure I understand what you are saying, you are using technical language that a I cannot follow?

Maxime DOYEN (mdoyen) wrote :

this is a copy/paste from another ticket to contribute to what to do at end.

a) the actual situation is as described on post 2nd of april:
when you load a file, HB collect all memo of all account to fill in the autocomplete field

b) so my proposal and question are:
- add a preference parameter to only insert into the list last X months, or Z days ?
- maybe add a parameter to disable this autocomplete option ?
- only propose list of memo for the current target account ?

Changed in homebank:
status: New → Incomplete

Hi,

Maybe add a parameter to disable this autocomplete option ?
Or
In the Manage menu include memo fields and one can just get to the memo fields to edit them as one needs to in much the same way as you would with accounts or payees for example. Does that not keep it simple?

Graham

Sent from Graham's iPad

> On 22 Jul 2017, at 11:32, Maxime Doyen <email address hidden> wrote:
>
> maybe add a parameter to disable this autocomplete option ?

Roland (roland-gonsales) wrote :

Bonjour Maxime,
Pourquoi ne peut-on pas ajouter, simplement, au menu "Gérer" trois items supplémentaires ?
A savoir "mémo" "info" et "étiquettes".
C'est ce qui serait le plus simple pour l'utilisateur (mais peut-être pas pour le développeur, si ?)
Roland

Maxime DOYEN (mdoyen) on 2017-08-06
Changed in homebank:
status: Incomplete → New
Christopher (u-graham) wrote :

Maxine & Roland,

Cela semble être sur les lignes de ce que je cherchais.

Chris

Maxime DOYEN (mdoyen) wrote :

Pourquoi ne peut-on pas ajouter, simplement, au menu "Gérer" trois items supplémentaires ?
A savoir "mémo" "info" et "étiquettes".
=> parce que mémo n'existe que sur chaque operation, ce n'est pas un élément éditable, cf mes premiers retours
=> étiquette n'a pas d'autocomplete et info non plus: hors du sujet de ce ticket
si vous avez besoin de faciliter votre saisie: utiliser les template (modèles), c'est fait pour ca

restons sur ce qui est gérable et envisageable, vu le problème initial à savoir:
1) s'il y a des erreurs de frappe = corriger l'opé ou cette erreur se trouve = deja possible
2) pour éviter les vielles entrées, ce que je propose est
a) de rajouter une option pour limiter les opé collectées aux derniers X mois ou Y jours
b) de pouvoir débrayer cette fonction
c) de collecter par compte et pas au global, actuellement si vous avez 3 comptes, tous les libelles des 3 comptes sont dans l'acp, ce que je propose serait de limiter l'acp par compte

Maxime DOYEN (mdoyen) wrote :

Done. You will:
- have a checkmark to enable/disable
- can limit the txn rolling days from 0 (current sesison) to 1460 (4 years)

Changed in homebank:
status: New → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions