wish: split the amount of a transaction into more than 10 categories.

Bug #1225122 reported by Karol Głąb on 2013-09-13
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
HomeBank
Wishlist
Maxime DOYEN

Bug Description

Some from my transactions has more than 6 categories. That will be helpfull for my friends and me, because we have many transactions who have a long list of categories. Split the amount Limited to 6 categories it is very cumbersome.

Homebank 4.5.2
OS: Windows 7

description: updated
Gabor Nagy (g-nagy) wrote :

I totally agree with you. It would be really great.
I solved it temporary on Linux by change the hb-transaction.h source code file and compiled it myself.
I changed this line:
#define TXN_MAX_SPLIT 6 --> #define TXN_MAX_SPLIT 20
The ideal TXN_MAX_SPLIT number would be for me the 80, but this window is not scrollable.

Maxime DOYEN (mdoyen) on 2013-09-21
Changed in homebank:
importance: Undecided → Wishlist
status: New → Confirmed
Maxime DOYEN (mdoyen) on 2014-06-29
tags: added: transaction
Maxime DOYEN (mdoyen) on 2014-07-30
Changed in homebank:
importance: Wishlist → Undecided
Andrey Melnikov (temnota-am) wrote :

I'm slightly reworked split dialog - make entries scrollable and incrased limit up to 80 entries.
Screenshot attached.

Gabor Nagy (g-nagy) wrote :

Thanks Andrey!
This is exaclty what I want.
When will be available in the repo?

Andrey Melnikov (temnota-am) wrote :

Sorry for delay, I'm hitting the problem - dialog generation so SLOOOOW (on my atom n570 it take 5-6 seconds before shown).

Maxime DOYEN (mdoyen) on 2014-10-28
Changed in homebank:
status: Confirmed → New
Maxime DOYEN (mdoyen) wrote :

Guys please you are free to hack if you want for your own purpose but please don't provide patch that are not good solution or have side effect you don't control to other users.

Maxime DOYEN (mdoyen) on 2015-02-01
Changed in homebank:
milestone: none → 5.1
Maxime DOYEN (mdoyen) on 2015-02-06
Changed in homebank:
assignee: nobody → Maxime Doyen (mdoyen)
importance: Undecided → Wishlist
status: New → Confirmed
Maxime DOYEN (mdoyen) on 2015-05-29
Changed in homebank:
milestone: 5.1 → 5.2
slodki (slodki) on 2015-09-29
summary: - wish : split the amount of a transaction into unlimited categories.
+ wish: split the amount of a transaction into unlimited categories.
Maxime DOYEN (mdoyen) on 2016-08-11
Changed in homebank:
milestone: 5.2 → none
Maxime DOYEN (mdoyen) on 2017-08-13
tags: added: data-structure

for the record, quicken is limited to 250.

summary: - wish: split the amount of a transaction into unlimited categories.
+ wish: split the amount of a transaction into more than 10 categories.
Maxime DOYEN (mdoyen) wrote :

I have refactored the txn split dialog with a list and button, similar to quicken.
The slowness for those who tried to extend was due to multiple category widget to fillin.

So now we can setup more split limit.
I have read 20, 80, there will be no ideal.
I still be taped for the needs or 80 splits I must admit.

Changed in homebank:
status: Confirmed → Incomplete
milestone: none → 5.2
Maxime DOYEN (mdoyen) on 2017-12-20
Changed in homebank:
status: Incomplete → Confirmed
Maxime DOYEN (mdoyen) on 2018-01-05
Changed in homebank:
status: Confirmed → In Progress
Maxime DOYEN (mdoyen) wrote :

let's go for 60 for now.

Changed in homebank:
status: In Progress → Fix Committed
Maxime DOYEN (mdoyen) on 2018-09-09
Changed in homebank:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions