heybuddy identi.ca client

Date string convertion fails if locale is set to de_CH.utf8

Reported by Navigium on 2010-06-13
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
heybuddy
High
Unassigned

Bug Description

I started heybuddy pretending I'm on a swiss german computer with 'LC_ALL=de_CH.utf8 heybuddy' (on Arch Linux). Then there is some problem with date string conversion. I don't know whether this is really heybuddys fault or a misconfiguration on my system...

http://identi.ca/api/statuses/friends_timeline/navigium.xml?since_id=0
http://identi.ca/api/statuses/mentions/navigium.xml?since_id=0
emitting statusesXML signal
Traceback (most recent call last):
  File "/usr/bin/heybuddy", line 277, in process_statusesXML
    data = self.xmlprocessor.get_dent_data(status)
  File "/usr/share/heybuddy/XMLProcessor.py", line 85, in get_dent_data
    t = time.mktime(time.strptime(created,"%a %b %d %H:%M:%S +0000 %Y") )
  File "/usr/lib/python2.6/_strptime.py", line 454, in _strptime_time
    return _strptime(data_string, format)[0]
  File "/usr/lib/python2.6/_strptime.py", line 325, in _strptime
    (data_string, format))
ValueError: time data u'Sun Jun 13 06:22:41 +0000 2010' does not match format '%a %b %d %H:%M:%S +0000 %Y'

Navigium (navigium) on 2010-06-13
description: updated
jezra (jezra) wrote :

It looks like the time.strptime function doesn't handle unicode strings. Odd.

Changed in heybuddy:
status: New → Confirmed
jezra (jezra) wrote :

Can you please test this?

Changed in heybuddy:
importance: Undecided → High
status: Confirmed → Fix Committed
Navigium (navigium) wrote :

I tested it on Arch. It works now with LC_ALL=de_CH.utf8. I don't have any other locale installed to check.....

On Wed, 16 Jun 2010 21:44:17 -0000
Navigium <email address hidden> wrote:

> I tested it on Arch. It works now with LC_ALL=de_CH.utf8. I don't have
> any other locale installed to check.....
>

That's fine. Testing with any non-English locale would suffice.

In this day and age, why would anyone record the date of international
communication with English specific strings for Month and Day?

jezra (jezra) on 2010-06-17
Changed in heybuddy:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers