Submission processing failed on C3 with manually exported submission file

Bug #1439500 reported by Po-Hsu Lin on 2015-04-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HEXR
Undecided
Unassigned
PlainBox (Toolkit)
High
Sylvain Pineau

Bug Description

For a recently tested system, I accidentally close the GUI before submitting the result.
This make the session become an Incomplete one.
And I can't resume it due to bug 1436737

I tried to export the xml file by the following command
$ plainbox session export pbox-il__l2ia -f xml -o /tmp/test.xml
Exporting session...
ERROR plainbox.ctrl: Ignoring invalid generated job 2013.com.canonical.certification::staging/disk/stats_{name}: Problem with field requires: wrong
Saving results to /tmp/test.xml

But this xml file can't be uploaded to C3, the fail message on C3 is:
Processing of this submission has failed!

FAILURE
    <MaybeEncodingError: Error sending result: '"<ExceptionInfo: SyntaxError('syntax error: line 1, column 0',)>"'. Reason: ''PicklingError("Can\'t pickle <class \'cElementTree.ParseError\'>: import of module cElementTree failed",)''.>

https://certification.canonical.com/submissions/status/13859

root@201404-14997:~$ apt-cache policy checkbox
checkbox:
  Installed: 0.17.10+bzr2829+pkg77+legacy1~ubuntu14.04.1
  Candidate: 0.17.10+bzr2830+pkg77+legacy1~ubuntu14.04.1
  Version table:
     0.17.10+bzr2830+pkg77+legacy1~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/checkbox-dev/ppa/ubuntu/ trusty/main amd64 Packages
 *** 0.17.10+bzr2829+pkg77+legacy1~ubuntu14.04.1 0
        100 /var/lib/dpkg/status
     0.17.6-0ubuntu6 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
root@201404-14997:~$ apt-cache policy plainbox
plainbox:
  Installed: 0.21+bzr3638+pkg25~ubuntu14.04.1
  Candidate: 0.21+bzr3638+pkg25~ubuntu14.04.1
  Version table:
 *** 0.21+bzr3638+pkg25~ubuntu14.04.1 0
        500 http://ppa.launchpad.net/checkbox-dev/ppa/ubuntu/ trusty/main amd64 Packages
        100 /var/lib/dpkg/status
     0.5.3-2 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
root@201404-14997:~$ plainbox dev list provider
provider '2013.com.canonical.plainbox:manifest'
provider '2013.com.canonical.certification:certification-client'
provider '2013.com.canonical.certification:checkbox'
provider '2013.com.canonical.certification:plainbox-resources'

Po-Hsu Lin (cypressyew) wrote :
summary: - Submission processing failed on C3
+ Submission processing failed on C3 with manually exported submission
+ file
Daniel Manrique (roadmr) wrote :

Hello! Could you also attach the submission file here? The error suggests it may be incomplete ("corrupted" I would say) which is causing the problem.

Changed in hexr:
status: New → Incomplete
Po-Hsu Lin (cypressyew) wrote :

Hi, sorry for the delay
here is the session tar file

Po-Hsu Lin (cypressyew) wrote :
Changed in hexr:
status: Incomplete → New
Po-Hsu Lin (cypressyew) wrote :

Note, the submission.xml file was generated from the session file

Ara Pulido (ara) wrote :

Marking as Invalid in HEXR. The XML file is not valid, it is normal that HEXR cannot parse it.

This should be fixed at a Plainbox level

Changed in hexr:
status: New → Invalid
Sylvain Pineau (sylvain-pineau) wrote :

ERROR plainbox.ctrl: Ignoring invalid generated job 2013.com.canonical.certification::staging/disk/stats_{name}: Problem with field requires: wrong

This bug has been fixed recently, caused by the udev parser creating devices without DEVNAME.

Changed in plainbox:
status: New → Fix Committed
milestone: none → 0.26
importance: Undecided → High
assignee: nobody → Sylvain Pineau (sylvain-pineau)
Pierre Equoy (pieq) on 2016-03-21
Changed in plainbox:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers