"Ubuntu Desktop Certified Hardware Self-Testing Guide" contains infinite loop

Bug #1407978 reported by Rod Smith on 2015-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HEXR
High
Ara Pulido

Bug Description

The "Ubuntu Desktop Certified Hardware Self-Testing Guide" document at https://certification.canonical.com/static/docs/Ubuntu_Desktop_Certified_Hardware_Self-Testing_Guide.pdf contains an infinite loop: The instructions for installing via APT (In "Getting the Checkbox Packages") say to refer to instructions at https://certification.canonical.com/self-testing/ for details on how to install via APT, but that page contains nothing but download links for the "Ubuntu Desktop Certified Hardware Self-Testing Guide" and its server counterpart. Thus, it's not obvious to the reader how to install the packages on an Internet-connected system, other than by using the method that involves downloading the packages in a tarball.

Daniel Manrique (roadmr) on 2015-01-06
Changed in checkbox:
status: New → Confirmed
importance: Undecided → High
affects: checkbox → hexr
tags: added: certification
Daniel Manrique (roadmr) wrote :

OK, so two ways to fix this:

1- Actually put download and installation instructions in the self-testing guide. A new PDF document would have to be produced (the source is kept as a Google doc and then exported to PDF) and uploaded to certification, which is done via a merge request to hexr plus a request to deploy.

2- Update the self-testing page, which is a "flat page" and can be updated in certification by an admin.

None of them require code changes, #1 will be a bit slower as it has to go through a deployment cycle.

Changed in hexr:
status: Confirmed → Triaged
Rod Smith (rodsmith) wrote :

IMHO, having the instructions in the PDF is a little cleaner, but that's just my feedback.

Daniel Manrique (roadmr) wrote :

Interestingly, I couldn't find any reference to the self-testing URL except in that self-testing PDF. So I wonder if we could dispense with the self-testing URL/flatpage and just put these changes in the doc. I'll talk to the cert team as owners of that document so we can get the ball rolling.

Changed in hexr:
milestone: none → 2015-08
importance: High → Medium
importance: Medium → High
Ara Pulido (ara) wrote :

Chris, can you take care of this, please?

Changed in hexr:
assignee: nobody → Chris Wayne (cwayne18)

I think I'm +1 on removing the Self-testing flat page. We put it all in the
self-testing pdf guides these days so client is the only place I think this
is still used. If at all.
On Mon, Jul 6, 2015 at 11:11 Ara Pulido <email address hidden> wrote:

> Chris, can you take care of this, please?
>
> ** Changed in: hexr
> Assignee: (unassigned) => Chris Wayne (cwayne18)
>
> --
> You received this bug notification because you are a member of HEXR Bug
> Wranglers, which is subscribed to HEXR.
> https://bugs.launchpad.net/bugs/1407978
>
> Title:
> "Ubuntu Desktop Certified Hardware Self-Testing Guide" contains
> infinite loop
>
> Status in Hardware Enablement Cross Referencer:
> Triaged
>
> Bug description:
> The "Ubuntu Desktop Certified Hardware Self-Testing Guide" document at
> https://certification.canonical.com/static/docs
> /Ubuntu_Desktop_Certified_Hardware_Self-Testing_Guide.pdf contains an
> infinite loop: The instructions for installing via APT (In "Getting
> the Checkbox Packages") say to refer to instructions at
> https://certification.canonical.com/self-testing/ for details on how
> to install via APT, but that page contains nothing but download links
> for the "Ubuntu Desktop Certified Hardware Self-Testing Guide" and its
> server counterpart. Thus, it's not obvious to the reader how to
> install the packages on an Internet-connected system, other than by
> using the method that involves downloading the packages in a tarball.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/hexr/+bug/1407978/+subscriptions
>
--
"Entropy isn't what it used to be."

Jeff Lane - Server Certification Lead, OCP Certification Tools Engineering
Lead,
                  Warrior Poet, Biker, Lover of Pie
Phone: 919-442-8649
Ubuntu Ham: W4KDH Freenode IRC: bladernr or
bladernr_
gpg: 1024D/3A14B2DD 8C88 B076 0DD7 B404 1417 C466 4ABD 3635 3A14 B2DD

Ara Pulido (ara) on 2015-09-28
Changed in hexr:
assignee: Chris Wayne (cwayne18) → Ara Pulido (apulido)
status: Triaged → In Progress
Chris Wayne (cwayne18) wrote :

So I've pushed the updated self testing guide to certification-static, should this be considered fixed?

Rod Smith (rodsmith) wrote :

I see that it's fixed at:

http://certification-static.canonical.com/docs/guides/14.04/Ubuntu_Desktop_Certified_Hardware_Self-Testing_Guide.pdf

The C3 page now links to this URL. The original guide with the problem reference still exists at:

https://certification.canonical.com/static/docs/Ubuntu_Desktop_Certified_Hardware_Self-Testing_Guide.pdf

I don't know offhand what, if anything, links to that file, aside from my initial bug report and now this reply, so this may not be a problem; but updating it might be in order. If not, a reader would link from that PDF to C3, which would then link to the updated guide. This could still be confusing.

Ara Pulido (ara) wrote :

I am proposing a merge request to remove the documents from c.c.c.

Waiting on feedback from Jeff.

Changed in hexr:
status: In Progress → Fix Committed
Ara Pulido (ara) on 2015-11-13
Changed in hexr:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers