Searching on https://help.ubuntu.com/ doesn't produce results from wiki.ubuntu.com

Bug #1310309 reported by Christopher M. Penalver on 2014-04-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Online publishing of the Ubuntu documentation
Wishlist
Unassigned

Bug Description

What is expected to happen is when one goes to:
https://help.ubuntu.com/

and searches for example Debugging, one of the results would be:
https://wiki.ubuntu.com/DebuggingProcedures

However, no results from wiki.ubuntu.com are listed under any of the default categories (All Results, Official, Community, Technical, AskUbuntu). One would have to know upfront from trial and error/experience that in order to get results from wiki.ubuntu.com one has to go to there and then look it up.

While I am aware of the different articles that I typically look for, and on which page to search for them, I constantly find myself desiring to be able to do a one stop shop search, instead of flipping between the two. Given this, having this searching capability would certainly empower the Ubuntu Community in their efforts to search for relevant documentation.

One potential resolution would be to integrate the results from wiki.ubuntu.com into Official, as the articles there tend to be released from Ubuntu/Canonical developers, and are of high technical quality.

If this would not be preferred, another solution would be to create a new search category (ex. Ubuntu Wiki), that populates results from wiki.ubuntu.com only.

Gunnar Hjalmarsson (gunnarhj) wrote :

Hi Christopher,

While I don't know why wiki.ubuntu.com is not included in the results generated by that search feature, I have a theory. wiki.ubuntu.com is principally intended for individuals and teams, i.e. not user documentation. So there is a risk that including wiki.ubuntu.com would lead to quite a few irrelevant items being included in the search results.

Possibly it would be better to move docs pages in wiki.ubuntu.com to help.ubuntu.com/community. But I have certainly no firm opinion.

Gunnar Hjalmarsson, thanks for the response.
>"I have a theory. wiki.ubuntu.com is principally intended for individuals and teams, i.e. not user documentation."

The vast majority of developer and end-user debugging documentation from all the developer teams are in wiki.ubuntu.com (ex. https://wiki.ubuntu.com/DebuggingProcedures ).

>"So there is a risk that including wiki.ubuntu.com would lead to quite a few irrelevant items being included in the search results."

The current issue is that for many search terms, most or all of what results from help.ubuntu.com is either irrelevant, or lower quality results (ex. AskUbuntu PPAs/WORKAROUNDs/hacks, etc.), in comparison to wiki.ubuntu.com.

As well, the small negative of including results from wiki.ubuntu.com that wouldn't apply, is outweighed by far from the increase in relevant results from the same.

For example, if one searches for pepper, intending to find the highest quality information about Pepper Flash (i.e. no PPA, WORKAROUNDs, etc.) in help.ubuntu.com one only finds not relevant, and lower quality information in the AskUbuntu category.

However, if one does a full text search at wiki.ubuntu.com one would find the most relevant article:
https://wiki.ubuntu.com/Chromium/Getting-Flash?highlight=%28pepper%29

This outcome is largely reproducible across various search terms.

Doug Smythies (dsmythies) wrote :

It is true that wiki.ubuntu.com is not included. You can observe a list of what is at:

https://www.google.com/cse/home?cx=003883529982892832976:e2vwumte3fq

Where, we can see that it needs to be updated because it is still pointing to help.ubuntu.com/12.04

I have been searching in old doc-list e-mails, but didn't yet find anything relevant as to the reasons behind this stuff.

The problem is that nobody is still involved with docs that knows about this. Myself, I do not know how to update the google custom search thing.

Doug Smythies (dsmythies) wrote :

The CSE has been updated.

Christopher: Try your example now. It was first in the list for me.

The questions remains if we want to keep this change or if it will result in a lot of garbage information. We have been asked to test this over the next few days.

Doug Smythies, thanks for the update.

Searching for debugging gives a lot of highly relevant results from wiki.ubuntu.com, with the expected DebuggingProcedures page at the top of the list.

As well, searching for pepper gives the expected wiki.ubuntu.com pepper flash plugin install article at the top of the list.

As far as I'm concerned, the searching has been dramatically improved for the betterment of the Ubuntu Community.

Dustin Kirkland  (kirkland) wrote :

Thanks Doug, Gunnar, for emailing me. I'm now subscribed to this bug. I created this CSE some years ago, along with Matthew East, and have maintained it.

I've made a couple of the changes requested here in this bug, namely adding the "stable" and "lts" official docs.

I also added wiki.ubuntu.com, somewhat reluctantly, however. We removed it from the search some years ago, as the wiki is not really "official" or "curated" documentation. It's a little messy, disorganized, and contains a ton of out of date information. It turns up hits, such as (ancient) IRC meeting logs, which is clearly not what a user searching help.ubuntu.com wants.

In any case, it's enabled at this point, for at least a little bit of testing.

I'll be working with Doug and Gunnar in the future, who have expressed an interest in helping co-maintain the CSE.

Cheers!
Dustin

Doug Smythies (dsmythies) wrote :

@Dustin: On our e-mail thread you had asked that we review the inclusion of wiki.ubuntu.com in "a few days". We would like to push a review out about 2 months. Would that be O.K. with you?

Due to issues with the .htaccess file and the the robots.txt file and the CSE needing an update, we think people have not been using the built in search. We want to try to get a broader audience using it again and get opinions.

affects: ubuntu-docs (Ubuntu) → help.ubuntu.com

I'm classifying as Fix Released, given the issue in the Bug Description (searching for debugging shows wiki.ubuntu results) is now resolved.

Changed in help.ubuntu.com:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers