Improve JPX request cadence optimization for non-evenly distributed data

Bug #605398 reported by Keith Hughitt on 2010-07-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Helioviewer.org
Medium
Keith Hughitt

Bug Description

Currently the getJPX API method works optimally when image data is distributed fairly evenly across the request time range. This is often not the case, however, and data may be clumped to one side or another for a given time window.

Instead of using the time window and and number of frames to optimize movie cadence, the actual distribution of the data should be taken into account as well.

Changed in helioviewer.org:
assignee: nobody → Keith Hughitt (keith-hughitt)
Keith Hughitt (keith-hughitt) wrote :

Movies are now generated such that instead of using the requested start and end dates, the nearest image at/inside each date is used instead. This eliminates problems caused by having gaps at either end of the request range which is currently the more problematic scenario. Future iterations may be improved by doing things like requesting all images with the request region (for regions which are not too large) and sub-sampling, or recursively dividing up time range and returning counts for each region with > 0 records to get a better picture of where gaps exist in the request range, and then only select frames from within those regions.

Changed in helioviewer.org:
milestone: none → 2.0.3
status: New → Fix Committed
Changed in helioviewer.org:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers