[SRU] unicode error when using old unicode non uuid style user id

Bug #1761629 reported by Seyeong Kim on 2018-04-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Heat
In Progress
Medium
Seyeong Kim
Ubuntu Cloud Archive
High
Unassigned
Mitaka
High
Unassigned
Ocata
High
Unassigned
Pike
High
Unassigned
Queens
High
Unassigned
Rocky
High
Unassigned
heat (Ubuntu)
High
Unassigned
Xenial
High
Unassigned
Artful
High
Unassigned
Bionic
High
Unassigned

Bug Description

[Impact]

When use old non unicode user id, such as Gāo

heat stack-list shows unicode error

Affected to
Xenial, Artful
UCA Mitaka, Ocata, Pike, Queens

[Test Case]

1. deploy openstack env
2. source novarc ( as admin user ) ( or novarcv3_project as admin )
3. keystone user-create --name test
- openstack user create --domain admin_domain test
4. openstack user set --password-prompt test
4. log into keystone node and install mysql-client
5. connect to mysql with keystone user
6. do below query
- set foreign_key_checks = 0;
- update local_user set user_id='Gāo' where user_id='UUID';
- update user set id='Gāo' where id='UUID';
- set foreign_key_checks = 1;
7. keystone user-role-add --user test --tenant admin --role Admin
- openstack role add --user test --domain admin_domain Admin
- openstack role add --user test --project [admin project id] Admin
- openstack role add --user test --project [admin project id] Member
8. source novarc ( as test user ) ( or novarcv3_project as test user )
9. heat stack-list

result is like [Others]

[Regression]

This patch fixes simple unicode. but heat api needs to be restarted. Could be short outage during restarting.

[Others]

Below is test result

heat --debug stack-list
DEBUG (session) REQ: curl -g -i -X GET http://10.0.11.184:5000/v2.0 -H "Accept: application/json" -H "User-Agent: python-keystoneclient"
INFO (connectionpool) Starting new HTTP connection (1): 10.0.11.184
DEBUG (connectionpool) "GET /v2.0 HTTP/1.1" 200 337
DEBUG (session) RESP: [200] Content-Length: 337 Vary: X-Auth-Token Keep-Alive: timeout=5, max=100 Server: Apache/2.4.18 (Ubuntu) Connection: Keep-Alive Date: Thu, 05 Apr 2018 21:20:39 GMT x-openstack-request-id: req-df64189d-c865-47fb-b89d-698d61dfafdc Content-Type: [68/1725]
on/json X-Distribution: Ubuntu
RESP BODY: {"version": {"status": "stable", "updated": "2014-04-17T00:00:00Z", "media-types": [{"base": "application/json", "type": "application/vnd.openstack.identity-v2.0+json"}], "id": "v2.0", "links": [{"href": "http://10.0.11.184:5000/v2.0/", "rel": "self"}, {"href": "ht
tp://docs.openstack.org/", "type": "text/html", "rel": "describedby"}]}}

DEBUG (v2) Making authentication request to http://10.0.11.184:5000/v2.0/tokens
DEBUG (connectionpool) "POST /v2.0/tokens HTTP/1.1" 200 3105
DEBUG (session) REQ: curl -g -i -X GET http://10.0.11.170:8004/v1/c9c6d2b72f74458bada7f94501369b18/stacks? -H "User-Agent: python-heatclient" -H "Accept: application/json" -H "X-Auth-Token: {SHA1}ad359574acee284a60451f9e2340ec46d6e17728"
INFO (connectionpool) Starting new HTTP connection (1): 10.0.11.170
DEBUG (connectionpool) "GET /v1/c9c6d2b72f74458bada7f94501369b18/stacks HTTP/1.1" 400 5508
DEBUG (session) RESP: [400] Date: Thu, 05 Apr 2018 21:20:39 GMT Content-Length: 5508 Content-Type: application/json; charset=UTF-8 Connection: keep-alive
RESP BODY: {"explanation": "The server could not comply with the request since it is either malformed or otherwise incorrect.", "code": 400, "error": {"message": "'ascii' codec can't encode character u'\\u0101' in position 1: ordinal not in range(128)", "traceback": "Tracebac
k (most recent call last):\n File \"/usr/lib/python2.7/dist-packages/heat/api/middleware/fault.py\", line 163, in process_request\n return req.get_response(self.application)\n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1317, in send\n application
, catch_exc_info=False)\n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1281, in call_application\n app_iter = application(self.environ, start_response)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 130, in __call__\n resp = self.ca
ll_func(req, *args, **self.kwargs)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 195, in call_func\n return self.func(req, *args, **kwargs)\n File \"/usr/lib/python2.7/dist-packages/oslo_middleware/base.py\", line 114, in __call__\n response = req.get
_response(self.application)\n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1317, in send\n application, catch_exc_info=False)\n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1281, in call_application\n app_iter = application(self
.environ, start_response)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 130, in __call__\n resp = self.call_func(req, *args, **self.kwargs)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 195, in call_func\n return self.func(req, *args,
 **kwargs)\n File \"/usr/lib/python2.7/dist-packages/oslo_middleware/base.py\", line 114, in __call__\n response = req.get_response(self.application)\n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1317, in send\n application, catch_exc_info=False)\
n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1281, in call_application\n app_iter = application(self.environ, start_response)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 130, in __call__\n resp = self.call_func(req, *args, **se
lf.kwargs)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 195, in call_func\n return self.func(req, *args, **kwargs)\n File \"/usr/lib/python2.7/dist-packages/heat/common/wsgi.py\", line 584, in __call__\n response = req.get_response(self.application)\
n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1317, in send\n application, catch_exc_info=False)\n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1281, in call_application\n app_iter = application(self.environ, start_response)\n
 File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 130, in __call__\n resp = self.call_func(req, *args, **self.kwargs)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 195, in call_func\n return self.func(req, *args, **kwargs)\n File \"/usr/li
b/python2.7/dist-packages/heat/common/wsgi.py\", line 584, in __call__\n response = req.get_response(self.application)\n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1317, in send\n application, catch_exc_info=False)\n File \"/usr/lib/python2.7/dis
t-packages/webob/request.py\", line 1281, in call_application\n app_iter = application(self.environ, start_response)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 130, in __call__\n resp = self.call_func(req, *args, **self.kwargs)\n File \"/usr/lib/py
thon2.7/dist-packages/webob/dec.py\", line 195, in call_func\n return self.func(req, *args, **kwargs)\n File \"/usr/lib/python2.7/dist-packages/keystonemiddleware/auth_token/__init__.py\", line 467, in __call__\n response = req.get_response(self._app)\n File \"/usr/li
b/python2.7/dist-packages/webob/request.py\", line 1317, in send\n application, catch_exc_info=False)\n File \"/usr/lib/python2.7/dist-packages/webob/request.py\", line 1281, in call_application\n app_iter = application(self.environ, start_response)\n File \"/usr/lib/
python2.7/dist-packages/webob/dec.py\", line 130, in __call__\n resp = self.call_func(req, *args, **self.kwargs)\n File \"/usr/lib/python2.7/dist-packages/webob/dec.py\", line 195, in call_func\n return self.func(req, *args, **kwargs)\n File \"/usr/lib/python2.7/dist-
packages/heat/common/wsgi.py\", line 581, in __call__\n response = self.process_request(req)\n File \"/usr/lib/python2.7/dist-packages/heat/common/context.py\", line 311, in process_request\n project_domain_id=project_domain_id)\n File \"/usr/lib/python2.7/dist-packag
es/heat/common/context.py\", line 256, in make_context\n return self.ctxcls(*args, **kwargs)\n File \"/usr/lib/python2.7/dist-packages/heat/common/context.py\", line 109, in __init__\n self.is_admin = self.policy.check_is_admin(self)\n File \"/usr/lib/python2[40/1725]
ackages/heat/common/policy.py\", line 88, in check_is_admin\n return self._check(context, 'context_is_admin', target={}, exc=None)\n File \"/usr/lib/python2.7/dist-packages/heat/common/policy.py\", line 65, in _check\n credentials = context.to_dict()\n File \"/usr/lib
/python2.7/dist-packages/heat/common/context.py\", line 127, in to_dict\n tenant=self.tenant_id or '-')\nUnicodeEncodeError: 'ascii' codec can't encode character u'\\u0101' in position 1: ordinal not in range(128)\n", "type": "UnicodeEncodeError"}, "title": "Bad Request"}

Traceback (most recent call last):
  File "/usr/bin/heat", line 10, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/dist-packages/heatclient/shell.py", line 702, in main
    HeatShell().main(args)
  File "/usr/lib/python2.7/dist-packages/heatclient/shell.py", line 652, in main
    args.func(client, args)
  File "/usr/lib/python2.7/dist-packages/heatclient/v1/shell.py", line 675, in do_stack_list
    utils.print_list(stacks, fields, sortby_index=sortby_index)
  File "/usr/lib/python2.7/dist-packages/heatclient/openstack/common/cliutils.py", line 169, in print_list
    for o in objs:
  File "/usr/lib/python2.7/dist-packages/heatclient/v1/stacks.py", line 127, in paginate
    stacks = self._list(url, 'stacks')
  File "/usr/lib/python2.7/dist-packages/heatclient/openstack/common/apiclient/base.py", line 135, in _list
    body = self.client.get(url).json()
  File "/usr/lib/python2.7/dist-packages/keystoneclient/adapter.py", line 176, in get
    return self.request(url, 'GET', **kwargs)
  File "/usr/lib/python2.7/dist-packages/heatclient/common/http.py", line 311, in request
    raise exc.from_response(resp)
heatclient.exc.HTTPBadRequest: ERROR: 'ascii' codec can't encode character u'\u0101' in position 1: ordinal not in range(128)

Fix proposed to branch: master
Review: https://review.openstack.org/559195

Changed in heat:
assignee: nobody → Seyeong Kim (xtrusia)
status: New → In Progress
Seyeong Kim (xtrusia) on 2018-04-06
tags: added: sts
Rabi Mishra (rabi) on 2018-04-16
Changed in heat:
importance: Undecided → Medium

This issue was fixed in the openstack/heat 11.0.0.0b1 development milestone.

Seyeong Kim (xtrusia) on 2018-04-24
summary: - unicode error when using old unicode non uuid style user id
+ [SRU] unicode error when using old unicode non uuid style user id
Seyeong Kim (xtrusia) on 2018-04-24
description: updated
Seyeong Kim (xtrusia) on 2018-04-24
tags: added: sts-sru-neede
tags: added: sts-sru-needed
removed: sts-sru-neede
Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
description: updated

The attachment "lp1761629_xenial.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Seyeong Kim (xtrusia) wrote :
description: updated
Seyeong Kim (xtrusia) wrote :
description: updated
Rico Lin (rico-lin) on 2018-05-07
Changed in heat:
milestone: none → no-priority-tag-bugs

Reviewed: https://review.openstack.org/562888
Committed: https://git.openstack.org/cgit/openstack/heat/commit/?id=b76d18730d1e4f110d720cfaba980b4cda9e561c
Submitter: Zuul
Branch: stable/queens

commit b76d18730d1e4f110d720cfaba980b4cda9e561c
Author: Seyeong Kim <email address hidden>
Date: Thu Apr 5 15:10:01 2018 -0700

    Fixing unicode issue when to_dict is called on py2.7 env

    When using non-unicode old style user id such as Gāo
    Unicode error popup on py2.7 environment
    Fixing it on common/context.py

    Change-Id: I95e49f359410049ff5b254cd1b8ee16402c8719d
    Closes-Bug: #1761629
    (cherry picked from commit 4d71926b3afc50c3f16378de260b86a85e8d721d)

tags: added: in-stable-queens
Changed in heat (Ubuntu):
importance: Undecided → High
status: New → Fix Released
Changed in heat (Ubuntu Xenial):
importance: Undecided → High
Changed in heat (Ubuntu Artful):
importance: Undecided → High
Changed in heat (Ubuntu Bionic):
importance: Undecided → High
Changed in heat (Ubuntu Xenial):
status: New → Triaged
Changed in heat (Ubuntu Artful):
status: New → Triaged
Changed in heat (Ubuntu Bionic):
status: New → Triaged
Corey Bryant (corey.bryant) wrote :

Seyeong, Thanks for the patches. I've uploaded everything for SRU Team review except for xenial(mitaka) and ocata. Those are failing to build due to unit test issues. Can you take a look?

Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :
Seyeong Kim (xtrusia) wrote :

Thanks for checking it corey,

I re-uploaded them.

Hello Seyeong, or anyone else affected,

Accepted heat into ocata-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:ocata-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-ocata-needed to verification-ocata-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-ocata-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-ocata-needed
Corey Bryant (corey.bryant) wrote :

Thanks Seyeong. I've uploaded this for ocata and xenial as well.

Łukasz Zemczak (sil2100) wrote :

We'll have to wait for the previous heat upload to get tested and released into bionic-updates.

Seyeong Kim (xtrusia) wrote :

Hello

I tested this on ocata env.

test case is the same as description.

with patch, it works fine.

dpkg -l | grep heat
ii heat-api 1:8.0.6-0ubuntu1~cloud1 all OpenStack orchestration service - ReST API
ii heat-api-cfn 1:8.0.6-0ubuntu1~cloud1 all OpenStack orchestration service - CFN API
ii heat-common 1:8.0.6-0ubuntu1~cloud1 all OpenStack orchestration service - common files
ii heat-engine 1:8.0.6-0ubuntu1~cloud1 all OpenStack orchestration service - engine
ii python-heat 1:8.0.6-0ubuntu1~cloud1 all OpenStack orchestration service - Python files

tags: added: verification-ocata-done
removed: verification-ocata-needed
Brian Murray (brian-murray) wrote :

Hello Seyeong, or anyone else affected,

Accepted heat into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/heat/1:10.0.1-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in heat (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Changed in heat (Ubuntu Artful):
status: Triaged → Fix Committed
tags: added: verification-needed-artful
Brian Murray (brian-murray) wrote :

Hello Seyeong, or anyone else affected,

Accepted heat into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/heat/1:9.0.4-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in heat (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

This was also accepted into Xenial although there is no comment about that acceptance.

Seyeong Kim (xtrusia) wrote :

Hello

I followed test case for verification xenial

after patch, it works fine.

dpkg -l | grep heat
ii heat-api 1:6.1.2-0ubuntu1.1 all OpenStack orchestration service - ReST API
ii heat-api-cfn 1:6.1.2-0ubuntu1.1 all OpenStack orchestration service - CFN API
ii heat-common 1:6.1.2-0ubuntu1.1 all OpenStack orchestration service - common files
ii heat-engine 1:6.1.2-0ubuntu1.1 all OpenStack orchestration service - engine
ii python-heat 1:6.1.2-0ubuntu1.1 all OpenStack orchestration service - Python files

tags: added: verification-done-xenial
removed: verification-needed-xenial
Seyeong Kim (xtrusia) wrote :

Hello

I followed test case for verification bionic

result are the same as above.

It works fine.

Below are the dpkg info.

dpkg -l | grep heat
ii heat-api 1:10.0.1-0ubuntu2 all OpenStack orchestration service - ReST API
ii heat-api-cfn 1:10.0.1-0ubuntu2 all OpenStack orchestration service - CFN API
ii heat-common 1:10.0.1-0ubuntu2 all OpenStack orchestration service - common files
ii heat-engine 1:10.0.1-0ubuntu2 all OpenStack orchestration service - engine
ii python-heat 1:10.0.1-0ubuntu2 all OpenStack orchestration service - Python files

tags: added: verification-done-bionic
removed: verification-needed-bionic
Seyeong Kim (xtrusia) wrote :

Hello

I followed steps in test case for verification artful

results are the same as above.

dpkg info is..

dpkg -l | grep heat
ii heat-api 1:9.0.4-0ubuntu2 all OpenStack orchestration service - ReST API
ii heat-api-cfn 1:9.0.4-0ubuntu2 all OpenStack orchestration service - CFN API
ii heat-common 1:9.0.4-0ubuntu2 all OpenStack orchestration service - common files
ii heat-engine 1:9.0.4-0ubuntu2 all OpenStack orchestration service - engine
ii python-heat 1:9.0.4-0ubuntu2 all OpenStack orchestration service - Python files

tags: added: verification-done-artful
removed: verification-needed-artful
Corey Bryant (corey.bryant) wrote :

Hello Seyeong, or anyone else affected,

Accepted heat into queens-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:queens-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-queens-needed to verification-queens-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-queens-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-queens-needed
Corey Bryant (corey.bryant) wrote :

Hello Seyeong, or anyone else affected,

Accepted heat into pike-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:pike-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-pike-needed to verification-pike-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-pike-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-pike-needed
Corey Bryant (corey.bryant) wrote :

Hello Seyeong, or anyone else affected,

Accepted heat into mitaka-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:mitaka-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-mitaka-needed to verification-mitaka-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-mitaka-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-mitaka-needed
Seyeong Kim (xtrusia) wrote :

Hello,

I verified queens it works fine with -proposed patch

I followed test case step for this ( I used openstack command )

ubuntu@juju-ca2c24-1-lxd-1:~$ sudo service heat-engine restart
ubuntu@juju-ca2c24-1-lxd-1:~$ dpkg -l | grep heat
ii heat-api 1:10.0.1-0ubuntu2~cloud0 all OpenStack orchestration service - ReST API
ii heat-api-cfn 1:10.0.1-0ubuntu2~cloud0 all OpenStack orchestration service - CFN API
ii heat-common 1:10.0.1-0ubuntu2~cloud0 all OpenStack orchestration service - common files
ii heat-engine 1:10.0.1-0ubuntu2~cloud0 all OpenStack orchestration service - engine
ii python-heat 1:10.0.1-0ubuntu2~cloud0 all OpenStack orchestration service - Python files

tags: added: verification-queens-done
removed: verification-queens-needed
Seyeong Kim (xtrusia) wrote :

Hello

I verified pike for this.

and It works fine after upgrading from -proposed repo

below is dpkg -l

root@juju-07a5af-1-lxd-3:~# dpkg -l | grep heat
ii heat-api 1:9.0.4-0ubuntu2~cloud0 all OpenStack orchestration service - ReST API
ii heat-api-cfn 1:9.0.4-0ubuntu2~cloud0 all OpenStack orchestration service - CFN API
ii heat-common 1:9.0.4-0ubuntu2~cloud0 all OpenStack orchestration service - common files
ii heat-engine 1:9.0.4-0ubuntu2~cloud0 all OpenStack orchestration service - engine
ii python-heat 1:9.0.4-0ubuntu2~cloud0 all OpenStack orchestration service - Python files

tags: added: verification-pike-done
removed: verification-pike-needed
Seyeong Kim (xtrusia) wrote :

Hello

I verified mitaka for this issue

It works file after upgrading from -proposed repo

dpkg -l is below

root@juju-75dedc-1-lxd-3:~# dpkg -l | grep heat
ii heat-api 1:6.1.2-0ubuntu1.1~cloud0 all OpenStack orchestration service - ReST API
ii heat-api-cfn 1:6.1.2-0ubuntu1.1~cloud0 all OpenStack orchestration service - CFN API
ii heat-common 1:6.1.2-0ubuntu1.1~cloud0 all OpenStack orchestration service - common files
ii heat-engine 1:6.1.2-0ubuntu1.1~cloud0 all OpenStack orchestration service - engine
ii python-heat 1:6.1.2-0ubuntu1.1~cloud0 all OpenStack orchestration service - Python files

tags: added: verification-mitaka-done
removed: verification-mitaka-needed

The verification of the Stable Release Update for heat has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heat - 1:10.0.1-0ubuntu2

---------------
heat (1:10.0.1-0ubuntu2) bionic; urgency=medium

  * Fixing heat error with unicode (LP: #1761629)
    - d/p/0001-Fixing-unicode-issue-when-to_dict-is-called-on-py2.7.patch

 -- Seyeong Kim <email address hidden> Tue, 24 Apr 2018 00:26:21 -0700

Changed in heat (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heat - 1:9.0.4-0ubuntu2

---------------
heat (1:9.0.4-0ubuntu2) artful; urgency=medium

  * Fixing heat error with unicode (LP: #1761629)
    - d/p/0001-Fixing-unicode-issue-when-to_dict-is-called-on-py2.7.patch

 -- Seyeong Kim <email address hidden> Mon, 23 Apr 2018 22:23:06 -0700

Changed in heat (Ubuntu Artful):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package heat - 1:6.1.2-0ubuntu1.1

---------------
heat (1:6.1.2-0ubuntu1.1) xenial; urgency=medium

  * Fixing heat error with unicode (LP: #1761629)
    - d/p/0001-Fixing-unicode-issue-when-to_dict-is-called-on-py2.7.patch

 -- Seyeong Kim <email address hidden> Mon, 23 Apr 2018 21:42:13 -0700

Changed in heat (Ubuntu Xenial):
status: Fix Committed → Fix Released
Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for heat has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package heat - 1:10.0.1-0ubuntu2~cloud0
---------------

 heat (1:10.0.1-0ubuntu2~cloud0) xenial-queens; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 heat (1:10.0.1-0ubuntu2) bionic; urgency=medium
 .
   * Fixing heat error with unicode (LP: #1761629)
     - d/p/0001-Fixing-unicode-issue-when-to_dict-is-called-on-py2.7.patch

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for heat has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package heat - 1:9.0.4-0ubuntu2~cloud0
---------------

 heat (1:9.0.4-0ubuntu2~cloud0) xenial-pike; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 heat (1:9.0.4-0ubuntu2) artful; urgency=medium
 .
   * Fixing heat error with unicode (LP: #1761629)
     - d/p/0001-Fixing-unicode-issue-when-to_dict-is-called-on-py2.7.patch

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for heat has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package heat - 1:8.0.6-0ubuntu1~cloud1
---------------

 heat (1:8.0.6-0ubuntu1~cloud1) xenial-ocata; urgency=medium
 .
   * Fixing heat error with unicode (LP: #1761629)
     - d/p/0001-Fixing-unicode-issue-when-to_dict-is-called-on-py2.7.patch

Corey Bryant (corey.bryant) wrote :

The verification of the Stable Release Update for heat has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Corey Bryant (corey.bryant) wrote :

This bug was fixed in the package heat - 1:6.1.2-0ubuntu1.1~cloud0
---------------

 heat (1:6.1.2-0ubuntu1.1~cloud0) trusty-mitaka; urgency=medium
 .
   * New update for the Ubuntu Cloud Archive.
 .
 heat (1:6.1.2-0ubuntu1.1) xenial; urgency=medium
 .
   * Fixing heat error with unicode (LP: #1761629)
     - d/p/0001-Fixing-unicode-issue-when-to_dict-is-called-on-py2.7.patch

tags: added: sts-sru-done
removed: sts-sru-needed

Reviewed: https://review.openstack.org/562887
Committed: https://git.openstack.org/cgit/openstack/heat/commit/?id=c4968824dbeaad849d16482cc7a6234e862714c6
Submitter: Zuul
Branch: stable/pike

commit c4968824dbeaad849d16482cc7a6234e862714c6
Author: Seyeong Kim <email address hidden>
Date: Thu Apr 5 15:10:01 2018 -0700

    Fixing unicode issue when to_dict is called on py2.7 env

    When using non-unicode old style user id such as Gāo
    Unicode error popup on py2.7 environment
    Fixing it on common/context.py

    Change-Id: I95e49f359410049ff5b254cd1b8ee16402c8719d
    Closes-Bug: #1761629
    (cherry picked from commit 4d71926b3afc50c3f16378de260b86a85e8d721d)

tags: added: in-stable-pike

This issue was fixed in the openstack/heat 9.0.5 release.

This issue was fixed in the openstack/heat 10.0.2 release.

Corey Bryant (corey.bryant) wrote :

This landed upstream in heat but I think heat is now using storyboard for bug tracking. I think the upstream task can be moved to fix released.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers