lbaas1 gates failed on master

Bug #1551383 reported by Oleksii Chuprykov on 2016-02-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OpenStack Heat
Fix Released
Critical
Rabi Mishra

Bug Description

2016-02-29 18:30:35.902 | 2016-02-29 18:30:35.853 | {1} heat_integrationtests.scenario.test_ceilometer_alarm.CeilometerAlarmTest.test_alarm [53.050075s] ... FAILED
2016-02-29 18:30:35.971 | 2016-02-29 18:30:35.916 |
2016-02-29 18:30:36.000 | 2016-02-29 18:30:35.958 | Captured traceback:
2016-02-29 18:30:36.010 | 2016-02-29 18:30:35.969 | ~~~~~~~~~~~~~~~~~~~
2016-02-29 18:30:36.030 | 2016-02-29 18:30:35.974 | Traceback (most recent call last):
2016-02-29 18:30:36.051 | 2016-02-29 18:30:36.001 | File "/opt/stack/new/heat/heat_integrationtests/scenario/test_ceilometer_alarm.py", line 52, in test_alarm
2016-02-29 18:30:36.078 | 2016-02-29 18:30:36.033 | self.metering_client.samples.create(**sample)
2016-02-29 18:30:36.102 | 2016-02-29 18:30:36.051 | File "/opt/stack/new/heat/.tox/integration/local/lib/python2.7/site-packages/ceilometerclient/v2/samples.py", line 57, in create
2016-02-29 18:30:36.104 | 2016-02-29 18:30:36.061 | body = self.api.post(url, json=[new]).json()
2016-02-29 18:30:36.149 | 2016-02-29 18:30:36.094 | File "/opt/stack/new/heat/.tox/integration/local/lib/python2.7/site-packages/ceilometerclient/openstack/common/apiclient/client.py", line 358, in post
2016-02-29 18:30:36.222 | 2016-02-29 18:30:36.182 | return self.client_request("POST", url, **kwargs)
2016-02-29 18:30:36.234 | 2016-02-29 18:30:36.194 | File "/opt/stack/new/heat/.tox/integration/local/lib/python2.7/site-packages/ceilometerclient/openstack/common/apiclient/client.py", line 345, in client_request
2016-02-29 18:30:36.274 | 2016-02-29 18:30:36.209 | self, method, url, **kwargs)
2016-02-29 18:30:36.302 | 2016-02-29 18:30:36.261 | File "/opt/stack/new/heat/.tox/integration/local/lib/python2.7/site-packages/ceilometerclient/openstack/common/apiclient/client.py", line 261, in client_request
2016-02-29 18:30:36.321 | 2016-02-29 18:30:36.272 | method, self.concat_url(endpoint, url), **kwargs)
2016-02-29 18:30:36.380 | 2016-02-29 18:30:36.313 | File "/opt/stack/new/heat/.tox/integration/local/lib/python2.7/site-packages/ceilometerclient/openstack/common/apiclient/client.py", line 201, in request
2016-02-29 18:30:36.410 | 2016-02-29 18:30:36.365 | raise exceptions.from_response(resp, method, url)
2016-02-29 18:30:36.459 | 2016-02-29 18:30:36.378 | ceilometerclient.openstack.common.apiclient.exceptions.Forbidden: RBAC Authorization Failed (HTTP 403) (Request-ID: req-aa631a1c-9bd1-49e3-8087-db045987e1a9)

Probably this commit is a root cause: https://review.openstack.org/#/c/234823/ .

Changed in heat:
status: New → Triaged
importance: Undecided → Critical
milestone: none → mitaka-3
Rabi Mishra (rabi) wrote :

Proposed a patch[1], to change that policy. Not sure if that would fix the issue and is acceptable to telemetry team. Waiting for jenkins results for https://review.openstack.org/#/c/286386/.

[1] https://review.openstack.org/#/c/286385/

Rabi Mishra (rabi) on 2016-03-01
Changed in heat:
assignee: nobody → Rabi Mishra (rabi)
Rabi Mishra (rabi) on 2016-03-02
Changed in heat:
status: Triaged → Fix Released
Changed in heat:
milestone: mitaka-3 → mitaka-rc1
milestone: mitaka-rc1 → mitaka-3

This issue was fixed in the openstack/ceilometer 6.0.0.0b3 development milestone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers