test_autoscaling_loadbalancer_neutron fails with a ConnectionError

Bug #1545587 reported by Thomas Herve on 2016-02-15
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Heat
Fix Released
Medium
Thomas Herve

Bug Description

Saw a bunch of times in recent builds. It fails in the test side trying to connect:

requests.exceptions.ConnectionError: ('Connection aborted.', BadStatusLine("''",))

Thomas Herve (therve) on 2016-02-15
Changed in heat:
importance: Undecided → Critical
importance: Critical → Low
Changed in heat:
status: New → Confirmed
Changed in heat:
importance: Low → Medium
milestone: none → mitaka-3

Fix proposed to branch: master
Review: https://review.openstack.org/281799

Changed in heat:
assignee: nobody → Thomas Herve (therve)
status: Confirmed → In Progress

Reviewed: https://review.openstack.org/281799
Committed: https://git.openstack.org/cgit/openstack/heat/commit/?id=df73c1c79852f697208bed6dc59c6b790aeb8eb8
Submitter: Jenkins
Branch: master

commit df73c1c79852f697208bed6dc59c6b790aeb8eb8
Author: Thomas Herve <email address hidden>
Date: Thu Feb 18 13:15:37 2016 +0100

    Ignore connection error when testing load balancer

    In the integration test with Neutron Load Balancer, we sometimes fail to
    connect to the Load Balancer when testing that the stack deployed
    successfully. Let's ignore those errors so that we retry for a bit in
    case it takes some time to be deployed.

    Change-Id: Ic97bd83fe56dc52fb49848d93e40cb57d1550a1f
    Closes-Bug: #1545587

Changed in heat:
status: In Progress → Fix Released

This issue was fixed in the openstack/heat 6.0.0.0b3 development milestone.

Reviewed: https://review.openstack.org/285967
Committed: https://git.openstack.org/cgit/openstack/heat/commit/?id=3bdcd6e2ce5481d6d2ddb77680586273d4e933e0
Submitter: Jenkins
Branch: stable/liberty

commit 3bdcd6e2ce5481d6d2ddb77680586273d4e933e0
Author: Thomas Herve <email address hidden>
Date: Thu Feb 18 13:15:37 2016 +0100

    Ignore connection error when testing load balancer

    In the integration test with Neutron Load Balancer, we sometimes fail to
    connect to the Load Balancer when testing that the stack deployed
    successfully. Let's ignore those errors so that we retry for a bit in
    case it takes some time to be deployed.

    Change-Id: Ic97bd83fe56dc52fb49848d93e40cb57d1550a1f
    Closes-Bug: #1545587
    (cherry picked from commit df73c1c79852f697208bed6dc59c6b790aeb8eb8)

tags: added: in-stable-liberty

This issue was fixed in the openstack/heat 5.0.2 release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers