When creating a KeyPair with Heat, KeyPair will not get deleted every times.

Bug #1415987 reported by David Hill on 2015-01-29
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Heat
Fix Released
Medium
Unassigned

Bug Description

Hi guys,

    We've hitting this bug with heat - Icehouse with nova - Icehouse... When we create a keypair with heat, it will not always get deleted for some reasons.

I've found this:
https://ask.openstack.org/en/question/45111/keypair-is-created-with-heat-stack-but-sometimes-not-deleted/

Dave

Angus Salkeld (asalkeld) on 2015-02-22
Changed in heat:
status: New → Triaged
importance: Undecided → Medium
Angus Salkeld (asalkeld) on 2015-03-24
tags: added: icehouse-backport-potential
removed: delete heat keypair nova
Changed in heat:
assignee: nobody → Limor Stotland (limor-bortman)
Limor Stotland (limor-bortman) wrote :

Hi,
Just to cover my basis.
Did you delete it from the same user or from a different user on the same project?
Because key pair is (surprising as it is...) per user and not per project,
And i create a stack with user admin and then delete it with the demo user: the stick was successfully delete
 BUT the key pair was not deleted and as admin i can still use it

Changed in heat:
assignee: Limor Stotland (limor-bortman) → nobody
Alan Pevec (apevec) on 2015-11-24
tags: removed: icehouse-backport-potential
Changed in heat:
assignee: nobody → zhaozhilong (zhaozhilong)
status: Triaged → In Progress
Changed in heat:
status: In Progress → Fix Committed
Changed in heat:
assignee: zhaozhilong (zhaozhilong) → nobody
Thomas Herve (therve) on 2017-02-24
Changed in heat:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers