RSS feed on NEW incoming

Bug #247647 reported by Pedro Fragoso
8
Affects Status Importance Assigned to Milestone
harvest
Fix Released
High
Dylan McCall

Bug Description

It would be nice to have a feed on the NEW incoming items.

Related branches

Revision history for this message
Benjamin Drung (bdrung) wrote :

python-pyrss2gen looks like a fitting tool: http://www.dalkescientific.com/Python/PyRSS2Gen.html

Changed in harvest:
status: New → Confirmed
Revision history for this message
Daniel Holbach (dholbach) wrote :

Does it gain us much over xml.dom.minidom? I'd like to keep the number of dependencies low, if we can.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Now that we use Django... at least in the django branch, maybe we can abuse something django-related for this?

Changed in harvest:
importance: Undecided → Low
status: Confirmed → Triaged
Changed in harvest:
importance: Low → Medium
Changed in harvest:
importance: Medium → High
Revision history for this message
Dylan McCall (dylanmccall) wrote :

Now that I'm looking at this problem properly, I'm realising there is a decent possibility of this torturing the server and being painfully slow :/
Of course, using RSS we have to provide everything up front, but that can be asking for a lot. (Which isn't good for an RSS feed, since these things should be fast and are typically expected to be so).

Some different ways to do this. We can have RSS feeds just for single packages, or only show packages (not opportunities) in said feeds. Maybe someone else has better ideas :)

Revision history for this message
Daniel Holbach (dholbach) wrote :

Maybe we should just start playing around with it. Maybe without having to use too many joins we can already deliver useful information. We could also limit to a number of opportunities (who wants to look at more than 1000 new opportunities?) or limit by date (who wants to look at opportunities that are over a week old and probably dealt with?)

Changed in harvest:
milestone: none → 0.2.8
status: Triaged → Fix Committed
assignee: nobody → Dylan McCall (dylanmccall)
Changed in harvest:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers