Port Harvest to Django >=1.3

Bug #1086279 reported by Daniel Holbach on 2012-12-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
harvest
High
Unassigned

Bug Description

harvest.ubuntu.com is going to be upgraded to precise. Let's make sure that Harvest can work with Django >= 1.3.

Daniel Holbach (dholbach) wrote :

https://launchpad.net/ubuntu/+source/python-django says:
 - for precise (12.04, LTS) we have 1.3.1
 - for quantal (12.10) we have 1.4.1
 - for raring (13.04) we have 1.4.2

Daniel Holbach (dholbach) wrote :

Not sure how much Django differs in these versions, preferrably we'd get the code in lp:harvest upgraded, so that it works on all the three versions.

Daniel Holbach (dholbach) wrote :

harvest.ubuntu.com was upgraded to precise (12.04) and seems to be working fine. It looks like the harvest code base is still compatible with Django 1.3. Still it'd be nice if we could make it so that Harvest works on 1.3 and on 1.4, so that we don't need to develop it in chroots. In any case this is less urgent now, degrading importance to 'high'.

Changed in harvest:
importance: Critical → High
Svetlana Belkin (belkinsa) wrote :

This bug is outdated, I will mark it as incomplte.

Changed in harvest:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers