Please backport facter 1.5.6-2ubuntu2.3 (main) from lucid-updates

Bug #910032 reported by Micah Gersten on 2011-12-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned

Bug Description

Please backport facter 1.5.6-2ubuntu2.3 (main) from lucid-updates to hardy.

Reason for the backport:
========================
Needed for backport of puppet (bug #910024). Package in ppa:micahg/ppa

Testing:
========
Mark off items in the checklist [X] as you test them, but please leave the checklist so that backporters can quickly evaluate the state of testing.

You can test-build the backport in your PPA with backportpackage:
$ backportpackage -u ppa:<lp username>/<ppa name> -s lucid -d hardy facter

* hardy:
[X] Package builds without modification
[ ] facter installs cleanly and runs

Reverse dependencies:
=====================
The following reverse-dependencies need to be tested against the new version of facter. For reverse-build-dependencies (-Indep), please test that the package still builds against the new facter. For reverse-dependencies, please test that the version of the package currently in the release still works with the new facter installed. Reverse- Recommends, Suggests, and Enhances don't need to be tested, and are listed for completeness-sake.

facter
------
* puppetmaster
  [ ] hardy (Reverse-Depends)
* puppet
  [ ] hardy (Reverse-Depends)

Testing:
========

* hardy:
[X] Package builds without modification
[X] facter installs cleanly and runs

Reverse dependencies:
=====================

* hardy:

facter
------
* puppetmaster
  [ ] hardy (Reverse-Depends)
  puppet-common: Depends: libaugeas-ruby1.8 which is a virtual package.
                 Depends: sysv-rc (>= 2.87) but 2.86.ds1-14.1ubuntu45.1 is installed. or
                          file-rc which is a virtual package.

* puppet
  [ ] hardy (Reverse-Depends)
  puppet-common: Depends: libaugeas-ruby1.8 which is a virtual package.
                 Depends: sysv-rc (>= 2.87) but 2.86.ds1-14.1ubuntu45.1 is installed. or
                          file-rc which is a virtual package.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers