apturl installs preferences in the wrong location for firefox 3.6.x

Bug #594864 reported by Chris Coulson
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Hardy Backports
High
Unassigned

Bug Description

Firefox in Hardy will be updated to 3.6.4 once it is released officially by Mozilla (see https://wiki.ubuntu.com/DesktopTeam/Specs/Lucid/FirefoxNewSupportModel/). This impacts on quite a few packages, with apturl being one of these.

apturl installs a preference file to /etc/firefox-3.0/pref. This needs to move to /etc/firefox/pref after the upgrade (see the security update in https://edge.launchpad.net/~ubuntu-mozilla-security/+archive/ppa/ for the change, which should be applied to the backported version too)

Changed in hardy-backports:
importance: Undecided → High
status: New → Triaged
Revision history for this message
John Vivirito (gnomefreak) wrote : Re: [Bug 594864] [NEW] apturl installs preferences in the wrong location for firefox 3.6.x

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 06/15/2010 06:26 PM, Chris Coulson wrote:
> Public bug reported:
>
> Firefox in Hardy will be updated to 3.6.4 once it is released officially
> by Mozilla (see
> https://wiki.ubuntu.com/DesktopTeam/Specs/Lucid/FirefoxNewSupportModel/).
> This impacts on quite a few packages, with apturl being one of these.
>
> apturl installs a preference file to /etc/firefox-3.0/pref. This needs
> to move to /etc/firefox/pref after the upgrade (see the security update
> in https://edge.launchpad.net/~ubuntu-mozilla-security/+archive/ppa/ for
> the change, which should be applied to the backported version too)
>
> ** Affects: hardy-backports
> Importance: High
> Status: Triaged
>
> ** Changed in: hardy-backports
> Importance: Undecided => High
>
> ** Changed in: hardy-backports
> Status: New => Triaged
>
Maybe i miss-understand you but Firefox is not going to be back ported
but will be pushed as a normal package update. off hand i don't recall
what repo it will be pushed to. Some of us are working on getting the
packages ready for <Lucid. more than likely it will be pushed to
proposed or security, but dont recall what was decided.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAkwY68QACgkQ9Plt3HZNXhNpzwCffoBxBM9Y2tgsl5Toon+cBU2r
qRQAnA90+bddXMrC2DnU0D5KF7UN49As
=Fl1E
-----END PGP SIGNATURE-----

Revision history for this message
John Vivirito (gnomefreak) wrote :

changed to apturl since this will not be a back-port but a security update.
damn didnt see you as reporter. Sorry Chris but i moved it out of back-port since it really doesn't belong there

affects: hardy-backports → apturl
Revision history for this message
John Vivirito (gnomefreak) wrote :

Changed back, sorry Chris, I didn't realize we pushed to -backports
Sorry about that

affects: apturl → hardy-backports
Changed in hardy-backports:
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers