Samba 3.4 needed to support Windows 7 domain joining

Bug #496160 reported by John Edwards on 2009-12-13
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned

Bug Description

Please backport Samba 3.4.3 to Ubuntu 8.04 to allow Windows 7 machines to join a Samba domain.

The current version in Ubuntu 8.04 is 3.0.28, which produces these errors when Windows 7 tries to join the domain:
[2009/12/07 14:07:12, 0] rpc_server/srv_netlog_nt.c:_net_auth_2(478) _net_auth2: creds_server_check failed. Rejecting auth request from client NORDIC-XP-16 machine account NORDIC-XP-16$
[2009/12/07 14:07:27, 0] lib/util_sock.c:read_data(534) read_data: read failure for 4 bytes to client 192.168.9.188. Error = Connection reset by peer
[2009/12/07 14:11:09, 0] rpc_server/srv_netlog_nt.c:_net_auth_2(478) _net_auth2: creds_server_check failed. Rejecting auth request from client NORDIC-XP-16 machine account NORDIC-XP-16$
[2009/12/07 14:11:21, 0] lib/util_sock.c:read_data(534) read_data: read failure for 4 bytes to client 192.168.9.188. Error = Connection reset by peer

Some more details:
  https://bugzilla.samba.org/show_bug.cgi?id=6099
  http://lists.samba.org/archive/samba-technical/2009-January/thread.html#62728

Other attempts at backporting:
  https://launchpad.net/~a.bono/+archive/samba3.4/+packages
  http://ubuntuforums.org/showthread.php?t=1225500

I've managed to successfully install the a.bono PPA packages onto Ubuntu 8.04, though they have a bug where the libpam-smbpass postinst and prerm files run 'pam-auth-update --package' which does not exist on Ubuntu 8.04. They were also built against libtalloc2 and libcap2, which also do not exist on Ubuntu 8.04 and so may need to be built.

Due to the large amount of differences between Samba 3.0 and 3.4 I do not think that a patch to 3.0 will be easy, so I am requesting a backport.

Thanks.

Serge van Ginderachter (svg) wrote :

An updated samba/winbind is also needed to join a Samba server to a Windows 2008 domain.

jmedina (jorgearma1982) wrote :

My vote to backport samba 3.4.x onto ubuntu 8.04 LTS, we have a lot of samba setups as domain controller with openldap for windows XP enviroments, we need to support win7, and as we already support 8.04 LTS I think it is important to samba 3.4 while we migrate to 10.04 which suports 3.4.

At the moment I have to compile samba 3.4 by hand.

Best regards.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers