please backport tomcat6 from intrepid

Bug #271784 reported by Florian Wallner on 2008-09-18
32
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Hardy Backports
Wishlist
Michael Casadevall

Bug Description

Please backport the package tomcat6 from intrepid to hardy. There are significant changes that would be very nice to have as a package on hardy.

Thank You,
     Florian Wallner

Michael Jeanson (mjeanson) wrote :

Here is the debdiff, I simply had to change the build depend from "default-jdk" to "openjdk-6-jdk" and adjust the JAVA_HOME accordingly in the rules file.

There is a test build available in my ppa: https://launchpad.net/~mjeanson/+archive

It runs the manager webapp on my laptop but I have not done further testing.

Michael Jeanson (mjeanson) wrote :

Corrected syntax of changelog entry.

Michael Jeanson (mjeanson) wrote :

Updated debdiff with new package version in Intrepid.

As a general rule of thumb, we attempt to avoid backporting server software due the high risk, low reward problem. If there is a concrete why we should risk breaking any tomcat user who has backports enabled, we will consider it, but if that isn't the case ...

Changed in hardy-backports:
status: New → Won't Fix
agent 8131 (agent-8131) wrote :

The tomcat packages are wisely split into separate packages per version. Anyone running tomcat in 8.04, for example, will, most likely, have the tomcat5.5 package installed. Therefore there is no risk of regression by backporting the tomcat6 package.

Furthermore, anyone who has enabled the backports repository without pinning is expressly configuring their system in a manner that suggests a policy of having the latest software regardless of possible incompatibilities. In my opinion, the traditional Linux policy is not to protect lesser experienced users from themselves at the expense of increased options for more experienced users. One could argue that more experienced users should be comfortable doing their own backports or installing from source. However, I feel that if users are willing to do the work of backporting their work should be accepted and users should be encouraged to using apt pinning whenever they enable backports. If this is not going to be the case for Ubuntu than perhaps a new backports repository for advanced users should be created.

Jim Wyatt (jimwyatt) wrote :

Justification for back porting is valid.

Changed in hardy-backports:
status: Won't Fix → In Progress
assignee: nobody → mcasadevall
status: In Progress → New
description: updated
Michael Jeanson (mjeanson) wrote :

Updated debdiff to latest Intrepid package.

Michael Jeanson (mjeanson) wrote :

Updated debdiff to latest Intrepid package.

If someone wants to test tomcat 6.0.18-0ubuntu6 I've updated the diff made by Michael and uploaded it to my ppa...seems to work fine on Hardy

Changed in hardy-backports:
status: New → Confirmed
Andy Kannberg (andy-kannberg) wrote :

Hi, I don't want to sound impatient - but when will the tomcat6 package be available in the backport repository ?
Cheers,
Andy

If you want you can test tomcat6 using my PPA and leave a comment if it works fine or not :)

Changed in hardy-backports:
importance: Undecided → Wishlist
agent 8131 (agent-8131) on 2009-05-21
tags: added: java server tomcat

Hi Alessio,

Any news on the tomcat6 being moved to the backport repository ?
Our Application engineer want to start testing Tomcat 6 on Hardy. Would be
cool if I could install it from the repository.

cheers,
Andy

2009/5/21 Alessio "Spinus" Moscatello <email address hidden>

> ** Changed in: hardy-backports
> Importance: Undecided => Wishlist
>
> --
> please backport tomcat6 from intrepid
> https://bugs.launchpad.net/bugs/271784
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Hardy Heron Backports: Confirmed
>
> Bug description:
> Please backport the package tomcat6 from intrepid to hardy. There are
> significant changes that would be very nice to have as a package on hardy.
>
> Thank You,
> Florian Wallner
>

Andy Kannberg (andy-kannberg) wrote :

Alessio,

I've added the PPA repo to my system, importing the key. All goes well,
apt-get update fetches the info from the PPA repo.
But when I search for tomcat6, it isn't found. What am I doing wrong ?

cheers,
Andy

2009/6/25 Andy Kannberg <email address hidden>

> Hi Alessio,
>
>
> Any news on the tomcat6 being moved to the backport repository ?
> Our Application engineer want to start testing Tomcat 6 on Hardy. Would be
> cool if I could install it from the repository.
>
> cheers,
> Andy
>
> 2009/5/21 Alessio "Spinus" Moscatello <email address hidden>
>
> ** Changed in: hardy-backports
>> Importance: Undecided => Wishlist
>>
>> --
>> please backport tomcat6 from intrepid
>> https://bugs.launchpad.net/bugs/271784
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug.
>>
>> Status in Hardy Heron Backports: Confirmed
>>
>> Bug description:
>> Please backport the package tomcat6 from intrepid to hardy. There are
>> significant changes that would be very nice to have as a package on hardy.
>>
>> Thank You,
>> Florian Wallner
>>
>
>

Hi Andy. I don't know when the backport request will be processed, because I wasn't able to contact Michael Casadevall...I will try to ask to another member of the Backport Team

Can you please paste me the line that you've added to your sources list? It should be:

deb http://ppa.launchpad.net/spinus/ppa/ubuntu hardy main

When you run "apt-get update" everything goes fine or there are any warnings/errors?

Regards,
Alessio

________________________________
Da: Andy Kannberg <email address hidden>
A: <email address hidden>
Inviato: Giovedì 25 giugno 2009, 12:08:47
Oggetto: Re: [Bug 271784] Re: please backport tomcat6 from intrepid

Alessio,

I've added the PPA repo to my system, importing the key. All goes well,
apt-get update fetches the info from the PPA repo.
But when I search for tomcat6, it isn't found. What am I doing wrong ?

cheers,
Andy

2009/6/25 Andy Kannberg <email address hidden>

> Hi Alessio,
>
>
> Any news on the tomcat6 being moved to the backport repository ?
> Our Application engineer want to start testing Tomcat 6 on Hardy. Would be
> cool if I could install it from the repository.
>
> cheers,
> Andy
>
> 2009/5/21 Alessio "Spinus" Moscatello <email address hidden>
>
> ** Changed in: hardy-backports
>> Importance: Undecided => Wishlist
>>
>> --
>> please backport tomcat6 from intrepid
>> https://bugs.launchpad.net/bugs/271784
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug.
>>
>> Status in Hardy Heron Backports: Confirmed
>>
>> Bug description:
>> Please backport the package tomcat6 from intrepid to hardy. There are
>> significant changes that would be very nice to have as a package on hardy.
>>
>> Thank You,
>> Florian Wallner
>>
>
>

--
please backport tomcat6 from intrepid
https://bugs.launchpad.net/bugs/271784
You received this bug notification because you are a member of Ubuntu
Backports Testing Team, which is subscribed to Hardy Backports.

@Andy: where are you searching for tomcat6? There's a known bug in Synaptic that won't allow the search function to work for added repositories. See bug #377932.

Are there any news when/if the backport is being added to the official repo?!

Andy Kannberg (andy-kannberg) wrote :

I haven't heard a thing about and to be honest, I haven't checked for a
while...

cheers,
Andy

2009/9/7 binwiederhier <email address hidden>

> Are there any news when/if the backport is being added to the official
> repo?!
>
> --
> please backport tomcat6 from intrepid
> https://bugs.launchpad.net/bugs/271784
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in Hardy Heron Backports: Confirmed
>
> Bug description:
> Please backport the package tomcat6 from intrepid to hardy. There are
> significant changes that would be very nice to have as a package on hardy.
>
> Thank You,
> Florian Wallner
>

How can we help speeding things up a bit? Is there anything I could do?

Regards,
Philipp

This fell off my radar. Working on it now.

Package uploaded to hardy-backports NEW.

Backporters ACK: tomcat6_6.0.18-0ubuntu3.1~hardy1

Changed in hardy-backports:
status: Confirmed → In Progress
James Westby (james-w) on 2009-09-14
Changed in hardy-backports:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers