Pidgin backport segfault in libc.so

Reported by Martin Smith on 2008-09-05
14
Affects Status Importance Assigned to Milestone
Hardy Backports
Undecided
Unassigned
Pidgin
Fix Released
Unknown
pidgin (Ubuntu)
Undecided
Unassigned

Bug Description

I just installed the latest Pidgin backport using Synatpic, and it segfaults in strcmp() in the C library. Please send me to the correct place to report this, if it isn't here :)

Here's the gdb trace:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb7003720 (LWP 25512)]
0xb75efd28 in strcmp () from /lib/tls/i686/cmov/libc.so.6

(gdb) bt
#0 0xb75efd28 in strcmp () from /lib/tls/i686/cmov/libc.so.6
#1 0xb64ab7d8 in ?? () from /usr/lib/purple-2/ssl-nss.so
#2 0xb786ba5e in purple_certificate_signed_by () from /usr/lib/libpurple.so.0
#3 0xb786df0f in ?? () from /usr/lib/libpurple.so.0
#4 0xb786e4b2 in ?? () from /usr/lib/libpurple.so.0
#5 0xb786b6f6 in purple_certificate_verify () from /usr/lib/libpurple.so.0
#6 0xb64aad78 in ?? () from /usr/lib/purple-2/ssl-nss.so
#7 0x080ad7f7 in ?? ()
#8 0xb77770ed in ?? () from /usr/lib/libglib-2.0.so.0
#9 0xb7742dd6 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#10 0xb7746193 in ?? () from /usr/lib/libglib-2.0.so.0
#11 0xb7746577 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#12 0xb7c43264 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#13 0x080ca79a in main ()

If it helps, at the same time I installed the following other things (this is a synaptic log of my session):

Upgraded the following packages:
apturl (0.2.2ubuntu1) to 0.2.6ubuntu1~hardy1
language-pack-en (1:8.04+20080708) to 1:8.04+20080805
language-pack-gnome-en (1:8.04+20080708) to 1:8.04+20080805
libpurple0 (1:2.4.3-0ubuntu1~hardy1) to 1:2.5.0-0ubuntu2~hardy1
libsmbclient (3.0.28a-1ubuntu4.4) to 3.0.28a-1ubuntu4.5
libsvn1 (1.4.6dfsg1-2ubuntu1) to 1.5.1dfsg1-1ubuntu2~hardy1
pidgin (1:2.4.3-0ubuntu1~hardy1) to 1:2.5.0-0ubuntu2~hardy1
pidgin-data (1:2.4.3-0ubuntu1~hardy1) to 1:2.5.0-0ubuntu2~hardy1
samba-common (3.0.28a-1ubuntu4.4) to 3.0.28a-1ubuntu4.5
smbclient (3.0.28a-1ubuntu4.4) to 3.0.28a-1ubuntu4.5
smbfs (3.0.28a-1ubuntu4.4) to 3.0.28a-1ubuntu4.5
subversion (1.4.6dfsg1-2ubuntu1) to 1.5.1dfsg1-1ubuntu2~hardy1
subversion-tools (1.4.6dfsg1-2ubuntu1) to 1.5.1dfsg1-1ubuntu2~hardy1

Installed the following packages:
libneon27-gnutls (0.27.2-1)

Related branches

Martin Smith (martinb3) wrote :

Hello again -- I reported the bug to the Pidgin developers. Their Trac ticket on it can be found at http://developer.pidgin.im/ticket/7013. They've accepted and fixed it (the diff is at http://developer.pidgin.im/viewmtn/revision/diff/254e5a24031a74103097db812ae3e723d696c11d/with/3cbc74478c8df61d53804d0363dc936a3e0adeb7).

I'm not sure how many people this bug affects that are using Hardy backports, but if SSL certs make Pidgin as unstable for everyone as it was for me, I'd suggest removing the package until the fixed version can be backported. I'd imagine this probably does affect most users since everything seems to use SSL and libnss except AIM and Yahoo. IRC and Jabber both cause Pidgin to crash.

For some reason my email and the launchpad account I dabbled for a short
period keep getting associated with another user (likely due to the use of
the nickname SpecialK). Correspondence sent to this address will not reach
the person who filed this bug. I've tried to sort this confusion out before,
but no one really seemed to care.

Scott K.

On Tue, Sep 9, 2008 at 6:59 AM, Martin <email address hidden> wrote:

> Hello again -- I reported the bug to the Pidgin developers. Their Trac
> ticket on it can be found at http://developer.pidgin.im/ticket/7013.
> They've accepted and fixed it (the diff is at
>
> http://developer.pidgin.im/viewmtn/revision/diff/254e5a24031a74103097db812ae3e723d696c11d/with/3cbc74478c8df61d53804d0363dc936a3e0adeb7
> ).
>
> I'm not sure how many people this bug affects that are using Hardy
> backports, but if SSL certs make Pidgin as unstable for everyone as it
> was for me, I'd suggest removing the package until the fixed version can
> be backported. I'd imagine this probably does affect most users since
> everything seems to use SSL and libnss except AIM and Yahoo. IRC and
> Jabber both cause Pidgin to crash.
>
> --
> Pidgin backport segfault in libc.so
> https://bugs.launchpad.net/bugs/265055
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Iain Lane (laney) wrote :

Thanks a lot for reporting the bug upstream, Martin. We'll backport the fix from pidgin mtn to Intrepid after Pidgin 2.5.1 lands there. Then we can look at doing another backport for Hardy.

Changed in pidgin:
status: Unknown → Fix Released
Iain Lane (laney) on 2008-09-19
Changed in hardy-backports:
status: New → Invalid
Changed in pidgin:
assignee: nobody → laney
status: New → In Progress
Iain Lane (laney) wrote :

Patch attached which should fix this issue. Can be dropped after Pidgin 2.5.2 is released including this patch.

Changed in pidgin:
assignee: laney → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pidgin - 1:2.5.1-0ubuntu2

---------------
pidgin (1:2.5.1-0ubuntu2) intrepid; urgency=low

  * debian/patches/06_ssl_null_pointer_deref.patch:
    - Backport fix from upstream MTN to fix null pointer defererence leading
      to a crash. This can be dropped if and when we get 2.5.2. (LP: #265055)

 -- Iain Lane <email address hidden> Fri, 19 Sep 2008 23:05:53 +0100

Changed in pidgin:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.