please backport git-* 1.5.6 to hardy

Bug #250526 reported by Martin Röhricht on 2008-07-21
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Hardy Backports
Wishlist
Unassigned

Bug Description

Within the last weeks the Linux kernel's version control system git advanced to release 1.5.6. A numereous number of bugs was fixed between hardy's release 1.5.4 and the current release 1.5.6, especially regarding HTTP support. Debian's backport from backports.org is not built with curl support as far as I remember. It would be a great gift to see the last maintenance release of git before it advances to release 1.6.

I'm confirming this one, it builds and is installable. Version tested: 1.5.6.3

(source package is git-core, git is a different package)

Changed in hardy-backports:
status: New → Confirmed
importance: Undecided → Wishlist
Scott Kitterman (kitterman) wrote :

Git has a stack of rdepends and these need to be tested to determine if they need to be updated too.

Changed in hardy-backports:
status: Confirmed → Incomplete
pranith (bobby-prani) wrote :

How do we proceed on this?

Scott Kitterman (kitterman) wrote :

Somebody who cares to have this backport done needs to test the rdepends, see if they work/need updating too, and document the results.

Pau Garcia Quiles (pgquiles) wrote :

The latest version of git is always available from my PPA for Hardy and Jaunty:
http://launchpad.net/~pgquiles/+archive/ppa

Currently, latest = 1.6.4.2

As previously mentioned, testing of the rdepends is what is blocking this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers