Please backport libgems-ruby from Intrepid

Bug #225466 reported by agent 8131
16
Affects Status Importance Assigned to Milestone
Hardy Backports
Fix Released
Wishlist
Unassigned
libgems-ruby (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

The current version in Debian testing is 1.0.1:
http://packages.debian.org/source/lenny/libgems-ruby

This version drastically improves memory consumption used during gem updates. The 0.9.4 version can use up all available memory during an update. I would like to see this added to intrepid and hardy-backports. Thank you.

Revision history for this message
Neil Wilson (neil-aldur) wrote : Re: Please sync libgems-ruby from Debian

Current version is 1.1.1. Please sync from Debian

description: updated
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Already in Intrepid, closing the Ubuntu task.

libgems-ruby | 1.1.1-1 | http://archive.ubuntu.com intrepid/universe Sources

Changed in libgems-ruby:
status: New → Invalid
Revision history for this message
Emilio Pozuelo Monfort (pochu) wrote :

Unsubscribing ubuntu-universe-sponsors

Revision history for this message
Neil Wilson (neil-aldur) wrote :

Builds OK on Hardy (as you would expect - it's ruby!)

Changed in hardy-backports:
status: New → Confirmed
Revision history for this message
Neil Wilson (neil-aldur) wrote :
Revision history for this message
Neil Wilson (neil-aldur) wrote :

Please test packages. If you have the existing rubygems packages in place then a simple

dpkg -i libgems*.deb
dpkg -i rubygems*.deb

should do the trick.

Revision history for this message
John Leach (johnleach) wrote :

Installed Neil's backported packages on Hardy, installed some gems and used them successfully. No problems!

Revision history for this message
agent 8131 (agent-8131) wrote :

I've installed the versions from intrepid on hardy without problems and would like to see them made available as backports.

Revision history for this message
Neil Wilson (neil-aldur) wrote :

Good to go I feel.

Changed in hardy-backports:
status: Confirmed → Triaged
Revision history for this message
agent 8131 (agent-8131) wrote :

This is still not available in hardy-backports as I have requested.

Changed in hardy-backports:
status: Triaged → Confirmed
Revision history for this message
Neil Wilson (neil-aldur) wrote :

'Triaged' means tested in this process. It won't get done any faster if you don't follow the process

https://help.ubuntu.com/community/UbuntuBackports#head-5523e47badd3e3ea3f7aebebb0ebf23bfc76129f

We are now in the hands of the backporting team, who are volunteers and busy guys. I find patience and the right level of lobbying on IRC tends to do the trick.

Changed in hardy-backports:
status: Confirmed → Triaged
Revision history for this message
Scott Kitterman (kitterman) wrote :

Ack from ubuntu-backporters.

Changed in hardy-backports:
importance: Undecided → Wishlist
status: Triaged → In Progress
Revision history for this message
Colin Watson (cjwatson) wrote :

 * Trying to backport libgems-ruby...
  - <libgems-ruby_1.1.1.orig.tar.gz: downloading from librarian>
  - <libgems-ruby_1.1.1-1.diff.gz: downloading from librarian>
  - <libgems-ruby_1.1.1-1.dsc: downloading from librarian>
I: Extracting libgems-ruby_1.1.1-1.dsc ... done.
I: Building backport of libgems-ruby-1.1.1 as 1.1.1-1~hardy1 ... done.

Changed in hardy-backports:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers