Update hardy's fontforge to 0.0.20080330

Bug #215755 reported by Arne Goetje on 2008-04-11
6
Affects Status Importance Assigned to Milestone
Hardy Backports
Wishlist
Unassigned
fontforge (Ubuntu)
Wishlist
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Wishlist
Unassigned

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects ubuntu/fontforge
 status new
 importance wishlist
 subscribe ubuntu-main-sponsors

Please sync fontforge 0.0.20080330-1 (main) from Debian unstable (main).

Reason: Version 0.0.20080330 changed the sfd file format. Font files which
were generated with fontforge >= 0.0.20080330 cannot be opened anymore with
older fontforge versions. For font developers using Hardy, this will be crucial
for their work. The DejaVu and Freefont projects have already switched to the
new format. Their future source packages cannot be built with older fontforge
versions anymore.

Changelog since current hardy version 0.0.20071110-1build2:

fontforge (0.0.20080330-1) unstable; urgency=low

  [Davide Viti]
  * New upstream release (Closes: #472772).
  * Updated version of showttf.c

  [ Kęstutis Biliūnas ]
  * debian/fontforge-doc.linda-override: removed this file, since linda no
    longer exists in the unstable distribution, and removed corresponding
    statements in the debian/rules install target.
  * debian/fontforge-doc.doc-base: an entry in the Section field changed
    from X11 to Graphics debian/rules install target.

 -- Davide Viti <email address hidden> Tue, 01 Apr 2008 13:42:53 +0200

fontforge (0.0.20080203-1) unstable; urgency=low

  * New upstream release (Closes: #465829).

  [ Kęstutis Biliūnas ]
  * debian/control:
    - bumped Standards-Version to 3.7.3. No changes required.
    - set the pkg-fonts team as Maintainer.
  * debian/patches:
    - fixed the patches 020_fix_pyext_path.diff and
      900_debian_HelpDir_path.diff.
    - removed the patch 021_libspiro_link.diff -- fixed upstream.
  * debian/rules:
    - in the install target removed the /usr/include directory.

  [ Christian Perrier ]
  * debian/copyright:
    - [Lintian] use the Unicode copyright symbol in copyright. Adapt
      copyright years.

 -- Christian Perrier <email address hidden> Wed, 20 Feb 2008 05:48:34 +0100

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFH/4LJbp/QbmhdHowRAkYxAJ9/GqdKqRUgzajiVVzf15B4/o+gzgCfcKXz
QxMb1dVg5jOQVf9cXtRpAHY=
=I7bS
-----END PGP SIGNATURE-----

Daniel Holbach (dholbach) wrote :

I'm OK from a Sponsors perspective. Subscribing ubuntu-release.

Colin Watson (cjwatson) on 2008-04-30
Changed in fontforge:
milestone: none → ubuntu-8.04.1
Khaled Hosny (khaledhosny) wrote :

Any chance this will get into hardy, I can't edit any sfd file created by new versions and I don't want to mess with building from source.

Martin Pitt (pitti) wrote :

New version is in intrepid.

Changed in fontforge:
milestone: ubuntu-8.04.1 → none
status: New → Fix Released
Martin Pitt (pitti) wrote :

Changed the bug to be an SRU request. Please include a complete changelog between hardy's current and this version. How much has the new version be tested? Does the UI change? Does the new version break compatibility with any format the current version still supports?

Changed in fontforge:
status: New → Incomplete
Khaled Hosny (khaledhosny) wrote :

The SFD formate got slightly changed in the new version, any old file can be open but will be always saved in the new formate. There might be many changes in the UI since current release in hardy is several releases behind (fontforge has a new release every month or so).

Khaled Hosny (khaledhosny) wrote :

Upstream changlog can be found here http://fontforge.sourceforge.net/changelog.html, there is around 500 line changelog between 9-Nov-2007 and 30-Mar-2008 only.

Martin Pitt (pitti) wrote :

To be honest this is a perfect candidate for a backport. Except from being old (which just happens in every stable release), there is nothing that warrants a SRU for Hardy here. Subscribing backports folks.

Changed in fontforge:
status: Incomplete → Won't Fix

I've built version 0.0.20080429-1 under Hardy with prevu and it works, but I don't know it enough to test all the rdeps...

Changed in hardy-backports:
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

rdepends need to be tested. Do other packages have to be able to read the new format?

Changed in hardy-backports:
importance: Undecided → Wishlist
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers