haguichi crashes on right click

Bug #755656 reported by Andreas B. Wagner on 2011-04-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Haguichi
Fix Released
High
Stephen Brandt

Bug Description

Hello, I was testing Haguichi 1.0.7 on ArchLinux when I tried to right click on a listed network and a listed username. Each caused Haguichi to crash with this error to stderr:

Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.ArgumentException: Value does not fall within the expected range.
  at Menus.NetworkMenu.SetNetwork (.Network netw) [0x00000] in <filename unknown>:0
  at NetworkView.ShowPopupMenu () [0x00000] in <filename unknown>:0
  at NetworkView.OnButtonPressEvent (Gdk.EventButton evnt) [0x00000] in <filename unknown>:0
  at Gtk.Widget.buttonpressevent_cb (IntPtr widget, IntPtr evnt) [0x00000] in <filename unknown>:0
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.buttonpressevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Haguichi.Main(System.String[] args)

Stephen Brandt (ztefn) wrote :

Can you send me the output of "hamachi list"? Then I'll try to get it reproduced.

 * [andreas_network2]

Also, it may be relevant that I need to put the following in my .xinitrc in order for haguichi to run:

 if which dbus-launch >/dev/null && test -z "$DBUS_SESSION_BUS_ADDRESS"; then
        eval "$(dbus-launch --sh-syntax --exit-with-session)"
 fi

Stephen Brandt (ztefn) wrote :

Using the same "list" (it's actually just a single empty network) doesn't give me any error. Do you experience the same error when running in demo mode (haguichi --demo)? And does running in debug mode (haguichi --debug) provide any clues?

About your .xinitrc, do you mean DBus isn't launched when you start your GNOME session? If so, it doesn't seem like a Haguichi specific problem.

Changed in haguichi:
status: New → Incomplete
Stephen Brandt (ztefn) wrote :

Andreas,

If you don't want your bug report to rot away, please gather some more information and answer my questions above.

I'm not using gnome, I'm using the musca window manager. Maybe haguichi has problems with non-gnome window managers.

Sorry for the delayed response.

Here is the stdout and stderr from running haguichi --debug --demo

[14:16:38.5984670 INFO] [Main] Greetings, I am Haguichi 1.0.7
[14:16:38.6918980 ENVIRONMENT] [Main] Registering session
[14:16:38.6995850 ENVIRONMENT] [Main] Using the following path for locales: /usr/lib/haguichi/../../share/locale
[14:16:38.7396170 ENVIRONMENT] [Settings.Init] Default commands for this session: GNOME
[14:16:38.8496820 HAMACHI] [Hamachi.GetInfo] Hamachi, a zero-config virtual private networking utility, ver 0.9.9.9-20

  version : hamachi-lnx-0.9.9.9-20
  pid : 12329
  status : offline
  nickname : abw-1

[14:16:38.8496900 ENVIRONMENT] [Settings.Init] Command for sudo: kdesu
[14:16:38.8509360 ENVIRONMENT] [Hamachi.DetermineScriptDirectory] /etc/rc.d
[14:16:39.0614690 HAMACHI] [Network.DetermineOwnership] hamachi network 044-433-877
    id : 044-433-877
    name : Contributors
    type : Mesh
    owner : This computer
    status : unlocked
    approve : manual
[14:16:39.0675880 HAMACHI] [Network.DetermineOwnership] hamachi network 044-751-972
    id : 044-751-972
    name : Portal Ubuntu
    type : Mesh
    owner : 092-466-858
[14:16:39.0684510 HAMACHI] [Network.DetermineOwnership] hamachi network 040-447-340
    id : 040-447-340
    name : WebUpd8
    type : Mesh
    owner : 094-409-761
[14:16:39.0912660 GUI] [MainWindow] State changed: 0
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.ArgumentException: Value does not fall within the expected range.
  at Menus.MemberMenu.SetMember (.Member memb, .Network netw) [0x00000] in <filename unknown>:0
  at NetworkView.ShowPopupMenu () [0x00000] in <filename unknown>:0
  at NetworkView.OnButtonPressEvent (Gdk.EventButton evnt) [0x00000] in <filename unknown>:0
  at Gtk.Widget.buttonpressevent_cb (IntPtr widget, IntPtr evnt) [0x00000] in <filename unknown>:0
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.buttonpressevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Haguichi.Main(System.String[] args)

Stephen Brandt (ztefn) wrote :

Thanks, this rules out any problems related to the network list.

As for window managers or desktop environments, Haguichi officially supports GNOME and KDE. For other environments you will have to locate the problem yourself (I cannot not install dozens exotic environments, that are not even available in the repo). However, once you have located the problem, I will try to help creating a fix.

Mao12345 (mao-250) wrote :

i have gnome and have the same problem, haguichi fails with hamachi and logmein-hamachi

Stephen Brandt (ztefn) wrote :

Hi Mao,

Could you please provide some more details:
1) What distro are you running?
2) What versions of haguichi and hamachi are you running?
3) Do you have both hamachi and logmein-hamachi installed on the same machine?
4) What makes you so sure it's the same problem?
5) Have you run haguichi in debug mode?* If so, what is the output?

* Fully quit Haguichi (Client -> Quit) and start it in a terminal using "haguichi --debug" (without the quotes)

Stephen Brandt (ztefn) wrote :

[posting again because Mao12345 was not subscribed to this bug report...]

Hi Mao,

Could you please provide some more details:
1) What distro are you running?
2) What versions of haguichi and hamachi are you running?
3) Do you have both hamachi and logmein-hamachi installed on the same machine?
4) What makes you so sure it's the same problem?
5) Have you run haguichi in debug mode?* If so, what is the output?

* Fully quit Haguichi (Client -> Quit) and start it in a terminal using "haguichi --debug" (without the quotes)

Stephen Brandt (ztefn) wrote :

Hi Andreas and Mao,

I have been able to reproduce the crash on Fedora 15, isolate the piece of code that triggered it, and create a fix for it [1].

[1] http://bazaar.launchpad.net/~ztefn/haguichi/1.0/revision/190

Changed in haguichi:
assignee: nobody → Stephen Brandt (ztefn)
importance: Undecided → Medium
status: Incomplete → Fix Committed
milestone: none → 1.0.9
Stephen Brandt (ztefn) on 2011-06-09
Changed in haguichi:
importance: Medium → High
Mao12345 (mao-250) wrote :

Hi Stephen

how can i install your fix in arch?
i have bzr installed but i dont know how it work

i have another problem, haguichi says that it not configured but when i press the configure button nothing happen

thanks

Stephen Brandt (ztefn) wrote :

Hi Mao,

You can get the latest code using the command "bzr branch lp:haguichi". If you have MonoDevelop installed, open the solution file (Haguichi.sln). Inside the solution's tree there's a "build" project. Right click this project and choose "Build" to generate a source tarball in the project folder. Once you have extracted this tarball you can install it by running "./configure", "make" and "make install" from this folder.

About the "Not configured" message, are you using version 1.0.8? If so please start Haguichi from the terminal using "haguichi --debug", click the configure button and send me all debug output.

Stephen Brandt (ztefn) wrote :

Btw, I plan to release 1.0.9 within a few days.

Mao12345 (mao-250) wrote :

Hi Stephen, many thanks
you've solved all the problems
the configuration problem it was because hamachi was open in the background, and that does not allow me to configure it.
for version 1.0.9 or 1.1 you could add the chat function, but that's not too important
sorry for my english

thank you very much

Mao

Stephen Brandt (ztefn) wrote :

Hi Mao,

There is no chat function. Or as I described in the FAQ [1] more elaborately: "The Hamachi client on Linux doesn’t support chat by itself. But fortunately you can chat with people in your network using an application like Pidgin (using ‘Bonjour protocol’) or Empathy (using ‘People nearby’) on both ends."

[1] http://www.haguichi.net/faq/

Stephen Brandt (ztefn) on 2011-06-17
Changed in haguichi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers