Haguichi won't build on Arch Linux

Reported by Andreas B. Wagner on 2011-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Haguichi
Undecided
Unassigned

Bug Description

Hello,

I am maintaining the haguichi package for arch linux and when trying to build the 1.0.4 package:

# Maintainer: Andreas B. Wagner <email address hidden>
# Contributor: scrawl <email address hidden>

pkgname=haguichi
pkgver=1.0.4
_series=1.0
pkgrel=1
pkgdesc="Hamachi GUI"
arch=('i686' 'x86_64')
url="http://www.haguichi.net"
license=('GPLv2')
depends=('mono' 'gnome-sharp' 'notify-sharp-svn')
source=("http://launchpad.net/$pkgname/$_series/$pkgver/+download/$pkgname-$pkgver.tar.gz" 'haguichi-scalable.svg')
md5sums=('77630d576da07b476d01418106fd7c27'
         '456c215081b3702287a50cddb42fec0d')

build() {
 cd $srcdir/$pkgname-$pkgver
 ./configure --prefix=/usr
 make DESTDIR=$pkgdir install || return 1
 install -Dm644 $srcdir/haguichi-scalable.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/haguichi.svg
}

I get these errors:

==> Making package: haguichi 1.0.4-1 (Sun Jan 30 11:54:38 EST 2011)
==> Checking Runtime Dependencies...
==> Checking Buildtime Dependencies...
==> Retrieving Sources...
  -> Found haguichi-1.0.4.tar.gz
  -> Found haguichi-scalable.svg
==> Validating source files with md5sums...
    haguichi-1.0.4.tar.gz ... Passed
    haguichi-scalable.svg ... Passed
==> Extracting Sources...
  -> Extracting haguichi-1.0.4.tar.gz with bsdtar
==> Removing existing pkg/ directory...
==> Entering fakeroot environment...
==> Starting build()...
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking for pkg-config... /usr/bin/pkg-config
checking for gmcs... /usr/bin/gmcs
checking pkg-config is at least version 0.9.0... yes
checking for GTK_SHARP_20... yes
checking for NOTIFY_SHARP... yes
checking for GCONF_SHARP_20... yes
checking for GLIB_SHARP_20... yes
checking for NDESK_DBUS_10... yes
configure: creating ./config.status
config.status: creating haguichi
config.status: creating Makefile
Making install in .
make[1]: Entering directory `/home/andreas/abs/haguichi/src/haguichi-1.0.4'
mkdir -p 'bin/Release'
cp 'haguichi' 'bin/Release/haguichi'
chmod +x 'bin/Release/haguichi'
mkdir -p bin/Release
gmcs -noconfig -codepage:utf8 -warn:4 -optimize- -out:bin/Release/Haguichi.exe -target:exe './src/Command.cs' './src/CommandsEditor.cs' './src/Connection.cs' './src/Controller.cs' './src/Debug.cs' './src/GlobalEvents.cs' './src/Hamachi.cs' './src/Main.cs' './src/Member.cs' './src/Network.cs' './src/NetworkView.cs' './src/Notify.cs' './src/PanelIcon.cs' './src/Status.cs' './src/TextStrings.cs' './src/Config/Client.cs' './src/Config/Key.cs' './src/Config/Settings.cs' './src/Dialogs/About.cs' './src/Dialogs/Base.cs' './src/Dialogs/ChangeNick.cs' './src/Dialogs/Confirm.cs' './src/Dialogs/JoinCreate.cs' './src/Dialogs/Message.cs' './src/Dialogs/RunTunCfg.cs' './src/Menus/CommandMenuItem.cs' './src/Menus/MemberMenu.cs' './src/Menus/Menubar.cs' './src/Menus/NetworkMenu.cs' './src/Menus/Quick.cs' './src/Widgets/GroupBox.cs' './src/Widgets/IndentHBox.cs' './src/Windows/Preferences.cs' './src/MainWindow.cs' './src/Dialogs/AddEditCommand.cs' './src/Dialogs/ChooseIcon.cs' './src/Dialogs/Information.cs' './src/Dialogs/NotInstalled.cs' './src/Dialogs/NotConfigured.cs' './src/Platform.cs' './src/Dialogs/SendRequest.cs' './src/Dialogs/ChangePassword.cs' './src/Dialogs/Attach.cs' './src/Utilities.cs' '-resource:./data/icons/hicolor/16x16/haguichi.png,16x16.haguichi' '-resource:./data/icons/hicolor/22x22/haguichi-connected.png,22x22.connected' '-resource:./data/icons/hicolor/22x22/haguichi-connecting-1.png,22x22.connecting-1' '-resource:./data/icons/hicolor/22x22/haguichi-connecting-2.png,22x22.connecting-2' '-resource:./data/icons/hicolor/22x22/haguichi-connecting-3.png,22x22.connecting-3' '-resource:./data/icons/hicolor/22x22/haguichi-disconnected.png,22x22.disconnected' '-resource:./data/icons/hicolor/22x22/haguichi.png,22x22.haguichi' '-resource:./data/icons/hicolor/24x24/haguichi.png,24x24.haguichi' '-resource:./data/icons/hicolor/32x32/haguichi.png,32x32.haguichi' '-resource:./data/icons/hicolor/48x48/haguichi.png,48x48.haguichi' '-resource:./data/icons/hicolor/64x64/haguichi.png,64x64.haguichi' '-resource:./data/icons/hicolor/24x24/haguichi-connected.png,24x24.connected' '-resource:./data/icons/hicolor/24x24/haguichi-connecting-1.png,24x24.connecting-1' '-resource:./data/icons/hicolor/24x24/haguichi-connecting-2.png,24x24.connecting-2' '-resource:./data/icons/hicolor/24x24/haguichi-connecting-3.png,24x24.connecting-3' '-resource:./data/icons/hicolor/24x24/haguichi-disconnected.png,24x24.disconnected' '-resource:./data/icons/hicolor/16x16/haguichi-connected.png,16x16.connected' '-resource:./data/icons/hicolor/16x16/haguichi-connecting-1.png,16x16.connecting-1' '-resource:./data/icons/hicolor/16x16/haguichi-connecting-2.png,16x16.connecting-2' '-resource:./data/icons/hicolor/16x16/haguichi-connecting-3.png,16x16.connecting-3' '-resource:./data/icons/hicolor/16x16/haguichi-disconnected.png,16x16.disconnected' '-resource:./data/icons/hicolor/12x12/haguichi-node-offline.png,12x12.node-offline' '-resource:./data/icons/hicolor/12x12/haguichi-node-online.png,12x12.node-online' '-resource:./data/icons/hicolor/12x12/haguichi-node-unapproved.png,12x12.node-unapproved' '-resource:./data/icons/hicolor/12x12/haguichi-node-unreachable.png,12x12.node-unreachable' '-resource:./data/icons/hicolor/18x18/haguichi-node-offline.png,18x18.node-offline' '-resource:./data/icons/hicolor/18x18/haguichi-node-online.png,18x18.node-online' '-resource:./data/icons/hicolor/18x18/haguichi-node-unapproved.png,18x18.node-unapproved' '-resource:./data/icons/hicolor/18x18/haguichi-node-unreachable.png,18x18.node-unreachable' -r:System -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/pango-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/atk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gdk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gtk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/glib-sharp.dll -r:Mono.Posix -r:/usr/lib/mono/notify-sharp/notify-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/pango-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/atk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gdk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gtk-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/glib-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/gconf-sharp.dll -r:/usr/lib/pkgconfig/../../lib/mono/gtk-sharp-2.0/glib-sharp.dll -r:/usr/lib/mono/ndesk-dbus-1.0/NDesk.DBus.dll
./src/Dialogs/SendRequest.cs(30,24): warning CS0108: `Dialogs.SendRequest.Name' hides inherited member `Gtk.Widget.Name'. Use the new keyword if hiding was intended
/usr/lib/mono/gac/gtk-sharp/2.12.0.0__35e10195dab3c99f/gtk-sharp.dll (Location of the symbol related to previous warning)
./src/Command.cs(134,27): warning CS0168: The variable `e' is declared but never used
./src/Command.cs(174,27): warning CS0168: The variable `e' is declared but never used
./src/CommandsEditor.cs(169,22): warning CS0219: The variable `bc1' is assigned but its value is never used
./src/CommandsEditor.cs(426,36): warning CS0219: The variable `edit' is assigned but its value is never used
./src/CommandsEditor.cs(435,32): warning CS0219: The variable `add' is assigned but its value is never used
./src/Controller.cs(113,35): warning CS0219: The variable `dlgNotConfigured' is assigned but its value is never used
./src/Controller.cs(118,34): warning CS0219: The variable `dlgNotInstalled' is assigned but its value is never used
./src/Controller.cs(233,34): warning CS0168: The variable `ex' is declared but never used
./src/Controller.cs(312,33): warning CS0219: The variable `dlg3' is assigned but its value is never used
./src/Controller.cs(333,33): warning CS0219: The variable `dlg2' is assigned but its value is never used
./src/Controller.cs(380,37): warning CS0219: The variable `msgDlg' is assigned but its value is never used
./src/Controller.cs(470,37): warning CS0219: The variable `dlg1' is assigned but its value is never used
./src/Controller.cs(890,20): warning CS0219: The variable `n' is assigned but its value is never used
./src/Controller.cs(920,20): warning CS0219: The variable `n' is assigned but its value is never used
./src/Controller.cs(950,20): warning CS0219: The variable `n' is assigned but its value is never used
./src/Controller.cs(980,20): warning CS0219: The variable `n' is assigned but its value is never used
./src/GlobalEvents.cs(251,24): warning CS0219: The variable `attachDlg' is assigned but its value is never used
./src/Hamachi.cs(421,29): warning CS0219: The variable `delDlg' is assigned but its value is never used
./src/Hamachi.cs(438,29): warning CS0219: The variable `delDlg' is assigned but its value is never used
./src/Hamachi.cs(445,29): warning CS0219: The variable `delDlg' is assigned but its value is never used
./src/Hamachi.cs(481,29): warning CS0219: The variable `delDlg' is assigned but its value is never used
./src/Hamachi.cs(703,39): warning CS0168: The variable `e' is declared but never used
./src/Hamachi.cs(751,39): warning CS0168: The variable `e' is declared but never used
./src/Network.cs(306,32): warning CS0219: The variable `passwordWindow' is assigned but its value is never used
./src/Config/Client.cs(226,31): warning CS0168: The variable `e' is declared but never used
./src/Config/Client.cs(242,31): warning CS0168: The variable `e' is declared but never used
./src/Dialogs/Confirm.cs(38,20): warning CS0219: The variable `cancelBut' is assigned but its value is never used
./src/Dialogs/JoinCreate.cs(152,26): warning CS0219: The variable `bc9' is assigned but its value is never used
./src/Dialogs/JoinCreate.cs(488,20): warning CS0168: The variable `head' is declared but never used
./src/Dialogs/JoinCreate.cs(489,20): warning CS0168: The variable `mesg' is declared but never used
./src/Dialogs/Message.cs(46,24): warning CS0618: `Gtk.TextBuffer.Insert(Gtk.TextIter, string)' is obsolete: `Replaced by 'ref TextIter iter' overload'
./src/Windows/Preferences.cs(259,26): warning CS0219: The variable `bc1' is assigned but its value is never used
./src/MainWindow.cs(195,22): error CS0176: Static member `MainWindow.Hide()' cannot be accessed with an instance reference, qualify it with a type name instead
./src/MainWindow.cs(199,22): error CS0176: Static member `MainWindow.Show()' cannot be accessed with an instance reference, qualify it with a type name instead
./src/Dialogs/AddEditCommand.cs(195,26): warning CS0219: The variable `bc1' is assigned but its value is never used
./src/Dialogs/AddEditCommand.cs(188,26): warning CS0219: The variable `bc2' is assigned but its value is never used
./src/Dialogs/AddEditCommand.cs(213,32): warning CS0219: The variable `iconDialog' is assigned but its value is never used
./src/Dialogs/SendRequest.cs(57,24): warning CS0219: The variable `output' is assigned but its value is never used
./src/Dialogs/Attach.cs(175,33): warning CS0219: The variable `msgDlg' is assigned but its value is never used
./src/Dialogs/Attach.cs(180,33): warning CS0219: The variable `msgDlg' is assigned but its value is never used
Compilation failed: 2 error(s), 39 warnings
make[1]: *** [bin/Release/Haguichi.exe] Error 1
make[1]: Leaving directory `/home/andreas/abs/haguichi/src/haguichi-1.0.4'
make: *** [install-recursive] Error 1
    Aborting...

Stephen Brandt (ztefn) wrote :
Changed in haguichi:
status: New → Fix Committed
milestone: none → 1.0.5
Stephen Brandt (ztefn) on 2011-02-20
Changed in haguichi:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers