performance on raspberry pi

Bug #1066918 reported by Miika Komu
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
h-box
Fix Released
Undecided
Vu Ba Tien Dung

Bug Description

The connection set up latency on Raspberry Pi is poor even though the media flows smoothly. Please investigate and try to isolate the problem:

* h-box?
* media server (try media server only set up on Pi)
* HIP?
* uPnP discovery?

From email: and also, we should try multiple clients getting different files from a remote media server. I believe there should be some bottleneck or implementation problems there.

Revision history for this message
Miika Komu (miika-iki) wrote :

Should we change the status of this bug?

Revision history for this message
Vu Ba Tien Dung (dung-vu-ba-tien) wrote :

We have tested the case of multiple clients fetching media content from a remote UPnP server. The result is very good. No delay was found.

The main problem lies with the huge latency of control messages. First of all, most of the time we run in the debugging mode in which a lot of messages are printed, printed to stdout, sent back to the SSH clients. Secondly, XMPP protocol is the main protocol leverage the control messages, the huge latency between h-box devices and the XMPP server can cause some huge performance degrade too.

Otherwise, everything works well.

Changed in h-box:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers