gwibber-accounts crashed with UnicodeEncodeError in on_foursquare_auth_title_change(): 'ascii' codec can't encode characters in position 0-6: ordinal not in range(128)

Reported by Nazarii Bardiuk on 2012-04-06
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gwibber
Medium
raza.sayed
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

My foursquare account is in ukrainian

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gwibber 3.4.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic-pae 3.2.14
Uname: Linux 3.2.0-22-generic-pae i686
NonfreeKernelModules: fglrx
ApportVersion: 2.0-0ubuntu4
Architecture: i386
Date: Fri Apr 6 22:54:01 2012
ExecutablePath: /usr/bin/gwibber-accounts
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: python /usr/bin/gwibber-accounts
ProcEnviron:
 SHELL=/bin/zsh
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/gwibber-accounts']
SourcePackage: gwibber
Title: gwibber-accounts crashed with UnicodeEncodeError in on_foursquare_auth_title_change(): 'ascii' codec can't encode characters in position 0-6: ordinal not in range(128)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Nazarii Bardiuk (girafik) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Changed in gwibber:
assignee: nobody → raza.sayed (raza-sayed-gmail)
raza.sayed (raza-sayed-gmail) wrote :

Ken, i have attached a fix for this bug. The crash is resolved with this change. Can you please review it ?

raza.sayed (raza-sayed-gmail) wrote :

The attachment "Fix for lp:975437" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) on 2012-04-12
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
Changed in gwibber:
status: New → Confirmed
Changed in gwibber (Ubuntu):
importance: Undecided → Low
importance: Low → Medium
Changed in gwibber:
importance: Undecided → Medium
Ken VanDine (ken-vandine) wrote :

The patch looks great, thanks Raza

Changed in gwibber:
status: Confirmed → Fix Committed
milestone: none → 3.4.1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.4.0-0ubuntu4

---------------
gwibber (3.4.0-0ubuntu4) precise; urgency=low

  * debian/patches/lp_975437.patch
    - foursquare: Don't crash on unicode characters in a users
      fullname, thanks to Raza Sayed (LP: #975437)
 -- Ken VanDine <email address hidden> Thu, 12 Apr 2012 14:51:08 -0400

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Bilal Shahid (s9iper1) on 2012-04-13
Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers