Problem with Facebook : empty message and status repeated many times

Bug #826323 reported by Xavier Guillot on 2011-08-14
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Gwibber
Medium
Ken VanDine
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

Hello,

Small problem in Gwibber 3.1.4.2 with Facebook service : some status are empty - no message content, only number of people who like it, without their names, message is blank.

Xavier Guillot (valeryan-24) wrote :
Xavier Guillot (valeryan-24) wrote :

And same status is repeated a lots of time in my Gwibber window...

Xavier Guillot (valeryan-24) wrote :

Facebook's display improved a lot in last Gwibber updates, now text messages, replies, likes... work well, but sometimes, when there are multimedia attachments or applications (like horoscope), there are still many repeats of the status displayed.

Ken VanDine (ken-vandine) wrote :

Looks like we aren't handling facebook apps output well.

Changed in gwibber:
importance: Undecided → Low
milestone: none → 3.2
assignee: nobody → Ken VanDine (ken-vandine)
Olivier FAURAX (olivier-faurax) wrote :

I use gwibber 3.2.1 and I see facebook messages duplicated.
Only on facebook.
It seems that older messages are duplicated more than recent messages.

Also, older copies have less "likes" than the newer copies of a message.
It suggests that what is displayed is "snapshots" of a message at a given time.

Workaround: reboot gwibber :(

Changed in gwibber:
importance: Low → Medium
milestone: 3.2 → 3.3.90
status: New → Confirmed
Changed in gwibber (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Bilal Shahid (s9iper1) on 2012-02-22
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.3.90-0ubuntu1

---------------
gwibber (3.3.90-0ubuntu1) precise; urgency=low

  * New upstream release
    - foursquare: display comments on checkins (Mark Tully)
    - Update LINGUAS to use all the provided translations (Robert Ancell)
    - make the messages stream default on startup
    - Updated favorite information to include if you liked a post
    - facebook: fixed dupes and empty posts (LP: #826323)
  * debian/control
    - drop Suggests for gwibber-service-buzz
 -- Ken VanDine <email address hidden> Thu, 23 Feb 2012 14:18:14 -0500

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Xavier Guillot (valeryan-24) wrote :

Recently (in March), I still got in Gwibber Facebook status repeated many times, but that's true, not empty...

Changed in gwibber:
status: Confirmed → Fix Committed
milestone: 3.3.90 → 3.4
Changed in gwibber:
status: Fix Committed → Fix Released
Xavier Guillot (valeryan-24) wrote :

There is still a little problem with Facebook plugins : no more empty messages but the Facebook user name / author does not appear anymore above the post :

https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/523088/+attachment/2894290/+files/Gwibber-16.png

Ken VanDine (ken-vandine) wrote :

Can you tell me what the name displayed there should be? The only reason that would happen is if it had characters that break the markup used to render that. I really need to know what characters are in that name so i can make sure we handle them.

Thanks!

First name and name of the message's author, in black bold font, as it
was before ( a few weeks ago), and as we have the twitter / identica
pseudo above message text...

Here it's empty for every Facebook user.

Xavier Guillot (valeryan-24) wrote :

Example a few minutes ago

Xavier Guillot (valeryan-24) wrote :

In the middle it's a Facebook post, above and under identica dents.

Facebook's user name is missing, we have only the avatar.

Xavier Guillot (valeryan-24) wrote :

For the 2 screenshots I posted, there are no special character in the name : only latin letters, no accents...

Xavier Guillot (valeryan-24) wrote :

Another screenshot : names of people who comment on Facebook are visible, but not name of main post's author.

The one in the middle is from Facebook and author name is missing, other messages are from identica and poster name is well written in black bold above text.

Xavier Guillot (valeryan-24) wrote :

OK, problem of Facebook name not displayed is described in the bug :
https://bugs.launchpad.net/gwibber/+bug/985801

And I well had "Show real names in messages" option not checked.

Corrected now with Gwibber 3.4.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers