Add Google+ Service to Gwibber

Bug #805452 reported by Matthias Fasching
This bug affects 270 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Unassigned
Gwibber Google+ Plugin
Undecided
Unassigned

Bug Description

Google offers now a similar service to Facebook called Google+. I would love to see it integrated into Gwibber!

Revision history for this message
Christian Hintze (hintze) wrote :

i second that.. or maybe google+ is just going to connect G+ with twitter/identi.ca/buzz.. nertheless, would be nice to have the option :)

Changed in gwibber:
status: New → Confirmed
Revision history for this message
Sergey Prokhorov (seriy-pr) wrote :

Google plus API is not available now, but you can subscribe to developer's announce list https://services.google.com/fb/forms/plusdevelopers/
Also, I'll be glad to implement G+ plugin for gwibber when the API will be available.

Revision history for this message
Jane Hadley (jhadle) wrote :

Just joined Google+ and would love to have it on Gwibber. Maybe we should urge Google to make its API available ASAP.

Revision history for this message
shgysk8zer0 (shgysk8zer0) wrote :

I would expect that the API will not be released until after Google+ is out of testing. It would be smart of them, I think, to do so before. Now is the time for them to work on these things.

Revision history for this message
Ken VanDine (ken-vandine) wrote :

I have signed up to be notified, we definitely need to create a plugin for it as soon as the API exists.

@Sergey: Have you signed up to get notified? It would be great if you could create the plugin when it becomes available. Ping me if you need help, best to find me on IRC. #gwibber on Freenode

Changed in gwibber:
importance: Undecided → High
Revision history for this message
Sergey Prokhorov (seriy-pr) wrote :

@Ken, yes, I signed up to be notified.
And also I have an expirience on creating Gwibber plugins - I develop and support Gwibber plugin for Vkontakte.ru https://code.launchpad.net/~seriy-pr/gwibber/vkontakte-ru-plugin which is works for many users in Russia, Ukraine etc., so, there is no problems implement another one)

Matze (matzman)
Changed in ubuntu:
status: New → Invalid
Revision history for this message
bruno (bruninho-ro) wrote :

@Sergey Prokhorov (seriy-pr)
Orkut is a popular service that has no plugin for gwibber

Changed in ubuntu:
status: Invalid → Confirmed
status: Confirmed → Invalid
Revision history for this message
tobias engelhardt (k5dq) wrote :

I have no plan about coding but I just found this article about unofficial g+ APIs for phyton, java, ... :
http://www.plus-apps.de/google-plus-api-fuer-php-python-java-net/

Revision history for this message
Sergey Prokhorov (seriy-pr) wrote :

@tobas: yeah, this "API's" really non-oficial and don't allow post messages, as I understand - only retrieve user's feed.
Python "wrapper" is really ugly and based on parsing g+ UI backend, which can be non-stable. So, I think that use this non-oficial pseudo-api is not a good idea.

Revision history for this message
Jorge Castro (jorge) wrote :
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
Revision history for this message
Mikkel Kamstrup Erlandsen (kamstrup) wrote :

The Google+ API has been out for *several hours* now and still no support in Gwibber. Surely it must be because Linux sucks :-O

Revision history for this message
Oweoqi (oweoqi) wrote :
Revision history for this message
Shishir Sharma (mail-mastermind) wrote :

Google+ is currently read only. http://developers.google.com/+/api/

Revision history for this message
Aemnas (rustyhaner) wrote :

Still, having a read plugin is better than nothing.

Revision history for this message
primefalcon (primefalcon) wrote :

Google plus is getting pretty popular, and I would prefer read only to nothing myself

Revision history for this message
Adolfo Jayme (fitojb) wrote :

A read-only plugin doesn’t serve for anything.

Let’s wait a bit until Google fully deploy the G+ API. Patience!

Revision history for this message
Kent Knudsen (forestmountain) wrote :

The API is now available here:
https://developers.google.com/+/downloads

Regards
Kent Knudsen

Revision history for this message
Kent Knudsen (forestmountain) wrote :

Sorry, my mistake - it's still read-ony!

Revision history for this message
Ken VanDine (ken-vandine) wrote :

Even read-only, it would be great if someone could start working on the service plugin for it. It would be a start, I am currently trying to work out how the g+ concepts would integration in the UI, but that doesn't block the service work. Any volunteers to get it started?

Revision history for this message
Sergey Prokhorov (seriy-pr) wrote :

I want to start developing a read-only G+ plugin in next few days

Revision history for this message
Ken VanDine (ken-vandine) wrote :

@seriy-pr: awesome!

Changed in gwibber:
assignee: Ken VanDine (ken-vandine) → Sergey Prokhorov (seriy-pr)
assignee: Sergey Prokhorov (seriy-pr) → Ken VanDine (ken-vandine)
milestone: none → 3.4
Revision history for this message
Sergey Prokhorov (seriy-pr) wrote :

Uhh... I explored G+ API now and discovered, that it has only 3 methods (ok, ok, 8):

1) method to get MY posts (that I personally post on my wall) https://developers.google.com/+/api/latest/activities/list. This is some kind related to gwibber.
2) method to get some user profile info https://developers.google.com/+/api/latest/people/get. This is practically non-related with gwibber.
3) method to get comments for posts. https://developers.google.com/+/api/latest/comments/list. This is some kind needed for gwibber too.
+ methods for full-text search for posts.

But there is no gwibber main API method (except posting) - method to get my friends activities, like in https://plus.google.com/stream page.

So, i'll not sure that there is a real need to start plugin development before /stream api will be added.

But there is a good news too: when I looked at API page about a week ago, there was only 3 methods. Now it's 8 methods in API. So, there is a good dynamics.

/sorry for my bad english...

Revision history for this message
Paul (p37307) wrote :

Definitely would make Gwibber more useful. I support it!

Revision history for this message
Aemnas (rustyhaner) wrote :

Well, I suppose we could ask Google. The API looks like it is getting more robust, but I still don't see a method for reading what users gwibber would have to obtain the stream of. I'm more of a designer than a programmer; I might have missed it.

Revision history for this message
Mark Magelky (froyoshark) wrote :

Yes! Gwibber needs Google+! I'd love to get notified of new posts instead of having to go on the website.

Revision history for this message
On-The-Fly (onthefly) wrote :

I'd be happy about a g+-support, even if it would only be rudimentary yet.

Revision history for this message
Frédéric Grosshans (fgrosshans) wrote :

Please stop adding "mee too" posts. Posts like "This bug is important for me" have the only effect to make information about the bug resolution harder to find out, like spam makes your email harder to read.

If you want to "vote" for this bug click on the link "Does this bug affect you ?" above instead.

Revision history for this message
Anne Marianne Vi (aniav) wrote :

I'm currently working on the Google+ support for Gwibber.
Development status: you can authorise with Google+ through OAuth 2.0 calls, your account information are being retreived, and the credentials are being saved. I think it needs just a few modifications to actually retreive content.
The source code is available on github:
https://github.com/aniav/gwibber-plugins-googleplus

@seriy-pr: please join me in development, I'd be happy with any help!

Sorry if this message shouldn't be placed here.

Revision history for this message
Ken VanDine (ken-vandine) wrote :
Revision history for this message
Guilherme Schvarcz Franco (guilhermefrancosi) wrote :

I really will love it too!

Revision history for this message
Guilherme Schvarcz Franco (guilhermefrancosi) wrote :
Revision history for this message
AlexanderFarrow (asfarrow) wrote :

aniav, I'd like to help out :)

Revision history for this message
Anne Marianne Vi (aniav) wrote :

I'll be happy with any help. Feel free to fork the project and send me a pull request with your changes ;)
I'll add a more specified ToDo list to the readme, just to let you know what has to be done.

Thanks!

Revision history for this message
Barry (barrymac) wrote :

This is a current issue asking for write access to the google plus stream

http://code.google.com/p/google-plus-platform/issues/detail?id=41

Revision history for this message
Vincent (vinnl) wrote :

People working on this (anyone? :) might be interested in the new developer page: http://googleplusplatform.blogspot.com/2012/02/google-developers-page.html

Revision history for this message
Hanine HAMZIOUI (hanynowsky) wrote :

It's believed the full API of Google+ won't be relesead after long. So for now, enabling a plugin for reading streams is of high importance. As Ken said, the plugin could be available through a PPA untill it's released by default in 12.10.

Revision history for this message
Vitaly Korolev (vitaly-korolev) wrote :

The API seems to be out.. https://developers.google.com/+/api/

Revision history for this message
Jacob Peddicord (jpeddicord) wrote :

Vitaly: "Note: The Google+ API currently provides read-only access to public data."

Unfortunately it seems third-party access is not a priority for Google.

Revision history for this message
Victor Andrade (vandrade89) wrote :

Is there at least a plug in out there that I can use for Google+?

Revision history for this message
Ken VanDine (ken-vandine) wrote :

Not yet, really just waiting for google. We'll be able to get a plugin working quickly once google provides an API

Revision history for this message
Vitaly Korolev (vitaly-korolev) wrote :

What's wrong with having read-only plugin? Just seeing the stream would be great for the first release.

Revision history for this message
Jan D (jandeyk-gmail) wrote :

I totally agree with Vitaly Korolev, desktop notification about new posts is the most essential function of Gwibber anyway.

Revision history for this message
Ken VanDine (ken-vandine) wrote :

The current read-only API only lets you see the things you post, not what is posted by people in your circles. The limitation is that there is no API for retrieving your circles, so the only content in your stream is what you've posted :(

Revision history for this message
Peter Meiser (meiser79) wrote :
Adolfo Jayme (fitojb)
no longer affects: ubuntu
Revision history for this message
primefalcon (primefalcon) wrote :

Wish google would hurry up already... but read only would be good too at least until the api is released

Revision history for this message
Tronde (tronde) wrote :

Well, this bug is as dead old as Google+. Does it still matter or should it be closed for good?

Revision history for this message
Bilal Shahid (s9iper1) wrote :

Closing it :)

Changed in gwibber:
status: Confirmed → Won't Fix
Changed in gwibber-service-googleplus:
status: New → Won't Fix
Changed in gwibber:
assignee: Ken VanDine (ken-vandine) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.