Sina support for Gwibber

Bug #759847 reported by An Yang on 2011-04-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned

Bug Description

Sina is the biggest microblog service provider in China, It has hundreds of millions microblog users in China.
I want to contribute the Sina plugin for Gwibber, the attachment is the patch for Gwibber 3.0.0.

An Yang (euroford) wrote :
An Yang (euroford) wrote :

The Sina Icons

Kamus (kamus) on 2011-04-13
tags: added: patch
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
assignee: Ken VanDine (ken-vandine) → nobody
milestone: none → 3.2.0
Changed in gwibber:
milestone: 3.2.0 → none
Ken VanDine (ken-vandine) wrote :

I took your patch and made some changes needed to install it as a separate plugin. Our goal is to enable plugin developers to create and package plugins without needing to get them merged into gwibber. You can find what I did at the following bzr branch:

lp:~ken-vandine/+junk/gwibber-service-sina

I added distutils stuff needed to create tarballs and I added debian packaging to create packages. To create a package from this branch:

sudo apt-get install bzr-builder
bzr bd

The resulting deb files will be in ../build-area/

You will need to tweak a few things:
  * copy the contents of the license to the COPYING file
  * Update debian/copyright to fill in the copyright and licensing information
  * Create a project on launchpad, I suggest "gwibber-service-sina"
  * Edit debian/sina to add the API key

An Yang (euroford) wrote :

Thanks for your kindly help.

These works is almost down, except bzr bd, bzr reports: ERROR: unknown command "bd"

And I have noticed that there is no standalone plugin by now, it's possible to merge this sina plugin into the Gwibber's mainstream?

An Yang (euroford) wrote :

Some additional information.

Sina's microblog protocol is open, you could check it on http://open.t.sina.com.cn.(chinese site)
My contribution follow GPL2.

An Yang (euroford) wrote :

sudo apt-get install bzr-builddeb
bzr bd

It works, and the package works too.

And I hope this sina plugin will be merged into the gwibber mainstream.

Ken VanDine (ken-vandine) wrote :

We are planning to move the existing plugins that are in the gwibber source out into separate sources as well. Just like I did for the sina plugin.

I can definitely work with you to help get your plugin uploaded into the ubuntu archive, once it opens for Oneiric. We can also make it a "Suggests" in the gwibber packaging, so it is more discoverable in ubuntu software center.

I would also love to get it uploaded to the gwibber-team PPA. Let me know when you get the project created for it and you commit the sources there.

An Yang (euroford) wrote :

lp:gwibber-service-sina is created.

It's my pleasure if this plugin could be uploaded in the gwibber-team PPA or ubuntu archive -:)

Thanks again.

Kamus (kamus) wrote :

An Yang, Please could you take a look at https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/761249, there is a crash related to gwibber-service-sina so if you can give us a hand would be appreciated. Thank you

An Yang (euroford) wrote :

HI, Kamus, from the description of the bug, I could not conclude gwibber-service-sina has any relationship with this bug.

And of cause, if you could give me more detail information, I can do something to fix the bug.

An Yang (euroford) wrote :

I'm sorry, from the traceback, it occurred in gwibber-service-sina.

But I could not reproduce this bug, could you give me more information?

An Yang (euroford) on 2011-05-25
Changed in gwibber:
status: New → Invalid
status: Invalid → New
Bilal Shahid (s9iper1) on 2012-04-06
Changed in gwibber:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers