Scrolling timeline flickers between current and top

Reported by Alan Pope ㋛ on 2011-01-25
88
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ken VanDine
gwibber (Ubuntu)
High
Ken VanDine

Bug Description

Binary package hint: gwibber

When I scroll in gwibber i can see people scrolling by but there's a distinct flicker. It looks like gwibber is rendering the first few items in the timeline, then the ones at the position of the scroll bar. Continuing to scroll causes the same effect over and over.

1. Scroll wheel down
2. show uppermost tweets
3. (very short delay)
4. show current tweets
5. Goto 1.

I have attached a video. It's not easy to see but it's infuriating when you're scrolling, because it's impossible to read anything as it flickers so much.

Watch the video and observe the most recent tweet in the timeline is one of dick_turpin and his avatar is a distinctive A with a Union Flag. Note how when I scroll it keeps appearing at the top. His is a good example because (at the time of writing) he tweet/dented 3 minutes ago (in the video), and then not again previously for 23 hours, so it's not like he just appears a lot in the timeline.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gwibber 2.91.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Tue Jan 25 09:23:28 2011
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: gwibber

Alan Pope ㋛ (popey) wrote :
Omer Akram (om26er) on 2011-01-25
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Changed in gwibber:
importance: Undecided → Medium
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

Can someone confirm if this is still a problem? It was never that obvious to me and recent webkit updates seem to have fixed quite a few issues.

Changed in gwibber (Ubuntu):
status: Confirmed → Incomplete
Changed in gwibber:
status: Confirmed → Incomplete
Dave Morley (davmor2) wrote :

Still happening here Ken Sorry

Step Schwarz (closethipster) wrote :

This is also happening to me, exactly as described by the original poster. Gwibber jumps to the top for a fraction of a second following any change in scroll position. Happens regardless of (Gwibber) theme.

I'm new to Gwibber with Fedora 14; I do not experience this issue with Ubuntu 10.10 on the same hardware.

gwibber-1:2.33.0-12.894bzr.fc14 (noarch) installed via Add/Remove Software
MacBook1,1 Intel Core Duo 2 GHz
Intel GMA 950 64 MB Shared System Memory

Step Schwarz (closethipster) wrote :

In addition to Fedora 14, this has started happening to me in Ubuntu since upgrading to 11.04.

Everthon Valadão (everthonvs) wrote :

This is still a problem and I'm experiencing it for 1+ year... I've stopped using Gwibber because of this annoying behaviour. So, Devs, how could we help you trace this issue? What information do you need?

Alan Pope ㋛ (popey) wrote :

Just FYI: this still happens in gwibber 3.0.0

Alan Pope ㋛ (popey) on 2011-04-10
Changed in gwibber:
status: Incomplete → Confirmed
Changed in gwibber (Ubuntu):
status: Incomplete → Confirmed
Omer Akram (om26er) wrote :

definitely something that we should fix for the Natty release.

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → ubuntu-11.04
tags: added: regression-release
Changed in gwibber:
importance: Medium → High
Ken VanDine (ken-vandine) wrote :

This is due to the way we use webkit and mako to render the streams and how we handle tracking position of the view so the user doesn't get bounced to the top on each refresh.

This won't be a problem in 3.2, the new client will handle this much better.

Changed in gwibber (Ubuntu):
milestone: ubuntu-11.04 → none
Ken VanDine (ken-vandine) wrote :

A side note, I think this problem is worse for some users than others. On my laptop it is barely noticeable, and I have to really watch closely to see it happen. And sometimes I can't see it when I try.

costales (costales) wrote :

Hi! Happen to me too, in Ubuntu 11.04 beta2 - Gwibber 3.0.0.1.

Mike Homer (homerhomer) wrote :

yep, broken on my fully updated 11.04

I'm really liking 11.04 and I'm trying to use all the default apps to get the feel for the official Ubuntu experience. This bug is one of my only annoyances. I'm getting the flicker in Gwibber 3.0.0.1 on a currently updated Ubuntu 11.04. Makes scrolling unusable.

piratemurray (mez-pahlan) wrote :

Gwibber 3.0.0.1
Ubuntu 11.04 AMD64

Same problem here.

Conversly on my previously up to date Maverick system with the same hardware this was not a problem.

Changed in gwibber:
milestone: none → 3.2
Changed in gwibber:
milestone: 3.2 → 3.1.2
Changed in gwibber:
status: Confirmed → Fix Committed
Kamus (kamus) on 2011-07-13
Changed in gwibber (Ubuntu):
importance: Medium → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.1.2-0ubuntu1

---------------
gwibber (3.1.2-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - Native retweet support
    - Display notifications when re-tweeting
    - Added messages and public streams, made home stream display everything
    - Scrolling timeline flickers between current and top (LP: #707320)
    - About gwibber is a bit outdated (LP: #748348)
    - Load more messages (LP: #559321)
    - Gwibber puts the newest tweets at the top and oldest at
      bottom (LP: #625863)
    - Scrolling skips bottom of a large message (LP: #782275)
    - should use gsettings rather than gconf (LP: #656329)
  * debian/patches/lpi.patch
    - Launchpad integration
  * debian/libgwibber-gtk2.symbols
    - Added symbols
  * debian/gwibber.desktop
    - Use gsettings for autostart key
 -- Ken VanDine <email address hidden> Fri, 15 Jul 2011 17:14:14 -0400

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released
Changed in gwibber:
status: Fix Committed → Fix Released
basos (basos-g) wrote :

Hello,
This bug affects me also and is very annoying.

I could not find the 3.1.2 version browsing the source repo.
I am using Debian and the latest version for testing is 3.0.0.1

Could you explain where I can get the version with the flickering fix

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers