Gwibber puts the newest tweets at the top and oldest at bottom

Bug #625863 reported by David Collins on 2010-08-28
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
One Hundred Papercuts
Wishlist
Unassigned
gwibber (Ubuntu)
Wishlist
Unassigned

Bug Description

Generally when I catch up on my Tweets either online or on Gwibber, I first must scroll down to find the place where I read the last tweet, look up to the next tweet, read down through that tweet, look up for the next tweet, read down through that one, look up, read down, look up, read down, up, down, up, down, up, down. As many as 20-30 times in a single session.
This is incredibly irritating, it essentially orders tweets in the opposite direction to which we really read. The only alternative is reading them out of order.

My proposal is that Gwibber records the last tweet you read when you close it. Next time you open Gwibber, it loads at the top a tweet maybe 5 tweets earlier to the one you last read, then loads all the tweets after it sequentially downwards.

With this, you open Gwibber, start reading at the top, remind yourself of the context of the last few tweets, and by reading downward you update yourself on what has happened since without eye strain. If a new tweet pops up, it'll be added to the bottom of the list, letting you scroll down more, maybe sending an alert or changing the titlebar to alert the user that there are new messages.

This will make reading tweets a far more natural process.

Ken VanDine (ken-vandine) wrote :

Perhaps we can make it sortable, and remember your last sort order. I'll look into this for next cycle. Thanks.

Changed in gwibber:
milestone: none → 3.0
Changed in gwibber:
status: New → Confirmed
Michal Predotka (mpredotka) wrote :

I also think that present Gwibber's behaviour is broken. It should work just like the rest of messaging applications or forums (or this bug report): text box at the bottom, new messages at the bottom.

Changed in hundredpapercuts:
status: New → Confirmed
Lyrae (julie-lyrae) wrote :

Just a thought: perhaps this way of sorting was chosen because that's how the Twitter Web site works?

Michal Predotka (mpredotka) wrote :

@Lyrae, maybe, but Twitter website has the place you type on top. You write your message on top and it appears there. With Gwibber it's different.
Also, look what happen when someone sent two messages one after another:
- in notify bubble you see:
"message 1
message 2"
- in Gwibber you see:
"message 2
message1"

Anyway, I think it should be one standard behaviour for every communication application (Evolution, Empathy, Gwibber) in Ubuntu.

Victor Vargas (kamus) on 2011-02-16
Changed in gwibber (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Vish (vish) on 2011-02-22
Changed in hundredpapercuts:
importance: Undecided → Wishlist
milestone: none → nt2-social-networking
status: Confirmed → Triaged
Ruben (ruben-tregeagle) wrote :

Some kind of sorting would be excellent. A colleague and I use Gwibber with status.net sites like this:

* Leave it running for the notifications.
* Use the web interface to respond 'in context'

If Gwibber posts could be sorted according to responses or at least have a way to show contextual threads this would negate the need to open the browser.

Dan Dart (dandart) wrote :

This is not a duplicate of bug 727044.

Dan Dart (dandart) wrote :

This is normal: everyone else does it.
But if we were to do this, where would we start?
Would we load 100 in, and provide a "previous" button?

Although, I kinda like identi.ca...
New ones are at the top but Context view shows threaded: newest lower down.
I think that's a better idea.

Changed in gwibber:
milestone: 3.0 → 3.2
Changed in gwibber:
milestone: 3.2 → 3.1.2
Changed in gwibber:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.1.2-0ubuntu1

---------------
gwibber (3.1.2-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - Native retweet support
    - Display notifications when re-tweeting
    - Added messages and public streams, made home stream display everything
    - Scrolling timeline flickers between current and top (LP: #707320)
    - About gwibber is a bit outdated (LP: #748348)
    - Load more messages (LP: #559321)
    - Gwibber puts the newest tweets at the top and oldest at
      bottom (LP: #625863)
    - Scrolling skips bottom of a large message (LP: #782275)
    - should use gsettings rather than gconf (LP: #656329)
  * debian/patches/lpi.patch
    - Launchpad integration
  * debian/libgwibber-gtk2.symbols
    - Added symbols
  * debian/gwibber.desktop
    - Use gsettings for autostart key
 -- Ken VanDine <email address hidden> Fri, 15 Jul 2011 17:14:14 -0400

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Changed in gwibber:
status: Fix Committed → Fix Released
Changed in hundredpapercuts:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers