Missing dependancy: python-libproxy

Bug #597744 reported by Amy H. on 2010-06-23
52
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Fabien Tassin

Bug Description

python-libproxy is not included in the new update of Gwibber.

I updated everything yesterday in Ubuntu and Gwibber was one of the things that needed to be updated. This python-libproxy was not applied when I updated, and apparently it's needed, so I added it separately. It causes Gwibber to not start.

Please add this python library to the needed libraries when the next update rolls around.

Thank you,

Amy

Omer Akram (om26er) on 2010-06-25
Changed in gwibber:
status: New → Confirmed
Omer Akram (om26er) wrote :

Fabien, can you please look into this?

Changed in gwibber:
assignee: nobody → Fabien Tassin (fta)
Fabien Tassin (fta) wrote :

kenvandine is the maintainer. he just fixed it and i've updated the dailies.

Changed in gwibber:
status: Confirmed → Fix Released
Mike Rushton (leftyfb) wrote :

Running Karmic
Does this mean Gwibber is not supported in Karmic anymore?

leftyfb@niagara:~$ sudo apt-get install gwibber gwibber-service
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  gwibber-service: Depends: python-libproxy (>= 0.3.1) but it is not going to be installed
                   Recommends: python-indicate (>= 0.3.0) but it is not going to be installed
E: Broken packages
leftyfb@niagara:~$ apt-cache policy python-libproxy
python-libproxy:
  Installed: (none)
  Candidate: 0.2.3-0ubuntu5
  Version table:
     0.2.3-0ubuntu5 0
        500 http://us.archive.ubuntu.com karmic/universe Packages
leftyfb@niagara:~$ apt-cache policy python-indicate
python-indicate:
  Installed: (none)
  Candidate: 0.2.0-0ubuntu1
  Version table:
     0.2.0-0ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/universe Packages

Dan Klassen (danklassen) wrote :

I'm also using Karmic and am running into the same issue with gwibber at the moment

MoLE (moleonthehill) wrote :

I'm running into the same issues as @Mike Rushton regarding python-libproxy on karmic.

Please excuse my ignorance however It seems that the released fix does not address this issue in karmic.

Should this bug status be changed to Confirmed?

The following packages are BROKEN:
  gwibber-service
0 packages upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 57.8kB of archives. After unpacking 393kB will be used.
The following packages have unmet dependencies:
  gwibber-service: Depends: python-libproxy (>= 0.3.1) but it is not installable
                   Conflicts: gwibber (< 2.29.1~bzr506-0ubuntu1) but 2.0.0~bzr476-0ubuntu3 is installed and it is kept back.
Unable to resolve dependencies! Giving up...
The following packages are BROKEN:
  gwibber-service
0 packages upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 57.8kB of archives. After unpacking 393kB will be used.
aptitude failed to find a solution to these dependencies. You can solve them yourself by hand or type 'n' to quit.
The following packages have unmet dependencies:
  gwibber-service: Depends: python-libproxy (>= 0.3.1) but it is not installable
                   Conflicts: gwibber (< 2.29.1~bzr506-0ubuntu1) but 2.0.0~bzr476-0ubuntu3 is installed and it is kept back.
Resolve these dependencies by hand? [N/+/-/_/:/?]

MoLE (moleonthehill) on 2010-06-29
Changed in gwibber:
status: Fix Released → Confirmed
Omer Akram (om26er) wrote :

please read the bug title. if you have any problem report a new bug.

Changed in gwibber:
status: Confirmed → Fix Released
MoLE (moleonthehill) wrote :

I think I know what you mean Omer. I assure you I did read the bug title and this did seem to be the issue to my nondeveloper brain. Perhaps the bug really is: Gwibber daily ppa not installable on karmic due to old version of python-libproxy?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers