gwibber-accounts crashed with KeyError in get_account_data()

Reported by Rainulf on 2010-03-31
This bug affects 227 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Unassigned
gwibber (Ubuntu)
High
Unassigned
Nominated for Maverick by Wes Garner
Lucid
High
Unassigned

Bug Description

Binary package hint: gwibber

I upgraded my Ubuntu 9.10 to 10.04. And that error appeared when I tried to add my Facebook in Social broadcast.

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: gwibber 2.29.93-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-18.27-generic-pae 2.6.32.10+drm33.1
Uname: Linux 2.6.32-18-generic-pae i686
NonfreeKernelModules: nvidia
Architecture: i386
CheckboxSubmission: 4cabdd51157a76a7613fd606bf6885f9
CheckboxSystem: 6ce041aeed0a2c17b3343b66d157175d
Date: Tue Mar 30 21:49:41 2010
ExecutablePath: /usr/bin/gwibber-accounts
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-accounts
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_CA.utf8
PythonArgs: ['/usr/bin/gwibber-accounts']
SourcePackage: gwibber
Title: gwibber-accounts crashed with KeyError in get_account_data()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Rainulf (rainulf1) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
ideathproof (glenn-immortal) wrote :

Same error fresh install UNR all updates applied asus EEE 900 with work around applied to 80-udisks.rules for ssd issue

Rainulf (rainulf1) on 2010-04-01
Changed in gwibber (Ubuntu):
status: Triaged → New
JDShu (jdshu) wrote :

Same problem, I'm using ZaReason's Limbo 4110, fully updated 32-bit. I did a straight upgrade from 9.10 Karmic Koala. In addition, I cannot add twitter or identi.ca accounts - nothing happens when I click "add" after entering user name and password. I haven't tried any of the other sites.

Jamie Welch (flapjack-fiasco) wrote :

I encountered this problem with a fresh install of 10.04. I did not encounter this problem when attempting the same action from the live cd.

merlinpr (merlinpr) wrote :

I had this problem after upgrading from 9.10 and trying to add Facebook. In my case I clicked on sign up by mistake instead of login in with my current account. I cancelled to start again and login with my Facebook account when this error appeared.

tags: added: bugpattern-needed
Ryan Gyger (ryan-rgckstudios) wrote :

I had the same thing happen to me. I did a fresh install of Lucid, and added my Twitter account with no problem. I then tried to add my Facebook account, went through all the authorizations, as soon as Gwibber said that Facebook was authorized, I tried to finish adding the account, and Gwibber hangs for a few seconds, then crashes with this same error. I restarted my laptop, tried to add the Facebook account again. Facebook realized right after sign in that I was authorized. So Gwibber kicked me straight to the last screen for adding a Facebook account, and I still get the same result. I am willing to provide some sort of logfile, I just don't know how to that well. So if someone can tell me, I will do it.

Changed in gwibber (Ubuntu):
status: New → Invalid
status: Invalid → New
status: New → Invalid
status: Invalid → New
Omer Akram (om26er) wrote :

Please dont change the status of bugs if you dont know what you are doing.

Changed in gwibber (Ubuntu):
status: New → Triaged
gero (tkd4) wrote :

i was trying to configure my broadcast account in facebook and when i clicked on add the error appeared.

Peter Kingsnorth (petejk) wrote :

This affects me too - can add twitter but not facebook account details.

Also I'm not recieving twitter updates through gwibber

Toupeiro (toupeiro) wrote :

Captured from tailed strace on gwibber when trying to add facebook details:

-------------------------------------------------------------
Could not identify preference: username
Could not identify preference: session_key
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/gwibber/accounts.py", line 184, in on_edit_account_save
    self.get_account_data()
  File "/usr/lib/python2.6/dist-packages/gwibber/accounts.py", line 343, in get_account_data
    aId = "%s-%s" % (self.account["protocol"], self.account["username"])
KeyError: 'username'

-------------------------------------------------------------

tags: added: bugpattern-written
removed: bugpattern-needed
FAJALOU (fajalou) wrote :

Same problem,
No facebook ability.
What is the triaged fix? Or is there one?

Alessandro Losavio (alo21) wrote :

i have the same problem, when i want to ability facebook on it there was a crash

same as the others, using a fresh lucid install, tried to add facebook and it crashed initially, now I try to add my fb account and everything seems to work but the account never shows up in the left sidepane and gwibber is clearly unaware of it. No matter how many times I repeat this process the result is the same. No Facebook.

Thats wat is hapening to my Ubuntu!!

Kush

> Date: Tue, 6 Apr 2010 14:04:18 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 552227] Re: gwibber-accounts crashed with KeyError in get_account_data()
>
> same as the others, using a fresh lucid install, tried to add facebook
> and it crashed initially, now I try to add my fb account and everything
> seems to work but the account never shows up in the left sidepane and
> gwibber is clearly unaware of it. No matter how many times I repeat this
> process the result is the same. No Facebook.
>
> --
> gwibber-accounts crashed with KeyError in get_account_data()
> https://bugs.launchpad.net/bugs/552227
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gwibber” package in Ubuntu: Triaged
>
> Bug description:
> Binary package hint: gwibber
>
> I upgraded my Ubuntu 9.10 to 10.04. And that error appeared when I tried to add my Facebook in Social broadcast.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.04
> Package: gwibber 2.29.93-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.32-18.27-generic-pae 2.6.32.10+drm33.1
> Uname: Linux 2.6.32-18-generic-pae i686
> NonfreeKernelModules: nvidia
> Architecture: i386
> CheckboxSubmission: 4cabdd51157a76a7613fd606bf6885f9
> CheckboxSystem: 6ce041aeed0a2c17b3343b66d157175d
> Date: Tue Mar 30 21:49:41 2010
> ExecutablePath: /usr/bin/gwibber-accounts
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
> InterpreterPath: /usr/bin/python2.6
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/gwibber-accounts
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_CA.utf8
> PythonArgs: ['/usr/bin/gwibber-accounts']
> SourcePackage: gwibber
> Title: gwibber-accounts crashed with KeyError in get_account_data()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/552227/+subscribe

_________________________________________________________________
Climate, controversies and the changing signatures of nature
http://green.in.msn.com/

John Riggs (jeriggs76) wrote :

This error occurred on a fresh install of Lucid. I was attempting to add my Facebook feed when Gwibber crashed.

As what others have posted, trying to add Facebook account and Gwibber-Account crashed, restarted Gwibber and added now and it has now added with out crashing.

Any log outputs you require I can send.

For what it's worth, I'm using the Gwibber from the Gwibber-daily PPA for Lucid, and still can't have my Facebook account added. bzr707 is the newest version right now.

ralemi (alemi-reza) wrote :

Same here , Sony VGN Z555DN lucid 64 bit beta 2 on facebook with gwibber

Paul Arnel Joaban (padjoaban) wrote :

Same case here... Mine is a upgraded to lucid beta 2 through update manager.

Toupeiro (toupeiro) wrote :

I was unable to verify that this actually does work with the beta 2 Live-CD as indicated above. I am getting the exact same error message on strace in a VM as I am on my physical machine with 10.04 beta 2 (upgraded)

node42 (node42) wrote :

Clean install of Beta 2 (plus aptitude safe-upgrade). Crash reporter directed me here.

Plamen Nikolaev (plamen-gmail) wrote :

updated an hour ago a fresh install of 10.04 (a couple of weeks old). This triggered on trying to connect a facebook account

Peter Kingsnorth (petejk) wrote :

Now able to add Facebook account details without crashing Gwibber.

Using 10.04 and latest Gwibber from daily ppa. (ver bzr723)

Toupeiro (toupeiro) wrote :

Just downloaded the same daily build. Still no dice for me.

Toupeiro (toupeiro) wrote :

daily build bzr723 strace output:

Updating...
Saving...
Could not identify preference: username
Could not identify preference: session_key
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/gwibber/accounts.py", line 184, in on_edit_account_save
    self.get_account_data()
  File "/usr/lib/python2.6/dist-packages/gwibber/accounts.py", line 347, in get_account_data
    aId = "%s-%s" % (self.account["protocol"], self.account["username"])
KeyError: 'username'
 <unfinished ...>
Traceback (most recent call last):
  File "/usr/bin/gwibber-accounts", line 81, in <module>
    gtk.main()
KeyboardInterrupt

Toupeiro (toupeiro) wrote :

This is now working for me using the daily and using the ubuntu maintained package. Was a user error issue:

Facebook steps:

1. authorize
2. enter name and password
3-(6). Scroll to the bottom of each page and ensure you click "Allow Access" on every gwibber page BEFORE clicking the ADD button on the gwibber app itself.

I was just typing name and password, logging in, and trying to click add before scrolling down to see there was more for me to do...

Same problem, crashed after adding Facebook; Lucid Beta 2 booted from Live Flash Drive on Compaq Mini 110c.

@Toupeiro: It could be that I'm thick, but where is the possibility to scroll a page when trying to add Facebook account? After I enter e-mail adress and password, Gwibber says Facebook account is "authorized", and the whole show stops.

Toupeiro (toupeiro) wrote :

No, its somewhat misleading at first glance. :)

From the beginning:

When you click "Authorize" there's no scrollbars yet, but when you click "Login with facebook" type your name/password and hit the connect button. The next screen it takes you to should let you scroll down. If you do not see any scrollbars, try using your wheel mouse or arrow keys anyway, and in the bottom of the embedded browser window, you will see an allow button. Do this a few more times (I think a total of three times) and when you're completely done, then you should be able to click the add key on the gwibber app, it should add the account without crashing.

Lorien (mcs) wrote :

@Toupeiro: You're right - it works! Thanks for your hint :-)

@Toupeiro & lORIEN: It does not work for me. I get no page after I finish log in. (If I try to authorize again, I get a page that only says "Success")

Toupeiro (toupeiro) wrote :

Depending on the number of attempts you guys have done, you may have to do the bug workaround here:

https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/553226

I had to do this when I deleted my facebook account to re-add it trying to document the steps I took. Doing this allowed me to properly re-add my account without another crash.

Toupeiro (toupeiro) wrote :

Here's a more in-depth triage effort to try depending on how much manual manipulation you may have done to attempt to fix this issue. I broke couchdb pretty bad by manually purging things from it out of my home directory, not knowing it was a flat-database with a web front end.

The following steps should only be done if you think you've busted up desktopcouch in the process of trying to fix gwibber:

1) Completely purge gwibber
  -sudo apt-get purge gwibber

2) Completely purge desktop-couch
  -sudo apt-get purge desktopcouch

3) perform autoclean and autoremove to clean up all dependencies
  - sudo apt-get autoclean && sudo apt-get autoremove

4) ensure that ~/.local/share/desktop-couch is removed. if its not, just rename it so when you reinstall desktop-couch, it completely regenerates its database structure.

5) Click on Accessories then Passwords and Encryption Keys and under Passwords:login, remove the Gwibber-pref key.

6) Reinstall Desktop-Couch
  -sudo apt-get install desktopcouch

7) Reinstall gwibber
  - sudo apt-get install gwibber

8) There is a way to manually kick off the desktopcouch services in your active session, but I was unsuccessful in doing so, so right about here, I'd log out of your account and log back in. You dont have to reboot.

9) You should now be able to add y our facebook account using the steps above because there should be no pre-existing settings in desktopcouch's database as you have re-initialized it.

This app still doesn't feel "Ready for primetime" being this fragile, but when it does work, I will admit its pretty nice!

Omer Akram (om26er) wrote :

Just deleting all configuration files of desktop couch should also make it work

Toupeiro (toupeiro) wrote :

I tried this, it didn't work for me, which is why I suggest a full purge of the app which will get ALL desktopcouch config files, even ones not in ~. I think manually hacking around in the directory is exactly what broke me.. Your mileage may vary..

Toupeiro (toupeiro) wrote :

Desktop Couch interacts with dbus. It's a flat database, just deleting files will freak it out. There is a proper way to unregister applications that use it...

http://www.freedesktop.org/wiki/Specifications/desktopcouch/Documentation/Troubleshooting

well, deleting configuration files solves problem for *many* so clearly you
are not one of those.

Toupeiro (toupeiro) wrote :

Yes, and it also breaks ALL other app registrations in desktop couch's config outside of ~. e.g. ubuntuone and others. Please do a little more research and heed others findings before copping an attitude.

Thanks.
-T

Bug is still present in version 2.30.0.1

Toupeiro (toupeiro) wrote :

Hello Ketil,

Can you confirm whether or not the procedures outlined above have worked for you?

Bo Rosén (bo-rosen) wrote :

I have this bug as well (and bug https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/530195 ).
I followed the steps in msg #33 with no success. I have to say though I'm also confused about the description for authorizing the facebook account. I come to the the embedded page that allows me to log in with Facebook, then to the page where I enter my email and password, then I hit button at the bottom that says (in Swedish) Link (as in link the facebook account to Gwibber). Then it takes a little while and I get the screen that says the account has been authorized. If I hit Add I get the crash again.

This is with v 2.30.0.1

188236 (christian-bernstein) wrote :

@the developers: comment #26 worked for me. Its not a software bug but a very unlucky combination of the Gwibber-GUI with the Facebook content. Many users just don't understand the GUI intuitivly. Maybe you can change the GUI (e.g. make it larger) so that the user can see the content with one view? Thanks!

@188236: Are you joking? The mentioned comment does not work for me. Just because you can work around the bug doesn't mean it works for everyone. I've been using Linux for ten years and know how to follow directions and use a GUI.

Toupeiro (toupeiro) wrote :

@Ketil. Not all GUI's are created equally. There are over 114 people reporting they are affected by this bug. I've been recreationally using linux since the mid-90's and using it at work it since 1998 but it doesn't mean every GUI is going to make sense to me. Maybe this workaround doesn't work for everyone, and maybe the problem is more user and less aplication, however the GUI is not alltogether as straightforward as it could be. I don't think the question was out of line for consideration in a future release of the application.

-T.

Alessandro Losavio (alo21) wrote :

when i tried to add on gwibber facebook there was a crash

lowlux (lowlux) wrote :

same issue, all update appealed

@Toupeiro: The question was not out of line, I agree. Thinking that comment #26 is a fix-all for all users was wrong. Postulating that all users after comment #26 can't follow instructions was out of line, in my opinion. Especially when several users have said that the steps didn't work *for them*.

Anyway, I tried investigating the steps in #26. I thought this might be due to the fact that Gwibber was already authorized on my Facebook profile. So, I removed Gwibber in Facebook application settings. I then was able to go through all the steps, and Gwibber has all boxes checked on Facebook. (Which it also used to have, because I first used Gwibber months and months ago.)
I still have no success, and the same crash.
So, proving that I can actually use scrollbars, can we accept that this is a software bug, not some users' inability to use a basic web UI?

Gwibber on my computer still does *nothing*, neither showing Twitter/ Identi.ca, nor posting to them. I'm not sure if these are all symptoms of the same problem.
I'm assuming that this bug is related to CouchDB, so maybe this bug should be marked accordingly?

TracyRosen (tracy) wrote :

Saturday morning update through update manager (April 17, 2010) and gwibber is now working with facebook and twitter :)

Matthew East (mdke) wrote :

I still have this bug with gwibber 2.30.0.1-0ubuntu1. Given the number of people it affects and duplicates I'll raise the status to High.

Changed in gwibber (Ubuntu):
importance: Medium → High

@TracyRosen: Have you done anything else recently, that might have caused Gwibber to be working? There was a desktopcouch update yesterday, but I'm still out of luck.

For the record, I redid all the steps from comment #33 today, to see if I was lucky this time. No dice.

TracyRosen (tracy) wrote :

@Ketil Wendelbo Aanensen Nothing new, just updated via update manager. I hadn't updated in about a week. Before I updated gwibber would crash. Now it works.

Kamil Shakirov (kamils80) wrote :

still no luck.

Brandon Frohs (bfrohs) wrote :

Upgrade from 9.10. Added Twitter account successfully. When adding Facebook, I authorized all of the things Gwibber required. Upon being authorized and clicking 'Add', I received the crash message. Oddly, the application was still open (just wouldn't add Facebook). I'm assuming the process that Gwibber runs to create a new account is what actually crashes.

Omer Akram (om26er) on 2010-04-18
Changed in gwibber:
status: New → Confirmed

Failed while trying to add a Facebook account.

Using Ubuntu beta 2, latest update today, 19/04/2010.

Peter Kingsnorth (petejk) wrote :

Try using adding OpenDNS - https://store.opendns.com/setup/device/ubuntu/
the reboot, and try adding the account again.

It worked for me - and Gwibber updated itself straight away again

@Peter Kingsnorth: That is a solution I did not expect. Adding Facebook now works, and Gwibber actually shows stuff.

There needs to be a way of working around this from the get go, because this is just weird and non-intuitive.

Chris Jepsen (jeppodude) wrote :

I can confirm adding OpenDNS allows Facebook to authorize Gwibber.

Also, Gwibber continues to function if you remove OpenDNS after setting up the account. Hopefully we can get this fixed before the release of Lucid.

Chris Jepsen (jeppodude) wrote :

Scrap that, Gwibber stops working after removing OpenDNS from settings.

JDShu (jdshu) wrote :

adding OpenDNS makes everything (twitter, identi.ca, facebook) work as well for me

corchox (corchoelgrande) wrote :

crashed, dont permit add accounts

Changed in gwibber:
assignee: nobody → corchox (corchoelgrande)
Omer Akram (om26er) on 2010-04-30
Changed in gwibber:
assignee: corchox (corchoelgrande) → nobody
Toby Roworth (toby-roworth) wrote :

I think I've discovered where the problem that's stopping facebook is:

in /usr/lib/python-2.6/gwibber/lib/gtk/facebook.py on lines 100 and 101 are the following:

url = web.get_main_frame().get_uri()
data = json.loads(urlparse.parse_qs(url.split("?", 1)[1])["session"][0])

Line 100 sets url to
http://www.facebook.com/connect/login_success.html
instead of
http://www.facebook.com/connect/login_success.html?session={"session_key":"2.3O...(rest of session key etc not shown)
which is what I get when I manually run the URL through a browser, which can be shown by inserting a "print url"

From what I can tell line 101 fails because split returns only 1 item, and the second is dereferenced - this trips the try, so the rest of the block is not executed, which includes the setting of username.

It's quite possible that this is a bug in an upstream package, as I can't see any reference to webkit (or wrappers therof) not returning the query string or having a method to get it

Hope this is helpful to a developer somewhere! - I'm continuing to look into it...

Toby Roworth (toby-roworth) wrote :

Very nasty, gritty workaround to get facebook working:

Please be careful when mucking about with program source files - this should be OK, but try it at your won risk, carefully. And backup files before editing!

1: log in, and authenticate - pressing add will still crash the program
2. quit gwibber
3: (backup and) edit /usr/lib/python2.6/dist-packages/gwibber/lib/gtk/facebook.py, and comment out (put a "#" without the quotes) line 83 ("req_perms": "publish_stream,read_stream,status_update,offline_access")
4.save
5. optional - may not be necessary: (backup elsewhere and) delete facebook.pyc
6. add acount again, and authorise

with any luck this will work - afterwards you should probably uncomment the line you commented out (remove the hash)

The bug itself seems to be a problem with how facebook connect works for authentication - I'll investigate further and try and write a patch

Changed in gwibber (Ubuntu):
assignee: nobody → Toby Roworth (toby-roworth)
P. T. (p.t) wrote :

Following your "how-to" I had it up'n'running in no time. Thank you!

Changed in gwibber (Ubuntu):
assignee: Toby Roworth (toby-roworth) → nobody
Toby Roworth (toby-roworth) wrote :

Having managed to solve the problem, I can no longer reproduce it, even if I remove both the authentication from within facebook and the profile from couchdb!

As such I can't test this patch properly, but I think it should work - if anyone wants to test it a call of:

cd /usr/lib/python2.6/dist-packages
sudo patch -p0 < [path]/patch.diff

should do it.

As said, I've been unable to reproduce this bug again, so if anyone wants to try this patch, please do, but be aware it's untested (but shouldn't be unsafe) - basically it catches errors processing the query string, and tries to reauthenticate without sending the req_perms, which seemed to be causing the query string to not be given, and if it still doesn't work writes an error (not warning) to the terminal.

Let me know of the results...

Dylan Fehrle (dkfehrle) wrote :

Toby, tried your patch and it worked perfectly with full expected results. Thanks.

Changed in gwibber (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → High
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber (Ubuntu Lucid):
assignee: nobody → Ken VanDine (ken-vandine)
cdeze (christophedeze) wrote :

Patch didn't work for me

got
Warning: Could not process response from Facebook server - retrying

Jorge Rubio (jorgerc85) wrote :

Having installed the patch still doesn't work. Running gwibber on terminal and attempting to authorize my account gives me this:

Updating...
Warning: Could not process response from Facebook server - retrying
Error: still can't process response from Facebook server
Error: still can't process response from Facebook server
Saving...
Could not identify preference: username
Could not identify preference: session_key
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/gwibber/accounts.py", line 184, in on_edit_account_save
    self.get_account_data()
  File "/usr/lib/python2.6/dist-packages/gwibber/accounts.py", line 353, in get_account_data
    aId = "%s-%s" % (self.account["protocol"], self.account["username"])
KeyError: 'username'

Nelson Lago (lago) wrote :

Using an up-to-date Lucid with gwibber 2.30.0.1-0ubuntu1, I have the same problem: I authenticate on facebook but cannot add. Tried the patch from Toby Roworth (post #64) and got exactly the same error message as Jorge Rubio on post #67.

Since some people had success with OpenDNS (not my case), this error might have something to do with language settings; my system is configured for pt-BR, a language supported by facebook. The facebook login page within gwibber is presented in pt-BR. I was unable to make the facebook page come up in English. If someone knows how to do it, I may try to see if the behaviour changes.

What I already tried: I tried unsetting LANG, LANGUAGE and LC_ALL before running gwibber (the UI was presented in English, but not the Facebook page), tried to activate a proxy on gnome preferences and on firefox to go through a us-based proxy (not sure it worked, though), changed DNS servers to OpenDNS, and tried to change the preferred languages order in firefox (is firefox the embedded browser?).

Toby Roworth (toby-roworth) wrote :

A note about my patch:

"Warning: Could not process response from Facebook server - retrying" basically means you are affected by this bug - if you see it, make sure you try pressing "add" before deciding it doesn't work (the message might not make this clear). If you get the "Error: still can't process response from Facebook server" message, however, my patch can't help!

A note about this bug:

I wonder if this is actually an upstream problem with cacheing in webkit or something - making a different HTTP request sometimes fixes it, and changing DNS server sometimes fixes it - from what I've seen of the gwibber code, there's nothing that's actually wrong, just a lack of query string being returned (in my case at least)

If my patch or other workarounds don't fix the problem, try printing the URL being returned by webkit at line 100 of lib/gtk/facebook.py and post it here - it would be good to see if it's the same bug for everyone

url = web.get_main_frame().get_uri()
print url; #add this line
data = json.loads(urlparse.parse_qs(url.split("?", 1)[1])["session"][0])

Just to let you know I tried all the info above and nothing worked...
BTW -- I'm running Gwibber 2.30.0.1 on Ubuntu 10.04 LTS

Then I remember the hack I had to do in order to have Twitter working -- increase the timeouts in /usr/share/pyshared/gwibber/microblog/network.py

So, I did the same to the /usr/share/pyshared/gwibber/microblog/util/facelib.py
line 843-844
        c.setopt(pycurl.TIMEOUT, 15) ## 15 secs only?
        c.setopt(pycurl.CONNECTTIMEOUT, 8) ## 8 secs? really?? you guys have an insanely fast connection :)

changed to:
        c.setopt(pycurl.TIMEOUT, 150)
        c.setopt(pycurl.CONNECTTIMEOUT, 80)

I know this timeout is much bigger now, but at least things work perfectly -- both Facebook & Twitter.

Have fun!

Tom (tompossin-gmail) wrote :

I increased the timeouts as well and can confirm that everything immediately
worked.
Thanks Rodrigo

On Wed, May 12, 2010 at 8:21 AM, Rodrigo Lima <email address hidden>wrote:

> Just to let you know I tried all the info above and nothing worked...
> BTW -- I'm running Gwibber 2.30.0.1 on Ubuntu 10.04 LTS
>
> Then I remember the hack I had to do in order to have Twitter working --
> increase the timeouts in
> /usr/share/pyshared/gwibber/microblog/network.py
>
> So, I did the same to the
> /usr/share/pyshared/gwibber/microblog/util/facelib.py
> line 843-844
> c.setopt(pycurl.TIMEOUT, 15) ## 15 secs only?
> c.setopt(pycurl.CONNECTTIMEOUT, 8) ## 8 secs? really?? you guys have
> an insanely fast connection :)
>
> changed to:
> c.setopt(pycurl.TIMEOUT, 150)
> c.setopt(pycurl.CONNECTTIMEOUT, 80)
>
> I know this timeout is much bigger now, but at least things work
> perfectly -- both Facebook & Twitter.
>
> Have fun!
>
> --
> gwibber-accounts crashed with KeyError in get_account_data()
> https://bugs.launchpad.net/bugs/552227
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Jorge Rubio (jorgerc85) wrote :

I can also confirm that increasing the timeouts fixed this problem for me... I only increased them to 60 and 32 seconds though... I have twitter and facebook working now! Thanks Rodrigo

Rodrigo's fix solved my problem. Mark this one solved!

martincasc (martincasco) wrote :

After 5 minutes of waiting, it's seems that works.. I don't know if this bug must be changed to resolved, but if it still working on, it must be an official bug fix..

Thanks Rodrigo!

Had a similar issue - fresh 64-bit install of 10.04, all I've done is install Wine and tweak my xorg config a bit, I get through the auth process, it locks up for a few seconds, says 'Facebook authorized' and won't let me add anything...

Rodrigo's fix worked. Mark this as resolved, and upstream that fix, ASAP.

Nicola Ferralis (feranick) wrote :

The bug can be marked as solved only when an update package hits the official repo.

David Futcher (bobbo) on 2010-06-08
tags: added: patch-forwarded-upstream
Yuioup (mghaoui) wrote :

See this bug as well:

https://bugs.launchpad.net/ubuntu/+source/seahorse/+bug/553032

If you run:

gnome-keyring-daemon; gwibber

.. then it works.

I had the same problem as described by the majority -- unable to add my Facebook account regardless of the fact that authorization was properly setup -- less and except the fact that I had no debug messages displayed when said issue appeared. This is most definitely not an user interface issue as per original comment #26 states.

Thanks to comment #77 by Yuioup on 2010-06/09 has saved me! Instantaneously started working 100% as expected upon executing those two commands within a terminal. I would personally advise trying this potential fix before enduring the mundane chore of compiling & patching from the source repositories and see if this works for you as well.

-Ubuntu 10.04 LTS | Linux 2.6.32-22-generic | All updates applied as of 2010-06/15 2:00:00 -6:00 GMT

To confirm what Jeffrey says, #77 worked for me as well.

Mike Beach (mbeach1) wrote :

I seem to be having a similar issue
After authorizing my facebook account it says "Authorized" but the final "Add" button is not there to click.

@Mike Beach - I have fixed a number of gwibber installations using comment 70 above.

However some additional steps were needed and the amount of stuff varied.

In the oldest gwibber installation I found it necessary to delete the couch databases with the gwibber account info and reboot to restart Erlang/beam before attempting to add my Facebook account back.

In simpler cases I just had to reboot and then delete the Facebook account through the gwibber GUI and re-add it.

In one case all I needed to do was to patch the /usr/share/pyshared/gwibber/microblog/network.py file ala comment 70 and reboot then Facebook started working again without deleting any accounts.

Ken VanDine (ken-vandine) wrote :

We have found the problem, it is facebook throttling the queries we have to do to successfully complete the auth process. This is throttled based on all the queries across all gwibber users, not just per-user. We need to figure out a way to reduce the number of queries or get facebook to increase the budget on queries.

affects: gwibber → sswsm
Changed in gwibber (Ubuntu):
assignee: Ken VanDine (ken-vandine) → alkass1@hotmail.de (alkass1)
Changed in sswsm:
assignee: nobody → alkass1@hotmail.de (alkass1)
Changed in gwibber (Ubuntu Lucid):
assignee: Ken VanDine (ken-vandine) → alkass1@hotmail.de (alkass1)
Changed in gwibber (Ubuntu):
status: Triaged → Confirmed
Changed in gwibber (Ubuntu Lucid):
status: Triaged → Confirmed

Ooops, this shouldn't have been assigned to the SSWSM project :-S

affects: sswsm → gwibber
Luciano Panepucci (lpanebr) wrote :

the only thing that worked for me was comment #80 as follows:

"
for those who have issues on ubuntu 10.4, do the following:
open terminal
type: rm -r ~/.gconf/apps/gwibber and hit enter
open system monitor and kill any gwibber process
reload gwibber and proceed to add facebook
...when you login to facebook on gwibber to authorize it use your username not your email
it should then say PERSON is authourised instead of facebook authorised
and the add button should appear, if you can't see it maximize the window.
"

Omer Akram (om26er) on 2010-07-05
Changed in gwibber:
assignee: alkass1@hotmail.de (alkass1) → nobody
Changed in gwibber (Ubuntu Lucid):
assignee: alkass1@hotmail.de (alkass1) → nobody
Changed in gwibber (Ubuntu):
assignee: alkass1@hotmail.de (alkass1) → nobody
Agustin (agustin-bosso) wrote :

I can confirm, Rodrigo's solution in comment #70 works perfectly.

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
Changed in gwibber (Ubuntu Lucid):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.31.2-0ubuntu1

---------------
gwibber (2.31.2-0ubuntu1) maverick; urgency=low

  * New upstream release
    - Better facebook api_key handling
    - Only download content from facebook that we haven't already downloaded
      yet (LP: #595265)
    - Cache the results of the friends query from facebook so we don't make so
      many redundant calls and download duplicate data (LP: #595265)
    - Added a CouchDB view for getting max_message_time and a method for
      looking it up per operation, using this value to only get content
      newer than the latest record we have stored
    - All of these fixes are related to reducing the number of calls we
      we make to facebook and reducing the size of the result. Facebook
      throttles application wide, not per-user based on usage. This throttling
      is the root cause for (LP: #552227) and (LP: #595265) and probably many
      other bug reports where facebook rejects gwibber.
    - Merged in the latest version of facelib.py
    - Don't fail when we get valid error codes back from facebook, log them.
    - Bump the map_async timeout up to make sure it is higher than the pycurl
      timeouts
    - Bump the pycurl.TIMEOUT to 150 and use default for pycurl.CONNECTTIMEOUT
 -- Ken VanDine <email address hidden> Thu, 08 Jul 2010 15:38:18 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released

Accepted gwibber into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Lucid):
status: Confirmed → Fix Committed
tags: added: verification-needed
Ben Rousch (brousch) wrote :

I installed the proposed version. I still can't login to Facebook, but Gwibber Accounts no longer hangs after the login failure. So, it's slightly fixed!

Omer Akram (om26er) wrote :

marking the upstream bug as fixed.

Changed in gwibber:
status: Confirmed → Fix Released
Martin Pitt (pitti) on 2010-07-12
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.1-0ubuntu1

---------------
gwibber (2.30.1-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release.
    - Better facebook api_key handling
    - Only download content from facebook that we haven't already downloaded
      yet (LP: #595265)
    - Cache the results of the friends query from facebook so we don't make so
      many redundant calls and download duplicate data (LP: #595265)
    - Added a CouchDB view for getting max_message_time and a method for
      looking it up per operation, using this value to only get content
      newer than the latest record we have stored
    - All of these fixes are related to reducing the number of calls we
      we make to facebook and reducing the size of the result. Facebook
      throttles application wide, not per-user based on usage. This throttling
      is the root cause for (LP: #552227) and (LP: #595265) and probably many
      other bug reports where facebook rejects gwibber.
    - Merged in the latest version of facelib.py
    - Don't fail when we get valid error codes back from facebook, log them.
    - Bump the map_async timeout up to make sure it is higher than the pycurl
      timeouts
    - Bump the pycurl.TIMEOUT to 150 and use default for pycurl.CONNECTTIMEOUT
 -- Ken VanDine <email address hidden> Thu, 08 Jul 2010 21:49:11 -0400

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released
ski (skibrianski) wrote :

I'm still having the problem on lucid with 2.30.1-0ubuntu1, as are a bunch of folks over on dupe bug thread https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/545859

ski (skibrianski) wrote :

... And also on lucid with these packages from maverick installed:
  Get:1 http://us.archive.ubuntu.com/ubuntu/ maverick/main gwibber 2.31.5-0ubuntu1 [326kB]
  Get:2 http://us.archive.ubuntu.com/ubuntu/ maverick/main gwibber-service 2.31.5-0ubuntu1 [65.5kB]
  Get:3 http://us.archive.ubuntu.com/ubuntu/ maverick/main python-libproxy 0.3.1-1ubuntu1 [6,896B]

The only thing that (almost) worked for me was the opendns suggestion, but that unfortunately only worked once, and I was bitten by the "no okay button when facebook thinks i'm already authorized" bug, so I'm still at square one.

ski (skibrianski) wrote :

... the workarounds I've tried in the past 24h:
- Use opendns (almost worked)
- Use google public dns
- connect over a 3g hotspot (for different DNS since that almost worked)
- blowing away ~/.gconf/apps/gwibber/ AND .cache/gwibber/
- blowing away gwibber-* databases in couchdb.
- Install dpkg's for gwibber, gwibber-service and python-libproxy (a depend) from maverick - no dice.

Something is still wrong. With the exception of install the packages from maverick, I tried these fixes over and over in various combinations. I'm very confused as to how this could have worked once with a different DNS server, but then never again.

Changed in gwibber (Ubuntu Lucid):
status: Fix Released → Incomplete
Changed in gwibber (Ubuntu):
status: Fix Released → Incomplete
ski (skibrianski) wrote :

after wasting a few hours, i have no idea what i did, but gwibber finally let me on to fb. i literally kept trying over and over and over again (probably a few hundred times) out of frustration (and procrastination ;-)), I think i kept hitting the fb servers until some sysadmin at fb looked into it and said "oh its another one of these people trying to use that poorly written app" and authorized me to spare themselves the server load ;-)

in any event, I'm on with the latest version from lucid, but there are clearly still problems to work out. Perhaps all the traffic from gwibber on fb is due to inconsiderate jerks like me doing same??

Changed in gwibber:
status: Fix Released → Confirmed
Wes Garner (wesgarner) wrote :

Still present in Maverick 10.10

Changed in gwibber (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
Changed in gwibber (Ubuntu Lucid):
assignee: Ken VanDine (ken-vandine) → nobody

Tried patch in comment #64 on gwibber 2.32.01 in maverick.
Hunk #1 was reported as failed, hunk #2 as successful. After applying the patch it was possible to add fb.

Thank you for all your comments. This bug was fixed, as indicated above. If you are still experiencing issues with Gwibber and facebook after insuring all available updates were applied to your system and the the system was restarted, please file a new bug by opening a terminal and typing

ubuntu-bug gwibber

Thank you.

Changed in gwibber (Ubuntu Lucid):
status: Incomplete → Fix Released
Changed in gwibber (Ubuntu):
status: Incomplete → Fix Released
Changed in gwibber:
status: Confirmed → Fix Released
assignee: Ken VanDine (ken-vandine) → nobody
Changed in gwibber (Ubuntu):
assignee: nobody → Inan Mayis Aru (mayisaru)
Changed in gwibber (Ubuntu):
assignee: Inan Mayis Aru (mayisaru) → nobody
To post a comment you must log in.