posting a comment on facebook does not update or add the comment to the post reply thread

Bug #541831 reported by Arutha
270
This bug affects 51 people
Affects Status Importance Assigned to Milestone
Gwibber
Low
Unassigned
gwibber (Ubuntu)
Medium
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Gwibber 2.31.1

posting a comment to someone else's post does not result in an update of the reply/comment thread in gwibber.
Also, does gwibber update the list with comments at every refresh? Or is the list only collected once and never updated?

Revision history for this message
Ryan Paul (segphault) wrote :

Gwibber does not update the comments on Facebook bubbles during subsequent refreshes. I'd like to get that fixed in Gwibber 3.

Changed in gwibber:
milestone: none → 3.0
status: New → Confirmed
Omer Akram (om26er)
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
moisesbelda (moisesbelda) wrote :

Same problem here...

But I didn't see all the comments, posted by me or not. I see some comments, but not all.

Revision history for this message
Jeffrey Flaker (jflaker) wrote :

I have observed that not ALL comments come in and no new comments are added.

Maybe do what tweetdeck seems to do....pull in X number of updates (adjustable in preferences or under accounts) and on refresh....then refresh to list completely.

Revision history for this message
frizzle21 (frederik-nnaji) wrote : Re: [Bug 541831] Re: posting a comment on facebook does not update or add the comment to the post reply thread

On Tue, May 4, 2010 at 02:34, Jeffrey Flaker <email address hidden> wrote:
>
> Maybe do what tweetdeck seems to do....pull in X number of updates
> (adjustable in preferences or under accounts) and on refresh....then
> refresh to list completely.

maybe start supporting XMLHTTPRequest or start providing dynamic feedback
upon User interaction?
see:
http://library.gnome.org/devel/hig-book/stable/principles-feedback.html.en

Revision history for this message
heidy james (heidy-james) wrote :

I’m delighted to visit this thread after stretched time which was because of my <a href="http://www.cisco-training-course.com">cisco training</a>. These types of sites always magnetize me.

Revision history for this message
heidy james (heidy-james) wrote :

I’m delighted to visit this thread after stretched time which was because of my [url=http://www.cisco-training-course.com]cisco training[/url]. These types of sites always magnetize me.

Revision history for this message
Davide86 (luciferoserra) wrote :

The list of comments in the various post (or treads) downloded by facebook is only update at the first refresh.
GWibber does not show the comments that I post also after a refresh.

Revision history for this message
Jeffrey Flaker (jflaker) wrote :

SPAM in message thread # 5 and 6

Revision history for this message
ranjan (s1-ranjan) wrote :

Yes I am too having this problem

Revision history for this message
Liam McNulty (liam-willowford) wrote :

Hi,
I can't post anything to Facebook from Gwibber. Twitter is fine, and flickr works perfectly, but not FB.
Gwibber is authenticated and I have set it to send and receive messages - it loads FB threads on first opening, but then doesn't refresh and I can't post anything. I'm using Ubuntu 10.04 and Gwibber 2.30.1. Any help or advice would be much appreciated - Gwibber seems a great program and you are doing a fine job.
Sorry if I have missed something obvious.
Attached is a printout of the terminal after this command: gwibber-service -d -o
Thanks.
Liam

Revision history for this message
Brandon Walker (bwalker4) wrote :

Hi, same problem here. Gwibber will not let me post a reply to anyone's post via Facebook. Using 10.04. Initially had problem that Gwibber would not update at all, but that seems to have been fixed by changing /etc/hosts from "127.0.1.0" to "127.0.0.1". Does anyone know how to fix this reply problem?

Revision history for this message
Christian Dysthe (christian-dysthe) wrote :

I've tried to remove Facebook and add it again using both <username>@myemail.com and <username>. Gwibber authenticates without problems, but after the update it's full stop. No more updates at all. I can post and see my posts on Facebook web, but nothing in Gwibber. I'm running 2.31.90 on Linux Mint 9 x64.

Revision history for this message
dtfjgk (dtfjgk-deactivatedaccount) wrote :

I have a trouble with posting on Twitter.

summary: - posting a comment on facebook does not update or add the comment to the
- post reply thread
+ posting a comment on facebook or twitter does not update or add the
+ comment to the post reply thread
summary: - posting a comment on facebook or twitter does not update or add the
- comment to the post reply thread
+ posting a comment on facebook does not update or add the comment to the
+ post reply thread
Changed in gwibber:
status: Confirmed → Fix Committed
Changed in gwibber:
importance: Undecided → Medium
milestone: 3.0 → 2.32.0
importance: Medium → Low
Changed in gwibber:
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted gwibber into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed
Changed in gwibber (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Revision history for this message
Souptik Duttaroy (souptik-b747) wrote :

Almost Same here.. I can post status updates but cannot comment on other people's post.. Any fixes available?

Revision history for this message
Omer Akram (om26er) wrote :

with the proposed version any comments are shown in a threaded form but every comment is also shown in @myname form too(this happened before). so verification is done and the other problem can be dealed in another bug report.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.32.0.2-0ubuntu1

---------------
gwibber (2.32.0.2-0ubuntu1) maverick-proposed; urgency=low

  * New upstream release (LP: #660693)
    - Reuse the libproxy.ProxyFactory object to prevent a race
      condition (LP: #651761)
    - Facebook: Check for new messages since "updated_time" instead
      of "created_time", to prevent losing status updates (LP: #541831)
    - Facebook: Better handling of data returned from facebook (LP: #615339)
    - Facebook: fixed matching of uid with profiles (LP: #524510)
    - Facebook: fixed missing notifications (LP: #575394)
    - Facebook: when checking for new content, use localtime
    - Update existing record if it conflicts instead of just
      ignoring it (LP: #541831)
    - Added a missing import to properly log failure on avatar resize
    - Fix for internal Digg errors, thanks Vadim Rutkovsky (LP: #352226)
    - Branch fixes gwibber icon is broken on the right
      side, thanks Vish. (LP: #655159)
    - start gwibber-service anytime the client needs it, not just for
      service operations
    - dropped print statement used for debugging scrolling
 -- Ken VanDine <email address hidden> Wed, 13 Oct 2010 15:19:46 -0400

Changed in gwibber (Ubuntu Maverick):
status: Fix Committed → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

copied to natty as well.

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
needlez6 (needlez6) wrote :

This issue isn't fixed! I am running Gwibber 2.32.0.2-0 and ubuntu 10.10. I try to post to facebook and then check facebook and my post doesn't go through. Also I can only add a facebook account a random times. Twitter updates fine, but facebook doesn't at all, and when posting to someone else's facebook, it shows @username: when i comment to a previous post. Not sure the exact terminal issue. But i will post it when i find it, and try to help fix this issue if can find anything about why its happening. Thanks to the whole ubuntubugsquad!

Revision history for this message
Omer Akram (om26er) wrote :

needlez6 thats bug 614742

Revision history for this message
frizzle21 (frederik-nnaji) wrote : Re: [Bug 541831] Re: posting a comment on facebook does not update or add the comment to the post reply thread

how about making Gwibber a "Stream Viewer" until the posting features
actually work?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Bug attachments