2.29.1 crash on start

Bug #520278 reported by godavid on 2010-02-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned

Bug Description

~:gwibber

Updating...
Updating...
Traceback (most recent call last):
  File "/usr/bin/gwibber", line 62, in <module>
    client.Client()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 433, in __init__
    self.w = GwibberClient()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 53, in __init__
    self.setup_ui()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 140, in setup_ui
    self.stream_view.set_state(self.model.settings["streams"] or DEFAULT_SETTINGS["streams"])
  File "/usr/lib/python2.6/dist-packages/gwibber/gwui.py", line 397, in set_state
    self.update()
  File "/usr/lib/python2.6/dist-packages/gwibber/gwui.py", line 385, in update
    self.message_view.render([self.navigation.selected_stream["view"]])
  File "/usr/lib/python2.6/dist-packages/gwibber/gwui.py", line 660, in render
    view._fetch()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 881, in _fetch
    data = self.view._exec(self.options)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 766, in _exec
    resp, data = self.resource.get(**self._encode_options(options))
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 978, in get
    return self._request('GET', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1029, in _request
    raise ResourceNotFound(error)
couchdb.client.ResourceNotFound: ('not_found', 'missing_named_view')

After that I start gwibber as root and its worked. I use 64 bit karmic with 2.6.32 kernel.

AlexHofbauer (alex-derhofbauer) wrote :

I wanted to confirm this issue. Testing with latest trunk I can't start gwibber-service.

Updating...
Traceback (most recent call last):
  File "/usr/bin/gwibber-service", line 77, in <module>
    message_monitor = dispatcher.MessagesMonitor()
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 219, in __init__
    util.couch.exclude_databases(["gwibber_messages"])
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/util/couch.py", line 113, in exclude_databases
    for x in db.execute_view("ubuntu_one_pair_record"):
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 871, in __iter__
    for row in self.rows:
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 893, in rows
    self._fetch()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 881, in _fetch
    data = self.view._exec(self.options)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 766, in _exec
    resp, data = self.resource.get(**self._encode_options(options))
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 978, in get
    return self._request('GET', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1029, in _request
    raise ResourceNotFound(error)
couchdb.client.ResourceNotFound: ('not_found', 'missing')

AlexHofbauer (alex-derhofbauer) wrote :

I was able to investigate further and found out, that ”exclude_databases“ wants to do something (related to ubuntu one) that is not available in Debian. Also, I now think my problem is not related to the reporter's, so please excuse the noise.

Workaround: Commenting out ”util.couch.exclude_databases(["gwibber_messages"])“ solves the issue for me.

Ryan Paul (segphault) wrote :

@AlexHofbauer: the bug you are encountering has already been fixed in trunk and is unrelated to the bug described in this report.

Omer Akram (om26er) wrote :

Can you please confirm if this is still an issue?

Changed in gwibber:
status: New → Incomplete
Omer Akram (om26er) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in gwibber:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers