Gwibber stops working after suspending

Bug #518550 reported by Clemens Koppensteiner on 2010-02-07
104
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Ken VanDine
gwibber (Ubuntu)
Medium
Ken VanDine

Bug Description

After suspending and waking up the computer, starting gwibber (from daily-ppa) only produces the following error:

Updating...
Traceback (most recent call last):
  File "/usr/bin/gwibber", line 62, in <module>
    client.Client()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 426, in __init__
    self.w = GwibberClient()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 34, in __init__
    if len(json.loads(self.service.GetAccounts())) == 0:
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.socket.error: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 397, in GetAccounts
    for account in self.accounts.get_records(COUCH_TYPE_ACCOUNT, True):
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 318, in get_records
    exists = self.view_exists(view_name, design_doc)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 265, in view_exists
    view_container = self.db[doc_id]["views"]
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 316, in __getitem__
    resp, data = self.resource.get(id)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 978, in get
    return self._request('GET', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1014, in _request
    resp, data = _make_request()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1009, in _make_request
    body=body, headers=headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 1068, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 872, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 849, in _conn_request
    conn.connect()
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 733, in connect
    raise socket.error, msg
error: [Errno 111] Connection refused

To get it working again I have to manually kill gwibber-service.

This is from 2.29.1~bzr561-0ubuntu2~daily1~karmic

William Wolf (throughnothing) wrote :

I have the exact same issue.

Jorge Castro (jorge) wrote :

It shows a greyed out text area for me.

Changed in gwibber:
status: New → Confirmed
assignee: nobody → Ken VanDine (ken-vandine)
Matthias Rosenkranz (rose) wrote :

Same as Jorge here. Greyed out text area and additionally a greyed out Refresh entry in the Gwibber menu.

Changed in gwibber:
milestone: none → 2.30.0
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Medium
milestone: none → ubuntu-10.04-beta-1
status: New → Confirmed
Omer Akram (om26er) on 2010-03-03
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
Changed in gwibber:
status: Confirmed → Fix Committed
Omer Akram (om26er) on 2010-03-05
Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed

At least for me the problem is still there in the current daily (2.29.91~bzr651-0ubuntu1~daily1~karmic) on ubuntu karmic.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.29.91-0ubuntu1

---------------
gwibber (2.29.91-0ubuntu1) lucid; urgency=low

  * new upstream release 2.29.91
    - fixed a bug that prevented mentions/replies to get added to the
      messaging indicator
    - added more debug level logging
    - Fixed raising the client via dbus, missed a variable rename
    - Added signatures to the URLShorten dbus methods, fixes (LP: #517723)
    - URL shortening should be async (LP: #521974)
    - don't fail if desktopcouch is slow to start
    - Make "Name" more descriptive, it is displayed on UNE and in
      GNOME Shell (LP: #522180)
    - Fixed calls to print_exc that failed
    - Gwibber stops working after suspending (LP: #518550)
    - Fixed notifications for mentions only (LP: #528270)
    - Set the autostart gconf key if it wasn't set at all before
    - Internationalization fixed from David Planella (LP: #520462)
    - use human readable time string in save to tomboy (LP: #532730)
    - imported translations from LP
    - Moved the init_design_doc method call to MessageMonitor, this fixes a
      bug loading the design document before it is created
    - fixed a problem with configuring accounts spawning two services
    - check to see if gwibber-service is already running before starting
  * debian/gwibber.desktop
    - Make gwibber-service autostart with a delay of 60s if accounts are
      configured
 -- Ken VanDine <email address hidden> Fri, 19 Feb 2010 16:42:07 -0500

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released
Omer Akram (om26er) on 2010-03-08
Changed in gwibber:
status: Fix Committed → Fix Released
Giovanni Go (dreamnid) wrote :

I think I still have this problem. Using Ubuntu 9.10 AMD64

Since gwibber 2.3 doesn't have a notification icon, I always forget to minimize rather than exiting. So when I try to restart gwibber, I get the same error log as Caramdir

dreamnid@dreamnid-desktop:~$ gwibber

** (gwibber:1409): WARNING **: Trying to register gtype 'WnckWindowState' as flags when in fact it is of type 'GEnum'

** (gwibber:1409): WARNING **: Trying to register gtype 'WnckWindowActions' as flags when in fact it is of type 'GEnum'

** (gwibber:1409): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as flags when in fact it is of type 'GEnum'
Updating...
Traceback (most recent call last):
  File "/usr/bin/gwibber", line 67, in <module>
    client.Client()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 442, in __init__
    self.w = GwibberClient()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 41, in __init__
    if len(json.loads(self.service.GetAccounts())) == 0:
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.socket.error: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 473, in GetAccounts
    for account in self.accounts.get_records(COUCH_TYPE_ACCOUNT, True):
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 318, in get_records
    exists = self.view_exists(view_name, design_doc)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 265, in view_exists
    view_container = self.db[doc_id]["views"]
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 316, in __getitem__
    resp, data = self.resource.get(id)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 978, in get
    return self._request('GET', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1014, in _request
    resp, data = _make_request()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1009, in _make_request
    body=body, headers=headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 1068, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 872, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 849, in _conn_request
    conn.connect()
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 733, in connect
    raise socket.error, msg
error: [Errno 111] Connection refused

Filename: pool/main/g/gwibber/gwibber_2.31.1~bzr694-0ubuntu1~daily1~karmic_all.deb

I also put my computer to sleep often.

Kevin Guertin (leonivek) wrote :

I, too, still get this issue and same connection refused error after suspending my computer with the daily build of Gwibber on Karmic 64-bit.

Evan Huus (eapache) wrote :

I am experiencing exactly this bug on a fresh install of Lucid Final x64. Since two other people have also reported that this bug still affects them, I am reopening it. Please let me know if there is any other information I can provide to help fix this issue.

Changed in gwibber (Ubuntu):
status: Fix Released → Confirmed
jon bystedt (jonbystedt) wrote :
Download full text (6.5 KiB)

Ok, this is weird. If I suspend once, when I return I get errors as above, mostly:

** (gwibber:2675): WARNING **: Trying to register gtype 'WnckWindowState' as enum when in fact it is of type 'GFlags'

** (gwibber:2675): WARNING **: Trying to register gtype 'WnckWindowActions' as enum when in fact it is of type 'GFlags'

** (gwibber:2675): WARNING **: Trying to register gtype 'WnckWindowMoveResizeMask' as enum when in fact it is of type 'GFlags'
Removing stale, deceptive pid file.
Apache CouchDB has started, time to relax.
Browse your desktop CouchDB at file:///home/jon/.local/share/desktop-couch/couchdb.html
Updating...
Traceback (most recent call last):
  File "/usr/bin/gwibber", line 67, in <module>
    client.Client()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 447, in __init__
    self.w = GwibberClient()
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 41, in __init__
    if len(json.loads(self.service.GetAccounts())) == 0:
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Python.socket.error: Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.6/dist-packages/gwibber/microblog/dispatcher.py", line 491, in GetAccounts
    for account in self.accounts.get_records(COUCH_TYPE_ACCOUNT, True):
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 482, in get_records
    exists = self.view_exists(view_name, design_doc)
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 429, in view_exists
    self.with_reconnects(self.db.__getitem__, doc_id)["views"]
  File "/usr/lib/python2.6/dist-packages/desktopcouch/records/server_base.py", line 164, in with_reconnects
    return func(*args, **kwargs)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 316, in __getitem__
    resp, data = self.resource.get(id)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 978, in get
    return self._request('GET', path, headers=headers, **params)
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1014, in _request
    resp, data = _make_request()
  File "/usr/lib/pymodules/python2.6/couchdb/client.py", line 1009, in _make_request
    body=body, headers=headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 1129, in request
    (response, content) = self._request(conn, authority, uri, request_uri, method, body, headers, redirections, cachekey)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 901, in _request
    (response, content) = self._conn_request(conn, request_uri, method, body, headers)
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 875, in _conn_request
    conn.connect()
  File "/usr/lib/pymodules/python2.6/httplib2/__init__.py", line 750, in connect
    raise socket.error, msg
error: [Errno 111] Connection refused

But when I suspen...

Read more...

Omer Akram (om26er) wrote :

Thanks for the bug report this particular bug has already been report but feel free to report any other bugs you may find.

Tim Fisken (tim2) on 2010-09-09
Changed in gwibber:
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers