Large font size, cannot be changed or overridden

Bug #460069 reported by Anthony Hook on 2009-10-24
This bug report is a duplicate of:  Bug #252640: [wishlist] Needs font size/selection. Edit Remove
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Ken VanDine
gwibber (Ubuntu)
Low
Ken VanDine

Bug Description

Version: 2.0.0 as included in Karmic has quite a large font and cannot be overridden by Preferences -> Syle -> Override checkbox, there is no change to font size even after Gwibber has been restarted.

Jordan Hall (jordan-hall) wrote :

This issue affects me also. No changes within the Preferences dialog effect the size of the font.

Jordan Hall (jordan-hall) wrote :

Just fixed this so that it complies with the default system font size. Please test the patch.

Jordan Hall (jordan-hall) wrote :

Here's a regular .deb which includes the patch if you want to help test without downloading the source and such.

Changed in gwibber:
status: New → Confirmed
summary: - Font size cannot be changed or overridden
+ Large font size, cannot be changed or overridden
Scott Kitterman (kitterman) wrote :

Uploaded for Ubuntu. I did edit your changelog some, so please have a look at that. Thank you for your contribution to Ubuntu.

Changed in gwibber (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.0.0~bzr476-0ubuntu2

---------------
gwibber (2.0.0~bzr476-0ubuntu2) karmic; urgency=low

  * adjusted font size so it stays with system font size rather than having a
    +2pt offset (LP: #460069)

 -- Jordan Hall <email address hidden> Sun, 25 Oct 2009 00:07:39 +0100

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released

I discovered that on 15/08/2009 and it was an extremely obvious error (I'm only a high school student and could fix it in one minute), so it's very funny it took 2 months for somebody else to realize that. Are we the only two Gwibber users who care about desktop coherence?
http://andrealazzarotto.com/2009/08/15/gwibber-aggiornato-ed-il-bug-della-dimensione-dei-font/

Jordan Hall (jordan-hall) wrote :

Scott, thanks for uploading, I'll remember to include the LP bug number next time.

Lazza, it was certainly a very simple fix. I've recently started using gwibber, but noticed the font issue. For a very minor change, it certainly improves the aesthetics of the application and makes it mesh more with the rest of the desktop.

Alexander Sack (asac) wrote :

Jordan, can you please suggest a merge for this to the packaging branch. did anyone from the gwibber team review this?

Alexander Sack (asac) wrote :

we definitly need a merge request for this packaging change. please replay and requeset a merge. thx

Alexander Sack (asac) wrote :

problem here is that this overwrites an upstream decision without explicitly checking why this was done and what kind of regressions this could have ...

Alexander Sack (asac) wrote :

this didnt really fix the bug. just adjusted a font offset, so you still couldnt change it in UI ...

uploaded ubuntu3 that backs it out as this should be done upstream ... and rather fixed properly (not only the offset)

Changed in gwibber (Ubuntu):
status: Fix Released → Confirmed
Alexander Sack (asac) wrote :

here are two bugs: a) big font due to offset -> this should be done by using the proper document-font without offset

b) font setting in UI not honoured -> this should be fixed by using the font size from the font UI if its set and if its not set, fallback to the document font setting.

Changed in gwibber (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged

I have the same problem with Epiphany webkit themes. I think is a bug related to Webkit and GTK, once Gwibber uses Webkit.

sensory (ivtephx) wrote :

Still have this font problem using 2.0.0~bzr478-0ubuntu2~daily1.

Maxmalin (slocomber) wrote :

Same problem here, and I'm using 2.0.0~bzr476-0ubuntu3 on Karmic (fresh install).

sensory (ivtephx) wrote :

Had this problem for the past 2 weeks.

Maxmalin (slocomber) wrote :

Checked today, issue solved itself.
... maybe an update in webkit/GTK libraries?

sensory (ivtephx) wrote :

2.0.0~bzr476-0ubuntu3 still has this problem.

As well with 2.0.0~bzr478-0ubuntu2~daily1.

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
status: Triaged → Confirmed
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber:
status: Confirmed → Fix Committed
Omer Akram (om26er) wrote :

This is fixed in the development release of gwibber.

Changed in gwibber:
status: Fix Committed → Fix Released
Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers