gwibber crashed with AttributeError in join()

Bug #446661 reported by Chris Coulson on 2009-10-08
144
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ken VanDine
gwibber (Ubuntu)
High
Ken VanDine
Karmic
High
Ken VanDine

Bug Description

Binary package hint: gwibber

I've just updated to the latest version of glom now, and this one still crashes repeatedly (but it's a new crash now). All I need to do is open it from the indicator, the window appears, but I get repeated crash reports for the whole time it is open, and no information from my Facebook account is ever displayed

ProblemType: Crash
Architecture: amd64
Date: Thu Oct 8 21:04:33 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gwibber
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: gwibber 2.0.0~bzr465-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-12.40-generic
PythonArgs: ['/usr/bin/gwibber']
SourcePackage: gwibber
Title: gwibber crashed with AttributeError in join()
Uname: Linux 2.6.31-12-generic x86_64
UserGroups: adm admin cdrom chrisandjo-rw dialout lpadmin plugdev sambashare schroot shared-rw vboxusers vmware

Chris Coulson (chrisccoulson) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Foppe Hemminga (foppe) wrote :

... Reports identical behavior, also on amd64 / Ubuntu 9.10.
When this did work until yesterday it had this oddity: I could only view (Twitter) messages after invoking the sidebar from View and select messages from there.
If you decide this is unrelated please ignore this message.

Foppe Hemminga (foppe) wrote :

Traceback added.

Changed in gwibber (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in gwibber (Ubuntu Karmic):
assignee: nobody → Ken VanDine (ken-vandine)

Architecture: amd64
DistroRelease: Ubuntu 9.10
Package: gwibber 2.0.0~bzr465-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-12.41-generic
Uname: Linux 2.6.31-12-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Ken, this is effecting robbiew, so he can help test fixes if needed. Thanks.

Ken VanDine (ken-vandine) wrote :
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
status: New → Fix Committed
Ken VanDine (ken-vandine) wrote :

A work around would be to run:

  gconftool-2 --unset /apps/gwibber/preferences/theme

Nizar Kerkeni (nizarus) wrote :

I confirm the work around of post #9

André Gondim (andregondim) wrote :

I confirm too, the work around of post #9

Leonel Nunez (leonelnunez) wrote :

I confirm too, the work around of post #9

Aaron Caskey (netwomble) wrote :

I confirm too, the work around of post #9

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.0.0~bzr466-0ubuntu1

---------------
gwibber (2.0.0~bzr466-0ubuntu1) karmic; urgency=low

  * New upstream snapshot - r466
    - Fixed theme handling when the theme configured doesn't
      exist (LP: #447733) and (LP: #446661)

 -- Ken VanDine <email address hidden> Fri, 09 Oct 2009 22:29:29 -0400

Changed in gwibber (Ubuntu Karmic):
status: Confirmed → Fix Released
Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers