Retweeting fails in 2.0

Bug #423026 reported by James Ogley on 2009-09-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Ken VanDine

Bug Description

Selecting ReTweet from the menu on a message populates the input field as I would expect but when I hit enter and the field clears, the message fails to be posted.

Sadly nothing of use appears at the commend line even with -dv.

This is solved for me in Build401.

Changed in gwibber:
status: New → Fix Released
James Ogley (riggwelter) wrote :

Reopened as I have to differ with curson, I still see it in 401 - any way of getting more debugging info?

Changed in gwibber:
status: Fix Released → New
Ryan Paul (segphault) wrote :

James: Do you get anything out at the terminal in the gwibber-daemon process? That's probably where the error message would show up rather than the terminal output of the gwibber client process. Let me know if you need help checking that.

James Ogley (riggwelter) wrote :

DEBUG:gwibber:Queueing Op: <send_thread:twitter>
DEBUG:gwibber:Performing Op: <send_thread:twitter>
DEBUG:gwibber:Failed Op: <send_thread:twitter> - Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/__init__.py", line 128, in run
    messages = self.perform_operation(opdata)
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/__init__.py", line 95, in perform_operation
    if not o.operation.return_value: o.perform_operation()
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/__init__.py", line 76, in perform_operation
    return self.function(*(args or self.args))
TypeError: send_thread() takes exactly 3 arguments (2 given)

James Ogley (riggwelter) wrote :

I looked into this and the problem is that a ReTweet counts as a thread but the code wasn't honouring that - one line change and it's fixed - patch attached!

Emilio (turl) on 2009-09-14
Changed in gwibber:
status: New → Confirmed
Changed in gwibber:
status: Confirmed → Fix Committed
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers