Bring back support for RSS/Atom feeds

Reported by Martin Gamache on 2009-09-01
468
This bug affects 101 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned

Bug Description

Since the 2.0 update of Gwibber, I cannot use it anymore to follow RSS/Atom feeds. There is no RSS/Atom item in the Create menu.

 Is this normal? Has the team decided to remove that feature, or will it be back in an upcoming update?

Related branches

Martin Gamache (martin-gamache) wrote :

Jorge, Komputes told me to send you this "bug", you were apparently the one to contact about this.

Gwibber is a great tool, but without the rss feed option, it's less interesting.

Regards

Ben (ben2talk) wrote :

Messages pass the notification window before they ever reach Gwibber - so I must concur, Gwibber was my first choice for several feeds - offering me a link to click and have it open sharply in my webkit browser rather than having to open up my feed aggregator and find it there.

Andrew M (primary-edw) wrote :

Vote +1 to have this featue back

Changed in gwibber:
status: New → Confirmed
komputes (komputes) wrote :

Spoke to Jorge, who confirmed that the gwibber project removed RSS, intending to re-implement it, but it never made it back into the rewrite. I was also told it is on the todo list for the project.

komputes (komputes) wrote :
Amaeth (dfoxpro) wrote :

Vote +1 to have this featue back

Jorge O. Castro (jorge) wrote :

This feature will return at some point, it just didn't make 2.0.

(Launchpad tip: Just click "Does this bug affect you?" on the top of the bug to "vote" for it, otherwise ever +1 spams everyone who is subbed to the bug)

Changed in gwibber:
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Ryan Paul (segphault)
Randall Ross (randall) wrote :

RSS support (in my humble opinion) is a great idea. Gwibber was once the "universal aggregator" and could regain that position again if RSS comes back. Hopefully soon!

Gabriel (gabriel-ggsalas) wrote :

+1

Andrew M (primary-edw) wrote :

Because I'm being impatient :) I am trying to get Gwibber to handle RSS. I modified the rss.py file to see if I could do it. Fortunately with some success :

I cannot get it to display a sensible name in the side panel. But I can now see RSS feeds!
I have attached the file for interest.

Please feel free to put into the main branch... But I am NOT a python dev of any skill. You will need to review and see where I have done things wrong.

Andrew M (primary-edw) wrote :

Oh and I had to add an rss.png to the ui/icons to work - I just copied digg.png :)

Jamal Fanaian (jamalta) wrote :

I created a branch that has the RSS functionality implemented.

Jamal Fanaian (jamalta) wrote :

Sorry, forgot to link to it.

lp:~jamalta/gwibber/bug-422602

Jamal Fanaian (jamalta) on 2009-12-30
Changed in gwibber:
status: Triaged → Fix Committed
LarryBoy327 (larryboy327) wrote :

Um... so how do I download all the files or do I only need certain ones?

Ryan Paul (segphault) wrote :

Jamal's branch is good. I'm planning to adapt his rss module to work in the latest revision of Gwibber so that we can get proper RSS support back in trunk. It's on my list of things to do.

LarryBoy327 (larryboy327) wrote :

How do I install this branch?

Stefan Hammer (j-4) wrote :

Will this bug be fixed in lucid?

Omer Akram (om26er) wrote :

I dont know exactly does this feature exist in the development release of gwibber?

Ryan Paul (segphault) wrote :

This was removed in version 2.0 and is not included in 2.3, but it will be back in version 3.0.

Changed in gwibber:
milestone: none → 3.0
status: Fix Committed → In Progress
summary: - RSS/Atom feeds are no longer accessible through Gwibber 2.0
+ Bring back support for RSS/Atom feeds
Randall Ross (randall) wrote :

Will this make it in soon? Was hoping *really hard* for inclusion in Maverick Meerkat...

Feanor's Curse (suepke) wrote :

I wrote a small python script which displays a note via libnotify when new feeds are available. However, it does not include a display in gwibber itself, but maybe some of you might find it useful.

http://suepke.eu/rsslibnotify-my-very-first-python-script/
Comments welcome

AJenbo (ajenbo) wrote :

@Randall I belive 3.0 will be out by April.

Changed in gwibber:
milestone: 3.0 → 3.2.0
status: In Progress → Triaged
assignee: Ryan Paul (segphault) → nobody

I have written a rss+atom plugin for gwibber. It is not really tested yet as it has been written in a few days. The plugin uses the feedparser package, which supports many versions of rss and atom feeds. I'm going to implement the search operation besides the receiving of feeds.
The code is available at https://code.launchpad.net/~nils-nilsdabrock/+junk/gwibber

Please let me know when there are any problems or mistakes.

Changed in gwibber:
milestone: 3.2.0 → 3.2
Oliver B (oliver.b) wrote :

@Jamal Fanaian: Hello, I downloaded Your branch and took the rss.py , so far so good, but how do I add an 'RSS URL' ? Somehow the popup list needs to be updated to contain the 'RSS' too to be able to add RSS URLs to follow.

Changed in gwibber:
status: Triaged → Fix Released
papukaija (papukaija) wrote :

Not fixed in v.3.4. Please reopen. Thanks.

@Tobias: Please don't touch at the bug's status without providing an explanation. Thanks.

papukaija (papukaija) wrote :

I've reopened this bug since this is not fixed in v.3.4 unless I'm blind.

affects: gwibber → null
Changed in null:
milestone: 3.2 → none
Changed in gwibber:
status: New → Confirmed
Pedro Azevedo (pazevedo) wrote :

Bring back Rss/Atom feeds support.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers