No notifications in trunk

Bug #421021 reported by James Ogley on 2009-08-29
64
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Gwibber
Medium
Ken VanDine

Bug Description

Since switching to the 2.0.0 trunk, I no longer get notifications on new messages, even though Display bubbles is enabled.

Niko Wenselowski (nik0) wrote :

I can confirm this for version 2.0 (bzr 394) from the daily PPA.

Nizar Kerkeni (nizarus) on 2009-09-01
Changed in gwibber:
status: New → Confirmed

Happens here too

Juan Simón (simonbcn) wrote :

Same problem.

Ubuntu 9.04 32bits

$ apt-cache policy gwibber
gwibber:
  Instalados: 2.0.0~bzr433-0ubuntu2~daily1~jaunty
  Candidato: 2.0.0~bzr433-0ubuntu2~daily1~jaunty
  Tabla de versión:
 *** 2.0.0~bzr433-0ubuntu2~daily1~jaunty 0
        500 http://ppa.launchpad.net jaunty/main Packages
        100 /var/lib/dpkg/status
     0.8-0ubuntu5 0
        500 http://archive.ubuntu.com jaunty/universe Packages

$ uname -a
Linux ubuntu-desktop 2.6.30.5-candela #1 SMP Tue Aug 25 03:04:37 CEST 2009 i686 GNU/Linux

This is a essential function of a twitter client, if this no works... This client is almost unuseful! :-(

Leonel Nunez (leonelnunez) wrote :

Same problem with Karmic

Gwibber version 2.0.0~bzr436

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Medium
status: Confirmed → Fix Committed
Aldo Latino (aldolat) wrote :

Just updated to 2.0.0~bzr438-0ubuntu2~daily1~jaunty but notification bubbles aren't still present.

James Ogley (riggwelter) wrote :

Updated to bzr445 which is latest trunk and has this work but it fails:

DEBUG:gwibber:Starting scheduled operations
Exception in thread Thread-5:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 522, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/site-packages/gwibber/microblog/__init__.py", line 204, in run
    if not k in self.messages: self.new_message(v)
  File "/usr/lib/python2.6/site-packages/gwibber/server.py", line 215, in new_message
    self.show_notification_bubble(message)
  File "/usr/lib/python2.6/site-packages/gwibber/server.py", line 248, in show_notification_bubble
    n = gintegration.notify(message["sender"], body, image, ["reply", "Reply"], expire_timeout)
  File "/usr/lib/python2.6/site-packages/gwibber/gintegration.py", line 47, in notify
    notification.add_action(action)
TypeError: NotifyNotification.add_action requires at least 3 arguments

James Ogley (riggwelter) wrote :

Added two null arguments to that line - it no longer hangs but still no notifications.

Ken VanDine (ken-vandine) wrote :

Fixed in trunk, we don't have a method for handling the action anyway so I removed it.

Changed in gwibber:
status: Fix Committed → Fix Released
Jacob Henderson (lmeditato) wrote :

Still no notifications for jaunty.

Jacob Henderson (lmeditato) wrote :

Sorry, lucid.

Ken VanDine (ken-vandine) wrote :

Please attach the log file, ~/.cache/gwibber/gwibber.log

Thanks!

Jacob Henderson (lmeditato) wrote :

Here it is. At first glance, gwibber-service looks like it's having trouble with parsing information from Facebook.

Ken VanDine (ken-vandine) wrote :

Looking at the log, it looks like it is sending notifications. Or at least trying to:

2010-03-26 22:03:38,957 - Gwibber Dispatcher - DEBUG - Checking message 500404500_107868949241529 timestamp (2010-03-26 22:02:54.00) to see if it is newer than 2010-03-26 21:53:38.95
2010-03-26 22:03:38,958 - Gwibber Dispatcher - DEBUG - Message 500404500_107868949241529 newer than 2010-03-26 21:53:38.95, notifying

Can you look at the notify-osd log in ~/.cache/notify-osd.log and see if there is anything that looks gwibber related?

Jacob Henderson (lmeditato) wrote :

No, there is nothing gwibber related.

Jacob Henderson (lmeditato) wrote :

But yeah, after some amount of normal activity (sleeps, restarts, and internet browsing), notifications always cease from Facebook. I can usually keep getting Twitter notifications long after the Facebook account stops, but this problem isn't unique to one installation. I've already tried three different Lucid Lynx installations, and this problem occurred on all three. Complete uninstallations and reinstallations, reverting to earlier versions of Gwibber, or using a daily build from launchpad all failed to solve the issue.

Jacob Henderson (lmeditato) wrote :

The Client itself will update when opened, and will post a notification if I "like" or comment on something. But it will not post notifications from the news feed, no matter what I do. I started a thread on the Ubuntu Forums confirming that I wasn't the only person with this issue.

Jacob Henderson (lmeditato) wrote :

This really is an issue. If you use Gwibber with Facebook for any length of time, you'll see it too. There is no activity in the notifyOSD logs from Gwibber regarding Facebook after a while (usually a couple of restarts). It looks like Gwibber simply doesn't persist in maintaining contact with notifyOSD when it comes to Facebook.

tags: added: gwibber notifications notify-osd
tags: removed: gwibber notifications
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments