Gwibber fails to start when GNOME has a floating point font set

Bug #383759 reported by Krzysztof Klinikowski
182
This bug affects 46 people
Affects Status Importance Assigned to Milestone
Gwibber
Fix Released
High
Unassigned
gwibber (Ubuntu)
Fix Released
Medium
Ken VanDine
Nominated for Lucid by Omer Akram

Bug Description

Hello. When you set font size on your gnome font settings like 8.5 then Gwibber getting error, because its float http://paste.jabbim.cz/3572 to resolve that you need to change self.settings.set_property("default-font-size", (int(fsize) + 2)) to self.settings.set_property("default-font-size", (eval(fsize) + 2)) and thats all ;)

Revision history for this message
Krzysztof Klinikowski (kkszysiu) wrote :
Changed in gwibber:
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Giorgio (uastasi) wrote :

I had the same problem too.
Switching from int to eval makes gwibber work.

Revision history for this message
Chris Jones (cmsj) wrote :

fwiw, without the patch, Gwibber fails to start with the traceback:

Traceback (most recent call last):
  File "./bin/gwibber", line 57, in <module>
    client.Client()
  File "/home/cmsj/code/scratch/gwibber/gwibber/client.py", line 106, in __init__
    self.w = GwibberClient()
  File "/home/cmsj/code/scratch/gwibber/gwibber/client.py", line 186, in __init__
    self.setup_ui()
  File "/home/cmsj/code/scratch/gwibber/gwibber/client.py", line 250, in setup_ui
    self.content_view = gwui.MessageStreamView(self.preferences["theme"], self)
  File "/home/cmsj/code/scratch/gwibber/gwibber/gwui.py", line 259, in __init__
    self.load_fonts(resources.get_font())
  File "/home/cmsj/code/scratch/gwibber/gwibber/gwui.py", line 270, in load_fonts
    self.settings.set_property("default-font-size", (int(fsize) + 2))
ValueError: invalid literal for int() with base 10: '6.5'

summary: - bug with font size as int
+ Gwibber fails to start when GNOME has a floating point font set
Revision history for this message
Alexander Sack (asac) wrote :

gwibber not starting is high importance. fix committed to trunk (rev 472)

Changed in gwibber:
importance: Medium → High
status: Triaged → Fix Committed
Revision history for this message
Omer Akram (om26er) wrote :

It has been a while since its fixed.

Changed in gwibber:
status: Fix Committed → Fix Released
Changed in gwibber:
status: Fix Released → Confirmed
Omer Akram (om26er)
Changed in gwibber:
status: Confirmed → Fix Released
Revision history for this message
Chow Loong Jin (hyperair) wrote :

The fix isn't in trunk.

Revision history for this message
Omer Akram (om26er) wrote :

a new bug report maybe would be better?

Revision history for this message
Caracuri (caracuri) wrote :

for me this bug is not fixed

Revision history for this message
Caracuri (caracuri) wrote :

Also self.web_settings.set_property("default-font-size", int(font_size)) has to be converted in eval :D

Revision history for this message
Mikel Pérez (mikelpr) wrote :

Was this fix really released?
Still not working, not in the default installation of Lucid, not even in the gwibber-dialy PPA!!!

Revision history for this message
mrgorefest (mrgorefest) wrote :

I have the same problem!

Revision history for this message
Omer Akram (om26er) wrote :
Changed in gwibber:
status: Fix Released → Fix Committed
Omer Akram (om26er)
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Revision history for this message
Omer Akram (om26er) wrote :

assigned Ken as he is the one who fixed it.

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Revision history for this message
Omer Akram (om26er) wrote :

this bug is fixed in gwibber 2.31.3 in Maverick. the problem will also be fixed in Lucid when gwibber 2.30.2 will be released

Changed in gwibber:
status: Fix Committed → Fix Released
Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers