[wishlist] Ability to start Gwibber minimized

Bug #325051 reported by Greg Grossmeier on 2009-02-03
132
This bug affects 26 people
Affects Status Importance Assigned to Milestone
Gwibber
Wishlist
Unassigned

Bug Description

Would be nice to have a command line option (say "-m") that will start gwibber in a minimized mode.

Use Case:
For users who wish to have Gwibber auto-started when they login. They may prefer it to start minimized.

Changed in gwibber:
importance: Undecided → Wishlist
status: New → Confirmed
Jonathan Lumb (jonolumb) wrote :

I would really appreciate it if Gwibber has an option (either command line or in the settings) to start the application in minimized mode. I use Gwibber all the time on my laptop but it's annoying having it pop up on the desktop as soon as the computer is turned on. I'm sure that this would be fairly simple to implement and would be a feature that would be used by many people.

Thanks!

doesnt /apps/gwibber/preferences/minimize_to_tray do it ?

Prinice Neyland (pneyland) wrote :

the key /apps/gwibber/preferences/minimize_to_tray
is for the 'minimize to tray on close' option.

Jonathan Lumb (jonolumb) wrote :

Yup - Prinice is right... there is still no option which is specific for minimizing gwibber when the computer starts up.

Jason Allen (jallen) wrote :

Agree. I would like to see this too, as it's most annoying!

Lucas Rocha (lucasr) wrote :

Here's a quick patch to implement this.

Jonathan Lumb (jonolumb) wrote :

Look forward to seeing this implemented soon :-)

Prinice Neyland (pneyland) wrote :

I applied the patch and it works for me. I do get an error message when I display Gwibber for the first time after it starts minimized.

prinice@neptune:~/projects/gwibber/gwibber$ ./bin/gwibber -s
Traceback (most recent call last):
  File "/home/prinice/projects/gwibber/gwibber/gwibber/client.py", line 474, in on_toggle_window_visibility
    self.move(*self.last_position)
AttributeError: 'GwibberClient' object has no attribute 'last_position'

I edited Lucas's patch to correct this error.

Reloweb (reloweb) wrote :

I applied this patch with

sudo patch -i ~/silent-option-v2.patch

but it fails...

sathyz (sathyz) wrote :

Here goes version 3 of the patch :)

* line number for GwibberClient is updated.
* set default silent=False for GwibberClient constructor also.

Reloweb (reloweb) wrote :

How can I patch Gwibber with the new patch?

I couldn't get the patch to apply using patch -i (/bin/gwibber not a regular file error?). I applied it by hand and it works as expected.

Now it is pushed up to lp:gwibber.

http://bazaar.launchpad.net/~gwibber-committers/gwibber/trunk/revision/355

Thanks!

Uglycharly (caponcet) wrote :

If I patch I will need to re-patch at each update ?... Can't implement gwibber on my linux stations because of this !
Then i tried A docking tool (alltray) to minimize gwibber, but I get two icons plus the "mail" that share pidgin and gwibber ! It's not user-friendly nor esthetic for community managers who don't want to understand technics !

Tom Verdaat (tom-verdaat) wrote :

It seems that (at least for Lucid) Gwibber is split in at least two packages:
- gwibber: the GTK+ gui
- gwibber-service: the application backend

Starting gwibber-service seems to do what you're looking for, so you can add to start at login.

This means that what's really wrong is that the gwibber preverences window provides an option named "start service at login". This is confusing. I propose this be changed to two (mutually exclusive) options:
1) Start gwibber minimized at login (adding gwibber-service to start at login)
2) Open gwibber at login (adding gwibber to start at login)

Omer Akram (om26er) wrote :

we can call this issue fixed since gwibber-service can start on startup

Changed in gwibber:
status: Confirmed → Fix Released
pberndt (phillip-berndt) wrote :

What I'd expect from an autostart feature was to have the main application start automatically, minimized to tray. So that I could open it by clicking on the icon. The current solution does not provide me with that feature. Instead, I get libnotify-notifications for each new Tweet. If I want to do anything with them, such as retweeting or replying, I first have to search through the menu to start Gwibber GUI manually.

Please reopen this bug and implement the suggested command line option!

(I know that the gwibber service integrates with the indicator applet. I don't use it and I don't want to. So I'd really love to have a "start minimized" option.. ☺)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions