[wishlist] No quick way to switch sending to different accounts

Bug #325046 reported by Rob Connolly on 2009-02-03
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Gwibber
Wishlist
Ryan Paul

Bug Description

There is currently no UI to enable a quick switch of which accounts get posted to, it currently must be done by editing the settings individually for different accounts.

It'd be great to have some UI underneath the message input field to enable quich selection of which account(s) a posted message is sent to.

Ryan Paul (segphault) wrote :

You can toggle which accounts are actively sending by using the checkboxes in the right-click context menu for the input textbox. This feature clearly has discoverability issues because it seems like I'm the only person who knows that it exists.

Does anybody have any proposals for specific UI enhancements that can be implemented to address this? Sil was working on making a protocol icon toolbar and I think that it might be wise to evaluate that approach again. In order for it to really work, I think we need good icons for each of the supported services.

Ryan besides the discoverability it takes to long to just select a SINGLE account if a user has many accounts, and more trouble to select all (or part) again.
It should be easier to do one-time select account.
Unfortunately I have no suggestion on how to implement this in the UI.

Maybe adding an extra checkbox to Account -> SERVICE -> Send here only
and some way to re-select all previous accounts, by maybe un-selecting the previous box (ok not again discoverable).

On another note, and may require further discussion from all devs, but is it just me, or is Gwibber just begining to have way to many buttons all over the place?

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Andreas Streim (webmail-streim) wrote :

Hmmm... it might be a workaround for some people, but it is not perfect.

For example I have three accounts. Usually I want to send my updates to the same two, so they are checked.

Sometimes I would like to send to the third one, not the other two. I can check the third one, but I have to manually uncheck the first two. And after sending I have to do the same again. It's not very comfortable, is it?

Fabian A. Scherschel (fabsh) wrote :

I totally agree with the original reporter as well. This should be set to feature request though, right?

Rob Connolly (rob-webworxshop) wrote :

Yeah, I agree (this was originally intended as a feature request).

Perhaps some form of account grouping would solve the problem:

- Accounts could be placed into multiple posting groups (so one account can be in more than one group).
- UI in the main window would allow selection of one group (radio buttons?)
- Messages are sent to all accounts in the selected group.

The approach is more complicated and I'm not sure how implementable it would be, but it seems like a solution to me.

Changed in gwibber:
importance: Undecided → Wishlist
zzz (oldman-deactivatedaccount) wrote :

I had meant to write a blueprint for this a while back, but after filling in the form firefox-3.2 decided to crash and I lost the content and the motivation to post it :-)

I'd like to suggest a solution to this problem. We continue with the input form at the foot of Gwibber's main UI. This has the existing context menu to switch which accounts it posts to and we continue to have this as the only place to post to multiple protocols in one hit. We then add a modal dialog entry box, similar to Pidgin's 'New Instant Message (CTRL+M)' dialog, which is invoked either by key shortcut or from the Gwibber menu. This then has a message input box and an account combo box to choose which account this one time message is sent to (see screenshot for Pidgin example, think of 'Name' as the message entry field and 'Account' as the protocol choice)

By adding this we cover the common use cases of 'post to lots of accounts' as well as the use case of 'just post to one particular account'. The only thing we fail to cover is the 'post to 2 out of my 4 accounts', but I'm personally happy to live with that to maintain usability :-)

Jorge Castro (jorge) on 2009-02-21
Changed in gwibber:
status: New → Confirmed
Ragnarokangel (ra-mailinator) wrote :

Why not just implement it in the way that ping.fm does in their web service? When adding accounts ask for them to be added to lists then add a drop down box above/below the input area of the client that selects which list to post to?

Mathias Menzer (mfm) wrote :

Suggestion: A small bar below the input field with icons representing the various services that can receive messages from Gwibber (The icons may look like the Twitter / identi.ca / Facebook / ... icons that are found throughout the web). hovering the mouse over an icon shows a the username for the appropiate service. Clicking on the icon enables or disables sending of messages to this service. Enabled services are show in color, disabled one are grayed out.

That would be UI experience...

Martin Pool (mbp) wrote :
Ryan Paul (segphault) wrote :

I'm working on an experimental overhaul of the Gwibber user interface. It introduces a filtering system that will make it easier for users to switch between accounts. The following screenshot is an early prototype:
http://www.scrnshots.com/users/segphault/screenshots/168441

When the user selects a specific account in the tree, outgoing messages will automatically be sent to only that account. I also have a slimmer combox version of the account selector UI that will be available as an option. You can see both in action in this video: http://www.youtube.com/watch?v=f3v__VpSlqk

I think that this will solve the account switching problem for most users. I might also add an option for putting a checkbox for sending in the sidebar tree if there are enough people who want it. Feedback is appreciated, so feel free to share your thoughts.

Ryan me likes it much. and me can see himself there too
eheh
now for serious is this just a mockup or do u have a code branch i could test?
I love it

Ryan Paul (segphault) wrote :

I'm glad you like it! It is actual working code, but it is still extremely buggy and there are a lot of features that don't work yet (such as search and user profiles). I'm planning to put it into a branch soon.

rpcutts (rpcutts) wrote :

I like it but...
It seems like it only deals with ALL or ONE.

e.g. I couldn't post to identi.ca and Jaiku but NOT Facebook

Ryan since 1.2 trunk can either last me 4h or 4 min, your code cant be any more unstable, so feel free to upload it ASAYC to get some feedback

since you are at it, can that fix bug 335178?
and jaiku bug 383780 and bug 300746 ?

its all about _how_ you view it

Changed in gwibber:
assignee: nobody → Ryan Paul (segphault)
status: Confirmed → In Progress
Gabriel (gabriel-ggsalas) wrote :

I wish I could answer comments on my blog (wordpress.org) with Gwibber

Trochee (trochee) wrote :

I am grateful for the response at comment 1; that context-menu feature is important, and cool, but is *NOT* discoverable -- I found it here before discovering it on my own. I like the UI Mathias suggests at number 8, with the icons indicating which accounts are "live".

tags: added: usability
Trochee (trochee) wrote :

I will add that the context-menu does not report properly when retweeting or replying. should this be a separate bug?

Ryan Paul (segphault) wrote :

Gwibber now has a message target bar at the bottom of the window with toggle buttons for each account. When you are sending a reply, it will show you which account is being used for the reply and will let you cancel it by clicking the red "x" icon.

Changed in gwibber:
status: In Progress → Fix Committed
Omer Akram (om26er) wrote :

This is fixed in gwibber 2.29.91 Thanks for the bug report

Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions