[wishlist] Needs font size/selection

Bug #252640 reported by Jorge Castro on 2008-07-28
54
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Gwibber
Wishlist
Unassigned

Bug Description

It would be nice if gwibber had some app specific font settings. Right now it appears to follow my desktop setting but it would be nice to select a smaller font, etc.

Jorge Castro (jorge) on 2008-07-28
Changed in gwibber:
importance: Undecided → Wishlist
Jeff Waugh (jdub) wrote :

It would probably be good, even if you decide to add configuration gumpf for this, to default to a slightly smaller size than the default application font size.

Jeff Waugh (jdub) on 2008-09-12
Changed in gwibber:
status: New → Confirmed
Filippo Argiolas (fargiolas) wrote :

It doesn't seem to follow the current desktop or applications font settings.. I have DejaVu Sans Condensed 9 set in gnome-appearance-properties but it seems to use Sans or DejaVu Sans 10... So, IMHO it would be good enough if it would follow current application fonts settings.

Ryan Paul (segphault) wrote :

You can now configure Gwibber's default font from the preference dialog.

Changed in gwibber:
assignee: nobody → Ryan Paul (segphault)
status: Confirmed → Fix Released
James Gregory-Monk (jamgregory) wrote :

Has this fix been incorporated into a released version? I've got version 0.9.1, but I can't see the font size selection box. I've just upgraded to Fedora 11 and the font size is massive so I'd like to decrease it.

Ryan Paul (segphault) wrote :

This feature is included in 1.2.0.

Ryan Grieve (thegrieve) wrote :

Has this reverted? I see no font selection in 2.0.0

Chris Conway (cconway) wrote :

Still none (AFAICT) in 2.30.0.1

Fabián Rodríguez (magicfab) wrote :

Workaround:

From a terminal window, edit the stylesheet file for the Ubuntu theme in Gwibber:
gksudo gedit /usr/share/gwibber/ui/themes/ubuntu/main.css

Edit your file to add font size and family information, such as:

* {
  color: black;
  font-size: 8pt;
  font-family: Liberation Sans;
}

.imgbox {
  -webkit-border-radius: 5px;
}

You will need to exit Gwibber and restart it to see the changes.

To see what fonts you have available and their corresponding family names, install the gnome-specimen package and then go to Applications > Graphics > Specimen Font Previewer.

Fabián Rodríguez (magicfab) wrote :

Using the latest Gwibber in 11.04 this issue is still not solved. Can someone please set the bug status appropriately ?

Changed in gwibber:
assignee: Ryan Paul (segphault) → nobody
status: Fix Released → Confirmed
Ken VanDine (ken-vandine) wrote :

I really don't think it is a good idea to include a application specific override for the font settings. It is important to have a consistent experience across the desktop. I think if a user prefers a smaller font, they probably really want that smaller font across all applications on the desktop. Adding the complexity of another setting, which really just introduces inconsistency, would just make things more confusing.

Perhaps if there needs to be a different font setting for a different class of content, we should look at solving that desktop wide.

Changed in gwibber:
status: Confirmed → Won't Fix
Fabián Rodríguez (magicfab) wrote :

By that logic Gnome terminal, Firefox and Evolution (core apps) shouldn't have customizable font sizes. Gwibber deals with content (and potentially lots of it). I *don't* want my whole desktop to change just because I want more content in Gwibber. I agree the default should match the global prefs, but one should be able to easily customize this bit, specially in content-intensive apps.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers